diff options
author | tho3.nguyen <tho3.nguyen@lge.com> | 2025-03-29 01:00:46 +0900 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2025-03-28 10:28:13 -0700 |
commit | 65f0ffec504ccf6f61b72bf11bbbb092047d7287 (patch) | |
tree | e40fea843d72ffab3964ffe2ecaa7d2e07a906a2 /meta-multimedia | |
parent | a2a531a61b779fc666cb161be029b8ff801d2c97 (diff) | |
download | meta-openembedded-65f0ffec504ccf6f61b72bf11bbbb092047d7287.tar.gz |
libcamera: Fix build with gcc-15
Backport patch to fix the following error:
...
In file included from ../git/src/libcamera/dma_buf_allocator.cpp:9:
../git/include/libcamera/internal/dma_buf_allocator.h:66:19: error: 'uint64_t' has not been declared
66 | void sync(uint64_t step);
| ^~~~~~~~
../git/include/libcamera/internal/dma_buf_allocator.h:17:1: note: 'uint64_t' is defined in header '<cstdint>'; this is probably fixable by adding '#include <cstdint>'
...
Signed-off-by: tho3.nguyen <tho3.nguyen@lge.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-libcamera-Add-missing-stdint.h-include-to-dma_buf_al.patch b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-libcamera-Add-missing-stdint.h-include-to-dma_buf_al.patch new file mode 100644 index 0000000000..18ba353de2 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera/0002-libcamera-Add-missing-stdint.h-include-to-dma_buf_al.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 91de550243121056984e5b9b693b486860655d31 Mon Sep 17 00:00:00 2001 | ||
2 | From: Sergei Trofimovich <slyich@gmail.com> | ||
3 | Date: Sat, 28 Dec 2024 19:11:19 +0000 | ||
4 | Subject: [PATCH] libcamera: Add missing <stdint.h> include to | ||
5 | dma_buf_allocator.h | ||
6 | |||
7 | Without the change the build fails on upcoming `gcc-15` as: | ||
8 | |||
9 | In file included from ../src/libcamera/dma_buf_allocator.cpp:9: | ||
10 | ../include/libcamera/internal/dma_buf_allocator.h:66:19: error: 'uint64_t' has not been declared | ||
11 | 66 | void sync(uint64_t step); | ||
12 | | ^~~~~~~~ | ||
13 | |||
14 | Signed-off-by: Sergei Trofimovich <slyich@gmail.com> | ||
15 | Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> | ||
16 | Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> | ||
17 | Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> | ||
18 | |||
19 | Upstream-Status: Backport [https://git.libcamera.org/libcamera/libcamera.git/commit/?id=91de550243121056984e5b9b693b486860655d31] | ||
20 | --- | ||
21 | include/libcamera/internal/dma_buf_allocator.h | 1 + | ||
22 | 1 file changed, 1 insertion(+) | ||
23 | |||
24 | diff --git a/include/libcamera/internal/dma_buf_allocator.h b/include/libcamera/internal/dma_buf_allocator.h | ||
25 | index d26f8a74..13600915 100644 | ||
26 | --- a/include/libcamera/internal/dma_buf_allocator.h | ||
27 | +++ b/include/libcamera/internal/dma_buf_allocator.h | ||
28 | @@ -8,6 +8,7 @@ | ||
29 | #pragma once | ||
30 | |||
31 | #include <memory> | ||
32 | +#include <stdint.h> | ||
33 | #include <string> | ||
34 | #include <vector> | ||
35 | |||
36 | -- | ||
37 | 2.34.1 | ||
38 | |||
diff --git a/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.4.0.bb b/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.4.0.bb index ef424c84e6..3d43b4f1da 100644 --- a/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.4.0.bb +++ b/meta-multimedia/recipes-multimedia/libcamera/libcamera_0.4.0.bb | |||
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "\ | |||
11 | SRC_URI = " \ | 11 | SRC_URI = " \ |
12 | git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \ | 12 | git://git.libcamera.org/libcamera/libcamera.git;protocol=https;branch=master \ |
13 | file://0001-media_device-Add-bool-return-type-to-unlock.patch \ | 13 | file://0001-media_device-Add-bool-return-type-to-unlock.patch \ |
14 | file://0002-libcamera-Add-missing-stdint.h-include-to-dma_buf_al.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRCREV = "35ed4b91291d9f3d08e4b51acfb51163e65df8f8" | 17 | SRCREV = "35ed4b91291d9f3d08e4b51acfb51163e65df8f8" |