summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2023-11-12 21:10:28 +0300
committerKhem Raj <raj.khem@gmail.com>2023-11-12 12:18:48 -0800
commit5086a9b6d1357eb7e039e57a29b5f2bead8d5679 (patch)
tree3a79047f41f239be6b7bb1a15115aa72c2ad6fcc /meta-multimedia
parent55274f650e304074783d171a406454748b2d456e (diff)
downloadmeta-openembedded-5086a9b6d1357eb7e039e57a29b5f2bead8d5679.tar.gz
tinyalsa: upgrade 1.1.1 -> 2.0.0
- CMakeList.txt patch deleted because added to the new version. Changelog: * Miscellaneous bugs fixed. * PCM plugin support. * Add CMake build support. * Add meson build support. * tinyplay can now read from stdin. * Improved versioning support for library. * Improvements to pcm actions (prepare at open time and after overrun, etc.) * Improvements/fixes to pcm_get_htimestamp(). * Fixes for the mixer percent functions. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch46
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-fixed-compilation-error-caused-by-strncpy.patch69
-rw-r--r--meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_2.0.0.bb (renamed from meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb)7
3 files changed, 72 insertions, 50 deletions
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch
deleted file mode 100644
index 6f9c39996..000000000
--- a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From fe4f3c2a37a81201f463ff962364f014f50c9896 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 16 Dec 2019 22:58:41 -0800
4Subject: [PATCH] Use CMAKE_INSTALL_<path> instead of hardcoding bin/lib/
5 install paths
6
7Helps fix build/packaging issues on machines where default libdir is not
8lib but say lib64
9
10Upstream-Status: Submitted [https://github.com/tinyalsa/tinyalsa/pull/143]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 CMakeLists.txt | 14 +++++++++++---
14 1 file changed, 11 insertions(+), 3 deletions(-)
15
16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index cb31c58..1cc4a85 100644
18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt
20@@ -41,12 +41,20 @@ add_util("tinymix" "utils/tinymix.c")
21 install(FILES ${HDRS}
22 DESTINATION "include/tinyalsa")
23
24+if(NOT DEFINED CMAKE_INSTALL_LIBDIR)
25+ set(CMAKE_INSTALL_LIBDIR lib)
26+endif()
27+
28+if(NOT DEFINED CMAKE_INSTALL_BINDIR)
29+ set(CMAKE_INSTALL_BINDIR bin)
30+endif()
31+
32 install(TARGETS "tinyalsa"
33 "tinyplay"
34 "tinycap"
35 "tinymix"
36 "tinypcminfo"
37- RUNTIME DESTINATION "bin"
38- ARCHIVE DESTINATION "lib"
39- LIBRARY DESTINATION "lib")
40+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
41+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
42+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
43
44--
452.24.1
46
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-fixed-compilation-error-caused-by-strncpy.patch b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-fixed-compilation-error-caused-by-strncpy.patch
new file mode 100644
index 000000000..64ebdb19c
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa/0001-fixed-compilation-error-caused-by-strncpy.patch
@@ -0,0 +1,69 @@
1From 639650dd64e483074dd7c3c7ea6dc1b1bd542743 Mon Sep 17 00:00:00 2001
2From: alperak <alperyasinak1@gmail.com>
3Date: Sun, 12 Nov 2023 20:16:55 +0300
4Subject: [PATCH] fixed compilation error caused by strncpy
5
6Issue:
7 https://github.com/tinyalsa/tinyalsa/issues/219
8
9Fix:
10 https://github.com/tinyalsa/tinyalsa/pull/220
11 https://github.com/tinyalsa/tinyalsa/pull/221
12
13Upstream-Status: Submitted
14
15Signed-off-by: alperak <alperyasinak1@gmail.com>
16---
17 src/mixer_plugin.c | 8 +++++---
18 src/pcm_plugin.c | 9 ++++++---
19 2 files changed, 11 insertions(+), 6 deletions(-)
20
21diff --git a/src/mixer_plugin.c b/src/mixer_plugin.c
22index 34117a9..f608563 100644
23--- a/src/mixer_plugin.c
24+++ b/src/mixer_plugin.c
25@@ -82,7 +82,8 @@ static int mixer_plug_get_elem_id(struct mixer_plug_data *plug_data,
26 id->iface = ctl->iface;
27
28 strncpy((char *)id->name, (char *)ctl->name,
29- sizeof(id->name));
30+ sizeof(id->name) - 1);
31+ ((char *)id->name)[sizeof(id->name) - 1] = '\0';
32
33 return 0;
34 }
35@@ -100,8 +101,9 @@ static int mixer_plug_info_enum(struct snd_control *ctl,
36
37 strncpy(einfo->value.enumerated.name,
38 val->texts[einfo->value.enumerated.item],
39- sizeof(einfo->value.enumerated.name));
40-
41+ sizeof(einfo->value.enumerated.name) - 1);
42+ einfo->value.enumerated.name[sizeof(einfo->value.enumerated.name) - 1] = '\0';
43+
44 return 0;
45 }
46
47diff --git a/src/pcm_plugin.c b/src/pcm_plugin.c
48index 15bfc80..47bf4a5 100644
49--- a/src/pcm_plugin.c
50+++ b/src/pcm_plugin.c
51@@ -153,9 +153,12 @@ static int pcm_plug_info(struct pcm_plug_data *plug_data,
52 return ret;
53 }
54
55- strncpy((char *)info->id, name, sizeof(info->id));
56- strncpy((char *)info->name, name, sizeof(info->name));
57- strncpy((char *)info->subname, name, sizeof(info->subname));
58+ strncpy((char *)info->id, name, sizeof(info->id) - 1);
59+ ((char *)info->id)[sizeof(info->id) - 1] = '\0';
60+ strncpy((char *)info->name, name, sizeof(info->name) - 1);
61+ ((char *)info->name)[sizeof(info->name) - 1] = '\0';
62+ strncpy((char *)info->subname, name, sizeof(info->subname) - 1);
63+ ((char *)info->subname)[sizeof(info->subname) - 1] = '\0';
64
65 info->subdevices_count = 1;
66
67--
682.25.1
69
diff --git a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_2.0.0.bb
index 68cf8795a..e261611af 100644
--- a/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa.bb
+++ b/meta-multimedia/recipes-multimedia/tinyalsa/tinyalsa_2.0.0.bb
@@ -4,13 +4,12 @@ HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia" 4SECTION = "libs/multimedia"
5 5
6LICENSE = "BSD-3-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b" 7LIC_FILES_CHKSUM = "file://NOTICE;md5=e04cd6fa58488e016f7fb648ebea1db4"
8 8
9SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5" 9SRCREV = "1c5fb68ced57d838f2b7ecd0c00bc1fefc9ab60d"
10SRC_URI = "git://github.com/tinyalsa/tinyalsa;branch=master;protocol=https \ 10SRC_URI = "git://github.com/tinyalsa/tinyalsa;branch=master;protocol=https \
11 file://0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch \ 11 file://0001-fixed-compilation-error-caused-by-strncpy.patch \
12 " 12 "
13PV = "1.1.1+git${SRCPV}"
14 13
15S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
16 15