summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-12-12 13:57:42 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-12 08:56:53 -0800
commit23b62b3391f2e605f59e02abb3c99db2a7b82eb5 (patch)
tree8dbba76719657cd2e495a8d7061fe422e2754e6c /meta-multimedia
parentcdaafdea99c6b49cc56216c6082722e01512a0cd (diff)
downloadmeta-openembedded-23b62b3391f2e605f59e02abb3c99db2a7b82eb5.tar.gz
rygel: add x11 to DISTRO_FEATURES
* it was added in rygel-0.41.0 with: https://github.com/GNOME/rygel/commit/18cd2cff6f64b7a54156ac97e5c4f50eb8fd8d67 * it might need libx11 dependency as well which would probably be pulled by gtk+3 already when x11 is in DISTRO_FEATURES * as shown in: http://errors.yoctoproject.org/Errors/Details/746017/ it requires x11 even when gtk support is disabled, meson-log.txt: Determining dependency 'x11' with pkg-config executable '/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config' env[PKG_CONFIG_DIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig env[PKG_CONFIG_PATH]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig:/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/share/pkgconfig env[PKG_CONFIG_LIBDIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot/usr/lib/pkgconfig env[PKG_CONFIG_DISABLE_UNINSTALLED]: yes env[PKG_CONFIG_SYSROOT_DIR]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot env[PKG_CONFIG_SYSTEM_LIBRARY_PATH]: /usr/lib:/usr/lib env[PKG_CONFIG_SYSTEM_INCLUDE_PATH]: /usr/include env[PKG_CONFIG]: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config ----------- Called: `/OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/rygel/0.42.4/recipe-sysroot-native/usr/bin/pkg-config --modversion x11` -> 1 stderr: Package x11 was not found in the pkg-config search path. Perhaps you should add the directory containing `x11.pc' to the PKG_CONFIG_PATH environment variable No package 'x11' found ----------- CMake binary for host machine is cached as not found Dependency lookup for x11 with method 'cmake' failed: CMake binary for machine host machine not found. Giving up. Run-time dependency x11 found: NO (tried pkgconfig) ../rygel-0.42.4/src/rygel/meson.build:9:80: ERROR: Dependency "x11" not found, tried pkgconfig Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb2
-rw-r--r--meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
index 5212e7833..4fbdce086 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.42.4.bb
@@ -18,7 +18,7 @@ RRECOMMENDS:${PN} = "rygel-plugin-media-export"
18inherit gnomebase features_check vala gobject-introspection gettext systemd 18inherit gnomebase features_check vala gobject-introspection gettext systemd
19 19
20# gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured 20# gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured
21REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" 21REQUIRED_DISTRO_FEATURES = "gobject-introspection-data x11"
22 22
23SRC_URI[archive.sha256sum] = "6310dfaa2d332b66119b9b020fad6a4bd27d9bc61faf780ca5ca0b62813303f7" 23SRC_URI[archive.sha256sum] = "6310dfaa2d332b66119b9b020fad6a4bd27d9bc61faf780ca5ca0b62813303f7"
24 24
diff --git a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
index b18ad6ad1..672c8abc9 100644
--- a/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
+++ b/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb
@@ -62,7 +62,7 @@ RDEPENDS:packagegroup-meta-multimedia-connectivity = "\
62 gupnp-dlna \ 62 gupnp-dlna \
63 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gupnp-tools", "", d)} \ 63 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gupnp-tools", "", d)} \
64 libupnp \ 64 libupnp \
65 ${@bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "rygel", "", d)} \ 65 ${@bb.utils.contains("DISTRO_FEATURES", "x11", bb.utils.contains("DISTRO_FEATURES", "gobject-introspection-data", "rygel", "", d), "", d)} \
66" 66"
67RDEPENDS:packagegroup-meta-multimedia-dvb = "\ 67RDEPENDS:packagegroup-meta-multimedia-dvb = "\
68 oscam \ 68 oscam \