summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-02-05 22:19:01 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-09 09:52:06 -0800
commit0f1629611c93fb8a6fa8224e6e8d20d463b7631a (patch)
treeb7394c145b94420a40190d18c9e68ca893f5f147 /meta-multimedia
parent3918a94eb50c704ad06f391704fa815c69290a38 (diff)
downloadmeta-openembedded-0f1629611c93fb8a6fa8224e6e8d20d463b7631a.tar.gz
pipewire: update 1.0.1 -> 1.0.3
- remove fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch PipeWire 1.0.3 (2024-02-02) This is a quick bugfix release that is API and ABI compatible with previous 1.0.x releases. Highlights - Fix ALSA version check. This should allow the alsa plugin to work again. - Some small fixes and improvements. PipeWire - Escape @DEFAULT_SINK@ in the conf files. Modules - Improve logging in module-pipe-tunnel. SPA - Always recheck rate matching in ALSA when moving drivers. This fixes a potential issue where the adaptive resampler would not be activated in some cases. ALSA - Fix version check. This should allow the alsa plugin to work again with version 1.0.2. Older versions: PipeWire 1.0.2 (2024-01-31) This is a bugfix release that is API and ABI compatible with previous 1.0.x releases. Highlights - Fix v4l2 enumeration with filter. This should fix negotiation in some GStreamer pipelines with capsfilter. Also probe for EXPBUF support before using it. - Fix max-latency property and Buffer param when dealing with small ALSA device buffers. This should fix stuttering with some AMD based soundcards. - More small cleanups an improvements. Modules - Improve netjack2 channel positions. - Improve RAOP module state after suspend/resume. (#3778) - Avoid crash in some LV2 plugins by configuring the Atom ports. (#3815) SPA - Bump libcamera requirements to 0.2.0. - Try to avoid unaligned load exceptions. (#3790) - Fix v4l2 enumeration with filter. (#1793) - Fix max-latency property and Buffer param when dealing with small ALSA device buffers. This should fix stuttering with some AMD based soundcards. (#3744,#3622) - Add a resync.ms option to node.driver to make it possible to resync fast to clock jumps. - Probe for EXPBUF support in v4l2 before using it. (#3821) pulse-server - Also emit change events when the port list change. Bluetooth - Log a more verbose explanation when other soundservers seem to be interfering with bluetooth. - Add quirks for Rockbox Brick. (#3786) - Add quirks for SoundCore mini2. (#2927) JACK - Improve check for the running state of clients. (#3794) Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire/fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch82
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.3.bb (renamed from meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.1.bb)7
2 files changed, 2 insertions, 87 deletions
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire/fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch b/meta-multimedia/recipes-multimedia/pipewire/pipewire/fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch
deleted file mode 100644
index 9c62df19e..000000000
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire/fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch
+++ /dev/null
@@ -1,82 +0,0 @@
1From fd33d2d3bb6333c7d6e74cbaa806bff2d908f589 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Barnab=C3=A1s=20P=C5=91cze?= <pobrn@protonmail.com>
3Date: Sat, 28 Oct 2023 02:09:06 +0200
4Subject: [PATCH] spa: libcamera: use `CameraConfiguration::orientation`
5
6libcamera commit cc65629b68d49d ("libcamera: camera: Introduce Orientation") [0]
7introduced to the `CameraConfiguration::orientation` member to describe the
8orientation of the image in the received memory buffers.
9
10Then c65e40b8480ffb ("libcamera: Use CameraConfiguration::orientation") [1]
11removed `CameraConfiguration::transform`, which broke the libcamera plugin.
12
13Fix that by using the new `orientation` member.
14
15[0]: https://git.linuxtv.org/libcamera.git/commit/?id=cc65629b68d49d5f2a4d61537584c56ba510a335
16[1]: https://git.linuxtv.org/libcamera.git/commit/?id=c65e40b8480ffb5f50e01a4e6713164c7194a937
17
18Upstream-Status: Backport [https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/fd33d2d3bb6333c7d6e74cbaa806bff2d908f589]
19---
20 spa/plugins/libcamera/libcamera-utils.cpp | 36 +++++++++++------------
21 1 file changed, 17 insertions(+), 19 deletions(-)
22
23diff --git a/spa/plugins/libcamera/libcamera-utils.cpp b/spa/plugins/libcamera/libcamera-utils.cpp
24index 2b1aea5a76..c197248d30 100644
25--- a/spa/plugins/libcamera/libcamera-utils.cpp
26+++ b/spa/plugins/libcamera/libcamera-utils.cpp
27@@ -716,25 +716,23 @@ static int spa_libcamera_use_buffers(struct impl *impl, struct port *port,
28 }
29
30 static const struct {
31- Transform libcamera_transform;
32- uint32_t spa_transform_value;
33-} transform_map[] = {
34- { Transform::Identity, SPA_META_TRANSFORMATION_None },
35- { Transform::Rot0, SPA_META_TRANSFORMATION_None },
36- { Transform::HFlip, SPA_META_TRANSFORMATION_Flipped },
37- { Transform::VFlip, SPA_META_TRANSFORMATION_Flipped180 },
38- { Transform::HVFlip, SPA_META_TRANSFORMATION_180 },
39- { Transform::Rot180, SPA_META_TRANSFORMATION_180 },
40- { Transform::Transpose, SPA_META_TRANSFORMATION_Flipped90 },
41- { Transform::Rot90, SPA_META_TRANSFORMATION_90 },
42- { Transform::Rot270, SPA_META_TRANSFORMATION_270 },
43- { Transform::Rot180Transpose, SPA_META_TRANSFORMATION_Flipped270 },
44+ Orientation libcamera_orientation; /* clockwise rotation then horizontal mirroring */
45+ uint32_t spa_transform_value; /* horizontal mirroring then counter-clockwise rotation */
46+} orientation_map[] = {
47+ { Orientation::Rotate0, SPA_META_TRANSFORMATION_None },
48+ { Orientation::Rotate0Mirror, SPA_META_TRANSFORMATION_Flipped },
49+ { Orientation::Rotate90, SPA_META_TRANSFORMATION_270 },
50+ { Orientation::Rotate90Mirror, SPA_META_TRANSFORMATION_Flipped90 },
51+ { Orientation::Rotate180, SPA_META_TRANSFORMATION_180 },
52+ { Orientation::Rotate180Mirror, SPA_META_TRANSFORMATION_Flipped180 },
53+ { Orientation::Rotate270, SPA_META_TRANSFORMATION_90 },
54+ { Orientation::Rotate270Mirror, SPA_META_TRANSFORMATION_Flipped270 },
55 };
56
57-static uint32_t libcamera_transform_to_spa_transform_value(Transform transform)
58+static uint32_t libcamera_orientation_to_spa_transform_value(Orientation orientation)
59 {
60- for (const auto& t : transform_map) {
61- if (t.libcamera_transform == transform)
62+ for (const auto& t : orientation_map) {
63+ if (t.libcamera_orientation == orientation)
64 return t.spa_transform_value;
65 }
66 return SPA_META_TRANSFORMATION_None;
67@@ -788,9 +786,9 @@ mmap_init(struct impl *impl, struct port *port,
68 buffers[i], SPA_META_VideoTransform, sizeof(*b->videotransform));
69 if (b->videotransform) {
70 b->videotransform->transform =
71- libcamera_transform_to_spa_transform_value(impl->config->transform);
72- spa_log_debug(impl->log, "Setting videotransform for buffer %d to %u (from %s)",
73- i, b->videotransform->transform, transformToString(impl->config->transform));
74+ libcamera_orientation_to_spa_transform_value(impl->config->orientation);
75+ spa_log_debug(impl->log, "Setting videotransform for buffer %u to %u",
76+ i, b->videotransform->transform);
77
78 }
79
80--
81GitLab
82
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.1.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.3.bb
index f1b1ce586..f1c9f8556 100644
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.1.bb
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_1.0.3.bb
@@ -12,11 +12,8 @@ LIC_FILES_CHKSUM = " \
12 12
13DEPENDS = "dbus ncurses" 13DEPENDS = "dbus ncurses"
14 14
15SRCREV = "79b98884af80329f59596906231da5597bcdb7b6" 15SRCREV = "6ab86209f23a841de7eac6bc0c1009aceb9ffd87"
16SRC_URI = " \ 16SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=1.0;protocol=https"
17 git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=1.0;protocol=https \
18 file://fd33d2d3bb6333c7d6e74cbaa806bff2d908f589.patch \
19"
20 17
21S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
22 19