diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-20 18:15:08 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-23 08:44:42 -0700 |
commit | 0b8dc5346b35e1ecf78d99a9f133e6bb8bedfdfb (patch) | |
tree | 55357a4c196390c5ae58f5b46f04f60296b2a92b /meta-multimedia | |
parent | 46db58f8c731213bfc97c670935584e6d602e6dc (diff) | |
download | meta-openembedded-0b8dc5346b35e1ecf78d99a9f133e6bb8bedfdfb.tar.gz |
pipewire-0.2: Include time.h for timespec struct signature
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia')
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2/0001-module-suspend-on-idle-Include-time.h-for-struct-tim.patch b/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2/0001-module-suspend-on-idle-Include-time.h-for-struct-tim.patch new file mode 100644 index 0000000000..ce381a78b3 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2/0001-module-suspend-on-idle-Include-time.h-for-struct-tim.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From b1d911fdab4a583f276d18395037d90bfc305109 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 20 May 2024 18:12:23 -0700 | ||
4 | Subject: [PATCH] module-suspend-on-idle: Include time.h for struct timespec | ||
5 | decl | ||
6 | |||
7 | This is flagged as error with gcc-14 on musl targets | ||
8 | |||
9 | In file included from ../git/src/pipewire/loop.h:27, | ||
10 | from ../git/src/pipewire/core.h:44, | ||
11 | from ../git/src/modules/module-suspend-on-idle.c:26: | ||
12 | ../git/spa/include/spa/support/loop.h:184:37: warning: 'struct timespec' declared inside parameter list will not be visible outside of this definition or declaration | ||
13 | 184 | struct timespec *value, | ||
14 | | ^~~~~~~~ | ||
15 | ../git/src/modules/module-suspend-on-idle.c: In function 'node_state_changed': | ||
16 | ../git/src/modules/module-suspend-on-idle.c:110:69: error: passing argument 2 of 'main_loop->utils->update_timer' from incompatible pointer type [-Wincompatible-pointer-types] | ||
17 | 110 | pw_loop_update_timer(main_loop, info->idle_timeout, &value, NULL, false); | ||
18 | | ^~~~~~ | ||
19 | | | | ||
20 | | struct timespec * | ||
21 | |||
22 | Upstream-Status: Inappropriate [Fixed in latest pipewire differently] | ||
23 | |||
24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
25 | --- | ||
26 | src/modules/module-suspend-on-idle.c | 1 + | ||
27 | 1 file changed, 1 insertion(+) | ||
28 | |||
29 | diff --git a/src/modules/module-suspend-on-idle.c b/src/modules/module-suspend-on-idle.c | ||
30 | index e5c1fcb30..4dba3be71 100644 | ||
31 | --- a/src/modules/module-suspend-on-idle.c | ||
32 | +++ b/src/modules/module-suspend-on-idle.c | ||
33 | @@ -20,6 +20,7 @@ | ||
34 | #include <string.h> | ||
35 | #include <stdio.h> | ||
36 | #include <errno.h> | ||
37 | +#include <time.h> | ||
38 | |||
39 | #include "config.h" | ||
40 | |||
41 | -- | ||
42 | 2.45.1 | ||
43 | |||
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2_git.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2_git.bb index 9895e89761..7c8afd3d51 100644 --- a/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2_git.bb +++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire-0.2_git.bb | |||
@@ -10,7 +10,9 @@ DEPENDS = "alsa-lib dbus udev" | |||
10 | SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d" | 10 | SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d" |
11 | PV = "0.2.7" | 11 | PV = "0.2.7" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/PipeWire/pipewire;branch=master;protocol=https" | 13 | SRC_URI = "git://github.com/PipeWire/pipewire;branch=master;protocol=https \ |
14 | file://0001-module-suspend-on-idle-Include-time.h-for-struct-tim.patch \ | ||
15 | " | ||
14 | 16 | ||
15 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
16 | 18 | ||