diff options
author | Yoann Congal <yoann.congal@smile.fr> | 2024-05-28 19:07:22 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-29 20:57:55 -0700 |
commit | ab916d7311782b0d12706fba94d24b4d7ca00307 (patch) | |
tree | c5f06ceee93c17f49140719164b3cc47a29f898b /meta-multimedia/recipes-multimedia | |
parent | 0b96a041fad57b2092ee5efc2a5bf2f7acea1064 (diff) | |
download | meta-openembedded-ab916d7311782b0d12706fba94d24b4d7ca00307.tar.gz |
sample-content: Set UNPACKDIR to S to avoid a QA warning
Since recent UNPACKDIR work, default S directory is not created anymore.
By setting UNPACKDIR to S, S in indirectly created in do_unpack.
Also set S to a known static value to match OE-Core definition of
UNPACKDIR/S[0].
Fixes these warnings:
WARNING: bigbuckbunny-480p-1.0-r0 do_unpack: bigbuckbunny-480p: the directory ${WORKDIR}/${BP} (.../tmp/work/all-poky-linux/bigbuckbunny-480p/1.0/bigbuckbunny-480p-1.0) pointed to by the S variable doesn't exist - please set S within the recipe to point to where the source has been unpacked to
WARNING: bigbuckbunny-720p-1.0-r0 do_unpack: bigbuckbunny-720p: the directory ${WORKDIR}/${BP} (.../tmp/work/all-poky-linux/bigbuckbunny-720p/1.0/bigbuckbunny-720p-1.0) pointed to by the S variable doesn't exist - please set S within the recipe to point to where the source has been unpacked to
WARNING: bigbuckbunny-1080p-1.0-r0 do_unpack: bigbuckbunny-1080p: the directory ${WORKDIR}/${BP} (.../tmp/work/all-poky-linux/bigbuckbunny-1080p/1.0/bigbuckbunny-1080p-1.0) pointed to by the S variable doesn't exist - please set S within the recipe to point to where the source has been unpacked to
WARNING: tearsofsteel-1080p-1.0-r0 do_unpack: tearsofsteel-1080p: the directory ${WORKDIR}/${BP} (.../tmp/work/all-poky-linux/tearsofsteel-1080p/1.0/tearsofsteel-1080p-1.0) pointed to by the S variable doesn't exist - please set S within the recipe to point to where the source has been unpacked to
[0]: https://git.yoctoproject.org/poky/commit/?id=d6ae8d2004f8ac3aab4571e0077d406b2d19b542
Signed-off-by: Yoann Congal <yoann.congal@smile.fr>
Reviewed-by: Alexandre Truong <alexandre.truong@smile.fr>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
4 files changed, 12 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb index e5a8f085b..5eba4da20 100644 --- a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-1080p.bb | |||
@@ -9,6 +9,9 @@ SRC_URI[sha256sum] = "69fe2cfe7154a6e752688e3a0d7d6b07b1605bbaf75b56f6470dc7b4c2 | |||
9 | 9 | ||
10 | inherit allarch | 10 | inherit allarch |
11 | 11 | ||
12 | S = "${WORKDIR}/sources" | ||
13 | UNPACKDIR = "${S}" | ||
14 | |||
12 | do_install() { | 15 | do_install() { |
13 | install -d ${D}${datadir}/movies | 16 | install -d ${D}${datadir}/movies |
14 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_1080p_surround.avi ${D}${datadir}/movies/ | 17 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_1080p_surround.avi ${D}${datadir}/movies/ |
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb index 37e519790..29e60cb0a 100644 --- a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-480p.bb | |||
@@ -9,6 +9,9 @@ SRC_URI[sha256sum] = "40d1cf5bc8e1b0e55dac7bb2e3fbc2aea05b6679444864781299b24db0 | |||
9 | 9 | ||
10 | inherit allarch | 10 | inherit allarch |
11 | 11 | ||
12 | S = "${WORKDIR}/sources" | ||
13 | UNPACKDIR = "${S}" | ||
14 | |||
12 | do_install() { | 15 | do_install() { |
13 | install -d ${D}${datadir}/movies | 16 | install -d ${D}${datadir}/movies |
14 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_480p_surround-fix.avi ${D}${datadir}/movies/ | 17 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_480p_surround-fix.avi ${D}${datadir}/movies/ |
diff --git a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb index 2b233d3e1..50ea2e3c8 100644 --- a/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb +++ b/meta-multimedia/recipes-multimedia/sample-content/bigbuckbunny-720p.bb | |||
@@ -9,6 +9,9 @@ SRC_URI[sha256sum] = "b957d6e6212638441b52d3b620af157cc8d40c2a0342669294854a06ed | |||
9 | 9 | ||
10 | inherit allarch | 10 | inherit allarch |
11 | 11 | ||
12 | S = "${WORKDIR}/sources" | ||
13 | UNPACKDIR = "${S}" | ||
14 | |||
12 | do_install() { | 15 | do_install() { |
13 | install -d ${D}${datadir}/movies | 16 | install -d ${D}${datadir}/movies |
14 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_720p_surround.avi ${D}${datadir}/movies/ | 17 | install -m 0644 ${UNPACKDIR}/big_buck_bunny_720p_surround.avi ${D}${datadir}/movies/ |
diff --git a/meta-multimedia/recipes-multimedia/sample-content/tearsofsteel-1080p.bb b/meta-multimedia/recipes-multimedia/sample-content/tearsofsteel-1080p.bb index 34753fdb1..ed3ff75ac 100644 --- a/meta-multimedia/recipes-multimedia/sample-content/tearsofsteel-1080p.bb +++ b/meta-multimedia/recipes-multimedia/sample-content/tearsofsteel-1080p.bb | |||
@@ -8,6 +8,9 @@ SRC_URI[sha256sum] = "bd2b5bc6c16d4085034f47ef7e4b3938afe86b4eec4ac3cf2685367d3b | |||
8 | 8 | ||
9 | inherit allarch | 9 | inherit allarch |
10 | 10 | ||
11 | S = "${WORKDIR}/sources" | ||
12 | UNPACKDIR = "${S}" | ||
13 | |||
11 | do_install() { | 14 | do_install() { |
12 | install -d ${D}${datadir}/movies | 15 | install -d ${D}${datadir}/movies |
13 | install -m 0644 ${UNPACKDIR}/ToS-4k-1920.mov ${D}${datadir}/movies/ | 16 | install -m 0644 ${UNPACKDIR}/ToS-4k-1920.mov ${D}${datadir}/movies/ |