summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-17 17:40:23 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-17 17:43:11 -0700
commit51ea6b4bfa029ba4c87053709aece9af8fe0d9ed (patch)
tree8c1194ec235aff7cf0af4cb23f7c8a43e0a12a14 /meta-multimedia/recipes-multimedia
parent998219d2e8179c8ca758da822b8dc17a1e3533b8 (diff)
downloadmeta-openembedded-51ea6b4bfa029ba4c87053709aece9af8fe0d9ed.tar.gz
gerbera: Fix build with fmt 10+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-against-fmt-10.patch168
-rw-r--r--meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb3
2 files changed, 170 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-against-fmt-10.patch b/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-against-fmt-10.patch
new file mode 100644
index 000000000..2da98cfcf
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gerbera/gerbera/0001-Fix-build-against-fmt-10.patch
@@ -0,0 +1,168 @@
1From 2c08724e8a7e3a0ee8cdd91246a714a17f2ba5c1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 17 May 2023 17:31:56 -0700
4Subject: [PATCH] Fix build against fmt 10+
5
6Fixes
7git/src/config/setup/config_setup_vector.cc:191:9: required from here
8| /home/hains/openpli-dm920-python3/build/tmp/work/cortexa15hf-neon-vfpv4-oe-linux-gnueabi/gerbera/1.11.0-r0/
9recipe-sysroot/usr/include/fmt/core.h:1691:7: error: static assertion failed: Cannot format an argument. To make type T formattable provide a formatter<T> specialization: https://fmt.dev/latest/api.html#udt
10| 1691 | formattable,
11| | ^~~~~~~~~~~
12
13Source: https://github.com/Hains/openpli-dm920-python3/commit/688ae121bd3928925a8656bd4aaf3857d8e8a8ed
14
15Upstream-Status: Pending
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 src/config/setup/config_setup_array.cc | 6 +++---
19 src/config/setup/config_setup_autoscan.cc | 2 +-
20 src/config/setup/config_setup_client.cc | 2 +-
21 src/config/setup/config_setup_dictionary.cc | 6 +++---
22 src/config/setup/config_setup_dynamic.cc | 2 +-
23 src/config/setup/config_setup_transcoding.cc | 2 +-
24 src/config/setup/config_setup_tweak.cc | 2 +-
25 src/config/setup/config_setup_vector.cc | 4 ++--
26 8 files changed, 13 insertions(+), 13 deletions(-)
27
28diff --git a/src/config/setup/config_setup_array.cc b/src/config/setup/config_setup_array.cc
29index 8f3cf1db..efc9b501 100644
30--- a/src/config/setup/config_setup_array.cc
31+++ b/src/config/setup/config_setup_array.cc
32@@ -136,11 +136,11 @@ std::vector<std::string> ConfigArraySetup::getXmlContent(const pugi::xml_node& o
33 std::vector<std::string> result;
34 if (initArray) {
35 if (!initArray(optValue, result, ConfigDefinition::mapConfigOption(nodeOption))) {
36- throw_std_runtime_error("Invalid {} array value '{}'", xpath, optValue);
37+ throw_std_runtime_error("Invalid {} array value '{}'", xpath, optValue.value());
38 }
39 } else {
40 if (!createOptionFromNode(optValue, result)) {
41- throw_std_runtime_error("Invalid {} array value '{}'", xpath, optValue);
42+ throw_std_runtime_error("Invalid {} array value '{}'", xpath, optValue.value());
43 }
44 }
45 if (result.empty()) {
46@@ -149,7 +149,7 @@ std::vector<std::string> ConfigArraySetup::getXmlContent(const pugi::xml_node& o
47 result = defaultEntries;
48 }
49 if (notEmpty && result.empty()) {
50- throw_std_runtime_error("Invalid array {} empty '{}'", xpath, optValue);
51+ throw_std_runtime_error("Invalid array {} empty '{}'", xpath, optValue.value());
52 }
53 return result;
54 }
55diff --git a/src/config/setup/config_setup_autoscan.cc b/src/config/setup/config_setup_autoscan.cc
56index e882ca3e..d773419b 100644
57--- a/src/config/setup/config_setup_autoscan.cc
58+++ b/src/config/setup/config_setup_autoscan.cc
59@@ -203,7 +203,7 @@ std::shared_ptr<ConfigOption> ConfigAutoscanSetup::newOption(const pugi::xml_nod
60 {
61 auto result = std::vector<AutoscanDirectory>();
62 if (!createOptionFromNode(optValue, result)) {
63- throw_std_runtime_error("Init {} autoscan failed '{}'", xpath, optValue);
64+ throw_std_runtime_error("Init {} autoscan failed '{}'", xpath, optValue.value());
65 }
66 optionValue = std::make_shared<AutoscanListOption>(result);
67 return optionValue;
68diff --git a/src/config/setup/config_setup_client.cc b/src/config/setup/config_setup_client.cc
69index 30bb98cb..56be9c53 100644
70--- a/src/config/setup/config_setup_client.cc
71+++ b/src/config/setup/config_setup_client.cc
72@@ -163,7 +163,7 @@ std::shared_ptr<ConfigOption> ConfigClientSetup::newOption(const pugi::xml_node&
73 auto result = std::make_shared<ClientConfigList>();
74
75 if (!createOptionFromNode(isEnabled ? optValue : pugi::xml_node(nullptr), result)) {
76- throw_std_runtime_error("Init {} client config failed '{}'", xpath, optValue);
77+ throw_std_runtime_error("Init {} client config failed '{}'", xpath, optValue.value());
78 }
79 optionValue = std::make_shared<ClientConfigListOption>(result);
80 return optionValue;
81diff --git a/src/config/setup/config_setup_dictionary.cc b/src/config/setup/config_setup_dictionary.cc
82index eb91c694..ea2aaa05 100644
83--- a/src/config/setup/config_setup_dictionary.cc
84+++ b/src/config/setup/config_setup_dictionary.cc
85@@ -162,11 +162,11 @@ std::map<std::string, std::string> ConfigDictionarySetup::getXmlContent(const pu
86 std::map<std::string, std::string> result;
87 if (initDict) {
88 if (!initDict(optValue, result)) {
89- throw_std_runtime_error("Init {} dictionary failed '{}'", xpath, optValue);
90+ throw_std_runtime_error("Init {} dictionary failed '{}'", xpath, optValue.value());
91 }
92 } else {
93 if (!createOptionFromNode(optValue, result) && required) {
94- throw_std_runtime_error("Init {} dictionary failed '{}'", xpath, optValue);
95+ throw_std_runtime_error("Init {} dictionary failed '{}'", xpath, optValue.value());
96 }
97 }
98 if (result.empty()) {
99@@ -175,7 +175,7 @@ std::map<std::string, std::string> ConfigDictionarySetup::getXmlContent(const pu
100 result = defaultEntries;
101 }
102 if (notEmpty && result.empty()) {
103- throw_std_runtime_error("Invalid dictionary {} empty '{}'", xpath, optValue);
104+ throw_std_runtime_error("Invalid dictionary {} empty '{}'", xpath, optValue.value());
105 }
106 return result;
107 }
108diff --git a/src/config/setup/config_setup_dynamic.cc b/src/config/setup/config_setup_dynamic.cc
109index 6a43b820..93030b85 100644
110--- a/src/config/setup/config_setup_dynamic.cc
111+++ b/src/config/setup/config_setup_dynamic.cc
112@@ -179,7 +179,7 @@ std::shared_ptr<ConfigOption> ConfigDynamicContentSetup::newOption(const pugi::x
113 auto result = std::make_shared<DynamicContentList>();
114
115 if (!createOptionFromNode(optValue, result)) {
116- throw_std_runtime_error("Init {} DynamicContentList failed '{}'", xpath, optValue);
117+ throw_std_runtime_error("Init {} DynamicContentList failed '{}'", xpath, optValue.value());
118 }
119 optionValue = std::make_shared<DynamicContentListOption>(result);
120 return optionValue;
121diff --git a/src/config/setup/config_setup_transcoding.cc b/src/config/setup/config_setup_transcoding.cc
122index 4827f109..c353ce1f 100644
123--- a/src/config/setup/config_setup_transcoding.cc
124+++ b/src/config/setup/config_setup_transcoding.cc
125@@ -492,7 +492,7 @@ std::shared_ptr<ConfigOption> ConfigTranscodingSetup::newOption(const pugi::xml_
126 auto result = std::make_shared<TranscodingProfileList>();
127
128 if (!createOptionFromNode(isEnabled ? optValue : pugi::xml_node(nullptr), result)) {
129- throw_std_runtime_error("Init {} transcoding failed '{}'", xpath, optValue);
130+ throw_std_runtime_error("Init {} transcoding failed '{}'", xpath, optValue.value());
131 }
132 optionValue = std::make_shared<TranscodingProfileListOption>(result);
133 return optionValue;
134diff --git a/src/config/setup/config_setup_tweak.cc b/src/config/setup/config_setup_tweak.cc
135index d7692c09..72c2beb2 100644
136--- a/src/config/setup/config_setup_tweak.cc
137+++ b/src/config/setup/config_setup_tweak.cc
138@@ -242,7 +242,7 @@ std::shared_ptr<ConfigOption> ConfigDirectorySetup::newOption(const pugi::xml_no
139 auto result = std::make_shared<DirectoryConfigList>();
140
141 if (!createOptionFromNode(optValue, result)) {
142- throw_std_runtime_error("Init {} DirectoryConfigList failed '{}'", xpath, optValue);
143+ throw_std_runtime_error("Init {} DirectoryConfigList failed '{}'", xpath, optValue.value());
144 }
145 optionValue = std::make_shared<DirectoryTweakOption>(result);
146 return optionValue;
147diff --git a/src/config/setup/config_setup_vector.cc b/src/config/setup/config_setup_vector.cc
148index c8ff853d..91f99ca4 100644
149--- a/src/config/setup/config_setup_vector.cc
150+++ b/src/config/setup/config_setup_vector.cc
151@@ -180,7 +180,7 @@ std::vector<std::vector<std::pair<std::string, std::string>>> ConfigVectorSetup:
152 {
153 std::vector<std::vector<std::pair<std::string, std::string>>> result;
154 if (!createOptionFromNode(optValue, result) && required) {
155- throw_std_runtime_error("Init {} vector failed '{}'", xpath, optValue);
156+ throw_std_runtime_error("Init {} vector failed '{}'", xpath, optValue.value());
157 }
158 if (result.empty()) {
159 log_debug("{} assigning {} default values", xpath, defaultEntries.size());
160@@ -188,7 +188,7 @@ std::vector<std::vector<std::pair<std::string, std::string>>> ConfigVectorSetup:
161 result = defaultEntries;
162 }
163 if (notEmpty && result.empty()) {
164- throw_std_runtime_error("Invalid vector {} empty '{}'", xpath, optValue);
165+ throw_std_runtime_error("Invalid vector {} empty '{}'", xpath, optValue.value());
166 }
167 return result;
168 }
diff --git a/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb b/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb
index 9f2f1b093..2a6d32871 100644
--- a/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb
+++ b/meta-multimedia/recipes-multimedia/gerbera/gerbera_1.11.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=25cdec9afe3f1f26212ead6bd2f7fac8"
5 5
6SRC_URI = "git://github.com/gerbera/gerbera.git;protocol=https;branch=master \ 6SRC_URI = "git://github.com/gerbera/gerbera.git;protocol=https;branch=master \
7 file://0001-Fix-build-with-fmt-9.0.patch \ 7 file://0001-Fix-build-with-fmt-9.0.patch \
8 " 8 file://0001-Fix-build-against-fmt-10.patch \
9 "
9 10
10SRCREV = "d73d8c1346213d784753c02ea771970500e0df2a" 11SRCREV = "d73d8c1346213d784753c02ea771970500e0df2a"
11 12