summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2018-02-23 19:13:12 +0200
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:12:56 -0800
commit6d3da810947c5b4725f6a83e87fad9df2f2eee28 (patch)
treee70fbe3da3a240b2964af91bf49d230fa110e5ff /meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb
parentac7cb1d69d63eefb49abc884d7db872d7b809e02 (diff)
downloadmeta-openembedded-6d3da810947c5b4725f6a83e87fad9df2f2eee28.tar.gz
sox: bump 14.4.0 -> 14.4.2
The big feature in the new version is opus codec support. Make the old vorbis codec optional via packageconfig. Remove sox-native because it's broken and nothing uses it. Refresh musl build-fix patch. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb b/meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb
new file mode 100644
index 000000000..d1ed08a89
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/sox/sox_14.4.2.bb
@@ -0,0 +1,39 @@
1DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
2It converts audio files among various standard audio file formats \
3and can apply different effects and filters to the audio data."
4HOMEPAGE = "http://sox.sourceforge.net"
5SECTION = "audio"
6
7DEPENDS = "libpng ffmpeg libsndfile1"
8
9# While this item does not require it, it depends on ffmpeg which does
10LICENSE_FLAGS = "commercial"
11
12PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)} \
13 magic \
14"
15PACKAGECONFIG[pulseaudio] = "--with-pulseaudio=dyn,--with-pulseaudio=no,pulseaudio,"
16PACKAGECONFIG[alsa] = "--with-alsa=dyn,--with-alsa=no,alsa-lib,"
17PACKAGECONFIG[wavpack] = "--with-wavpack=dyn,--with-wavpack=no,wavpack,"
18PACKAGECONFIG[flac] = "--with-flac=dyn,--with-flac=no,flac,"
19PACKAGECONFIG[amrwb] = "--with-amrwb=dyn,--with-amrwb=no,opencore-amr,"
20PACKAGECONFIG[amrnb] = "--with-amrnb=dyn,--with-amrnb=no,opencore-amr,"
21PACKAGECONFIG[oggvorbis] = "--with-oggvorbis=dyn,--with-oggvorbis=no,libvorbis"
22PACKAGECONFIG[opus] = "--with-opus=dyn,--with-opus=no,opusfile"
23PACKAGECONFIG[magic] = "--with-magic,--without-magic,file,"
24PACKAGECONFIG[mad] = "--with-mad,--without-mad,libmad,"
25PACKAGECONFIG[id3tag] = "--with-id3tag,--without-id3tag,libid3tag,"
26PACKAGECONFIG[lame] = "--with-lame,--without-lame,lame,"
27PACKAGECONFIG[ao] = "--with-ao,--without-ao,libao,"
28
29LICENSE = "GPLv2 & LGPLv2.1"
30LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe \
31 file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
32
33SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz \
34 file://0001-remove-the-error-line-and-live-without-file-type-det.patch \
35 "
36SRC_URI[md5sum] = "d04fba2d9245e661f245de0577f48a33"
37SRC_URI[sha256sum] = "b45f598643ffbd8e363ff24d61166ccec4836fea6d3888881b8df53e3bb55f6c"
38
39inherit autotools pkgconfig