summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-14 10:58:04 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-14 11:53:54 -0800
commit6fc561ce106dfb00631043f274345443d124e6ae (patch)
treea5e1694cd2ca7212c477d14e9bc3659a1127c290 /meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb
parenteb6cf36865da9e3363479d93b5b5a1085bb8d2fa (diff)
downloadmeta-openembedded-6fc561ce106dfb00631043f274345443d124e6ae.tar.gz
openal-soft: Upgrade to 1.19.1
License-Update: Removed sections that are not needed see https://github.com/kcat/openal-soft/commit/4c61103e34b190c53f0669cb341355d031044571#diff-7116ef0705885343c9e1b2171a06be0e Switch to github for SRC_URI Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb b/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb
new file mode 100644
index 000000000..a9cdfac8a
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/openal/openal-soft_1.19.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "OpenAL is a cross-platform 3D audio API"
2HOMEPAGE = "http://kcat.strangesoft.net/openal.html"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0f159f19f9377e1895fbb477d5a7953e"
5
6inherit cmake pkgconfig
7
8# openal-soft-1.19.1
9SRCREV = "6761218e51699f46bf25c377e65b3e9ea5e434b9"
10SRC_URI = "git://github.com/kcat/openal-soft \
11 file://0001-Use-BUILD_CC-to-compile-native-tools.patch \
12 file://0002-makehrtf-Disable-Wstringop-truncation.patch \
13 "
14
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa pulseaudio', d)}"
18PACKAGECONFIG[alsa] = "-DALSA=TRUE, -DALSA=FALSE, alsa-lib"
19PACKAGECONFIG[pulseaudio] = "-DPULSEAUDIO=TRUE, -DPULSEAUDIO=FALSE, pulseaudio"
20# currently doesn't work with libav-9
21# PKG_CHECK_MODULES(FFMPEG libavcodec>=53.61.100 libavformat>=53.32.100 libavutil>=51.35.100)
22# but alffmpeg.c:418:44: error: 'AV_CH_LAYOUT_MONO' undeclared (first use in this function)
23PACKAGECONFIG[examples] = "-DEXAMPLES=TRUE, -DEXAMPLES=FALSE, libav"
24
25FILES_${PN} += "${datadir}/openal"