diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-17 17:56:57 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-17 17:57:36 -0700 |
commit | 6b23d6fcef9f480ebbcada1ffa98d16125a570ba (patch) | |
tree | a31b8c84940c6ab6b798b614b27461cbb3c3e3bb /meta-multimedia/recipes-multimedia/musicpd | |
parent | 8fdc550f0a8259f5f294fc56f83322ca0848fd4b (diff) | |
download | meta-openembedded-6b23d6fcef9f480ebbcada1ffa98d16125a570ba.tar.gz |
mpd: Fix build with clang-16
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-multimedia/musicpd')
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicpd/mpd/0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch | 28 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb | 1 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch new file mode 100644 index 000000000..37aa448e9 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/musicpd/mpd/0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From f2fbfeeb9c4ff7aa9ba4b95604ee0fb14ecec763 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 17 May 2023 17:54:09 -0700 | ||
4 | Subject: [PATCH] SndfileDecoderPlugin: Fix type mismatch for std::span | ||
5 | |||
6 | Fixes | ||
7 | ../git/src/decoder/plugins/SndfileDecoderPlugin.cxx:231:25: error: non-constant-expression cannot be narrowed from type 'sf_count_t' (aka 'long long') to 'size_type' (aka 'unsigned int') in initializer list [-Wc++11-narrowing] | ||
8 | std::span{buffer, num_frames * frame_size}, | ||
9 | ^~~~~~~~~~~~~~~~~~~~~~~ | ||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/decoder/plugins/SndfileDecoderPlugin.cxx | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/src/decoder/plugins/SndfileDecoderPlugin.cxx b/src/decoder/plugins/SndfileDecoderPlugin.cxx | ||
17 | index ad3908847..a3cb87ca9 100644 | ||
18 | --- a/src/decoder/plugins/SndfileDecoderPlugin.cxx | ||
19 | +++ b/src/decoder/plugins/SndfileDecoderPlugin.cxx | ||
20 | @@ -228,7 +228,7 @@ sndfile_stream_decode(DecoderClient &client, InputStream &is) | ||
21 | break; | ||
22 | |||
23 | cmd = client.SubmitAudio(is, | ||
24 | - std::span{buffer, num_frames * frame_size}, | ||
25 | + std::span{buffer, static_cast<std::size_t>(num_frames * frame_size)}, | ||
26 | 0); | ||
27 | if (cmd == DecoderCommand::SEEK) { | ||
28 | sf_count_t c = client.GetSeekFrame(); | ||
diff --git a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb index c6672ca46..0c309ded0 100644 --- a/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb +++ b/meta-multimedia/recipes-multimedia/musicpd/mpd_0.23.12.bb | |||
@@ -22,6 +22,7 @@ SRC_URI = "git://github.com/MusicPlayerDaemon/MPD;branch=master;protocol=https \ | |||
22 | file://mpd.conf.in \ | 22 | file://mpd.conf.in \ |
23 | file://minor-fixup-for-libfmt10.patch \ | 23 | file://minor-fixup-for-libfmt10.patch \ |
24 | file://fix-build-error-when-fmt-updated.patch \ | 24 | file://fix-build-error-when-fmt-updated.patch \ |
25 | file://0001-SndfileDecoderPlugin-Fix-type-mismatch-for-std-span.patch \ | ||
25 | " | 26 | " |
26 | SRCREV = "b1422fbda40a1831d397fb161e7a555443c2a072" | 27 | SRCREV = "b1422fbda40a1831d397fb161e7a555443c2a072" |
27 | S = "${WORKDIR}/git" | 28 | S = "${WORKDIR}/git" |