summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-06-17 13:34:49 -0700
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit9ecd1e0e1395d1af605260c3617e700563205eef (patch)
treed4a7be9225d140042c13865ab400874bba372aad /meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
parent2be8e0fe2f61685758e0f0b2508e950d4cb7c805 (diff)
downloadmeta-openembedded-9ecd1e0e1395d1af605260c3617e700563205eef.tar.gz
libebml: don't rely on make -e, obey LDFLAGS
We need to obey LDFLAGS to get the correct hash style for external toolchains, and passing vars explicitly is better than relying on implicitly overriding everything blindly from the environment. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 64d874f768207a8a1e27a5c6edd3abe90607af03) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb44
1 files changed, 39 insertions, 5 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb b/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
index 71e2bfc56..b756a3924 100644
--- a/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
+++ b/meta-multimedia/recipes-mkv/libebml/libebml_1.3.0.bb
@@ -2,15 +2,49 @@ SUMMARY = "libebml is a C++ libary to parse EBML files"
2LICENSE = "LGPLv2.1" 2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=f14599a2f089f6ff8c97e2baa4e3d575" 3LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=f14599a2f089f6ff8c97e2baa4e3d575"
4 4
5SRC_URI = "http://dl.matroska.org/downloads/libebml/libebml-${PV}.tar.bz2" 5SRC_URI = "\
6 http://dl.matroska.org/downloads/libebml/libebml-${PV}.tar.bz2 \
7 file://ldflags.patch \
8 file://override-uname.patch \
9"
6SRC_URI[md5sum] = "efec729bf5a51e649e1d9d1f61c0ae7a" 10SRC_URI[md5sum] = "efec729bf5a51e649e1d9d1f61c0ae7a"
7SRC_URI[sha256sum] = "83b074d6b62715aa0080406ea84d33df2e44b5d874096640233a4db49b8096de" 11SRC_URI[sha256sum] = "83b074d6b62715aa0080406ea84d33df2e44b5d874096640233a4db49b8096de"
8 12
9EXTRA_OEMAKE = "-e MAKEFLAGS=" 13do_unpack[postfuncs] += "dos2unix"
10 14
11do_compile() { 15dos2unix () {
12 cd ${S}/make/linux 16 cr="$(printf '\r')"
13 oe_runmake CROSS="${TARGET_PREFIX}" 17 for f in make/*/Makefile; do
18 tr -d "$cr" <"$f" >"$f.new" && \
19 mv "$f.new" "$f"
20 done
21}
22
23LIBEBML_OS = "Unknown"
24LIBEBML_OS_linux = "Linux"
25LIBEBML_OS_darwin = "Darwin"
26LIBEBML_OS_mingw32 = "Windows"
27
28EXTRA_OEMAKE = "\
29 'TARGET_OS=${LIBEBML_OS}' \
30 \
31 'CXX=${CXX}' \
32 'LD=${CXX}' \
33 'AR=${AR}' \
34 'RANLIB=${RANLIB}' \
35 \
36 'DEBUGFLAGS=' \
37 'CPPFLAGS=${CPPFLAGS}' \
38 'CXXFLAGS=${CXXFLAGS}' \
39 'LDFLAGS=${LDFLAGS}' \
40 \
41 'prefix=${prefix}' \
42 'libdir=${libdir}' \
43 'includedir=${includedir}/ebml' \
44"
45
46do_compile () {
47 oe_runmake -C make/linux
14} 48}
15 49
16do_install() { 50do_install() {