summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-dvb
diff options
context:
space:
mode:
authorPeter BaĊĦista <pbasista@gmail.com>2023-01-12 11:54:48 +0100
committerKhem Raj <raj.khem@gmail.com>2023-01-12 09:02:10 -0800
commitbabfc021766d32578c5ed136897d22cef5abdd24 (patch)
treedde98f0837714404b0395844c1c541f49f9c449c /meta-multimedia/recipes-dvb
parent7a3ae99f59bf95c9d5433b0bdf0067e316eff094 (diff)
downloadmeta-openembedded-babfc021766d32578c5ed136897d22cef5abdd24.tar.gz
Make tvheadend recipe compatible with the latest tvheadend version
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-dvb')
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch8
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb3
2 files changed, 5 insertions, 6 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
index ff2e789e3..c6e20b75e 100644
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-adjust-for-64bit-time_t.patch
@@ -33,12 +33,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
33 } 33 }
34--- a/src/epggrab/module/psip.c 34--- a/src/epggrab/module/psip.c
35+++ b/src/epggrab/module/psip.c 35+++ b/src/epggrab/module/psip.c
36@@ -383,14 +383,14 @@ _psip_eit_callback_channel 36@@ -223,14 +223,14 @@ _psip_eit_callback_channel
37 37
38 tvhtrace(LS_PSIP, " %03d: [%s] eventid 0x%04x at %"PRItime_t", duration %d, title: '%s' (%d bytes)", 38 tvhtrace(LS_PSIP, " %03d: [%s] eventid 0x%04x at %"PRItime_t", duration %d, etmlocation %x, title: '%s' (%d bytes)",
39 i, ch ? channel_get_name(ch, channel_blank_name) : "(null)", 39 i, ch ? channel_get_name(ch, channel_blank_name) : "(null)",
40- eventid, start, length, 40- eventid, start, length, etmlocation,
41+ eventid, (intmax_t)start, length, 41+ eventid, (intmax_t)start, length, etmlocation,
42 lang_str_get(title, NULL), titlelen); 42 lang_str_get(title, NULL), titlelen);
43 43
44 save2 = changes2 = 0; 44 save2 = changes2 = 0;
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
index b3d9d6bf7..b3e5e78c7 100644
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
+++ b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
@@ -12,7 +12,7 @@ SRC_URI = "git://github.com/tvheadend/tvheadend.git;branch=master;protocol=https
12 file://0001-adjust-for-64bit-time_t.patch \ 12 file://0001-adjust-for-64bit-time_t.patch \
13 " 13 "
14 14
15SRCREV = "9a51cea492e4a5579ca3ddf9233fecfa419de078" 15SRCREV = "cc602833684953fc3e6f1c89d4f08f6dfef179e3"
16PV = "4.3+git${SRCPV}" 16PV = "4.3+git${SRCPV}"
17PKGV = "4.3+git${GITPKGV}" 17PKGV = "4.3+git${GITPKGV}"
18 18
@@ -30,4 +30,3 @@ EXTRA_OECONF:append:libc-musl = " --disable-execinfo"
30 30
31EXTRA_OEMAKE = "CFLAGS_NO_WERROR=yes" 31EXTRA_OEMAKE = "CFLAGS_NO_WERROR=yes"
32CLEANBROKEN = "1" 32CLEANBROKEN = "1"
33