diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-08-11 14:52:17 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-15 08:20:06 -0700 |
commit | bd0db062df54cfe9fc550db91be2134ddbf763e6 (patch) | |
tree | aa30f8c6e11b03ab196dd21c859477d173c56e26 /meta-multimedia/recipes-dvb/oscam | |
parent | 85b0d91d397fd46922c9266db13e725f36968837 (diff) | |
download | meta-openembedded-bd0db062df54cfe9fc550db91be2134ddbf763e6.tar.gz |
oscam: Upgrade to latest rev 11431 on trunk
Add patch to fix build with glibc 2.28+
Remove backported patches which are no longer needed
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-dvb/oscam')
3 files changed, 29 insertions, 41 deletions
diff --git a/meta-multimedia/recipes-dvb/oscam/oscam/0001-include-sys-sysmacros.h-for-major-minor-definitions.patch b/meta-multimedia/recipes-dvb/oscam/oscam/0001-include-sys-sysmacros.h-for-major-minor-definitions.patch new file mode 100644 index 0000000000..d3d89e333b --- /dev/null +++ b/meta-multimedia/recipes-dvb/oscam/oscam/0001-include-sys-sysmacros.h-for-major-minor-definitions.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From a372fe467495a674ad6244b67e83dfbfa8455f51 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 11 Aug 2018 13:54:32 -0700 | ||
4 | Subject: [PATCH] include sys/sysmacros.h for major/minor definitions | ||
5 | |||
6 | csctapi/ifd_db2com.c:27: undefined reference to `minor' | ||
7 | collect2: error: ld returned 1 exit status | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | globals.h | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/globals.h b/globals.h | ||
16 | index bd12244..9e10225 100644 | ||
17 | --- a/globals.h | ||
18 | +++ b/globals.h | ||
19 | @@ -36,6 +36,7 @@ | ||
20 | #include <termios.h> | ||
21 | #include <inttypes.h> | ||
22 | #include <sys/utsname.h> | ||
23 | +#include <sys/sysmacros.h> | ||
24 | |||
25 | /* | ||
26 | * The following hack is taken from Linux: include/linux/kconfig.h | ||
diff --git a/meta-multimedia/recipes-dvb/oscam/oscam/respect-cflags.patch b/meta-multimedia/recipes-dvb/oscam/oscam/respect-cflags.patch deleted file mode 100644 index 179d04a559..0000000000 --- a/meta-multimedia/recipes-dvb/oscam/oscam/respect-cflags.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | Upstream-Status: Backport | ||
2 | http://www.streamboard.tv/oscam/changeset/10068 | ||
3 | http://www.streamboard.tv/oscam/changeset/10070 | ||
4 | |||
5 | Index: /CMakeLists.txt | ||
6 | =================================================================== | ||
7 | --- a/CMakeLists.txt (revision 10067) | ||
8 | +++ b/CMakeLists.txt (revision 10068) | ||
9 | @@ -625,8 +625,8 @@ | ||
10 | list(GET GCC_VERSION_COMPONENTS 0 GCC_MINOR) | ||
11 | add_definitions ("-W -Wall ") | ||
12 | - set (CMAKE_C_FLAGS "-Wall -O2") | ||
13 | - set (CMAKE_CXX_FLAGS "-Wall -O2") | ||
14 | - set (CMAKE_C_FLAGS_DEBUG "-O0 -ggdb") | ||
15 | - set (CMAKE_CXX_FLAGS_DEBUG "-O0 -ggdb") | ||
16 | + set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -O2") | ||
17 | + set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -O2") | ||
18 | + set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -ggdb") | ||
19 | + set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 -ggdb") | ||
20 | endif (CMAKE_COMPILER_IS_GNUCC) | ||
21 | # some optimisations | ||
22 | Index: /csctapi/CMakeLists.txt | ||
23 | =================================================================== | ||
24 | --- a/csctapi/CMakeLists.txt (revision 10069) | ||
25 | +++ b/csctapi/CMakeLists.txt (revision 10070) | ||
26 | @@ -6,8 +6,8 @@ | ||
27 | list(GET GCC_VERSION_COMPONENTS 0 GCC_MINOR) | ||
28 | add_definitions ("-W -Wall ") | ||
29 | - set (CMAKE_C_FLAGS "-Wall -O2") | ||
30 | - set (CMAKE_CXX_FLAGS "-Wall -O2") | ||
31 | - set (CMAKE_C_FLAGS_DEBUG "-O0 -ggdb") | ||
32 | - set (CMAKE_CXX_FLAGS_DEBUG "-O0 -ggdb") | ||
33 | + set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -O2") | ||
34 | + set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -O2") | ||
35 | + set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -ggdb") | ||
36 | + set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 -ggdb") | ||
37 | endif (CMAKE_COMPILER_IS_GNUCC) | ||
38 | # Mac extra removes to avoid ranlib warnings in some situations | ||
diff --git a/meta-multimedia/recipes-dvb/oscam/oscam_svn.bb b/meta-multimedia/recipes-dvb/oscam/oscam_svn.bb index cac517ff5d..2bd970fd5d 100644 --- a/meta-multimedia/recipes-dvb/oscam/oscam_svn.bb +++ b/meta-multimedia/recipes-dvb/oscam/oscam_svn.bb | |||
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | |||
7 | DEPENDS = "libusb1 openssl pcsc-lite" | 7 | DEPENDS = "libusb1 openssl pcsc-lite" |
8 | 8 | ||
9 | SRC_URI = "svn://www.streamboard.tv/svn/oscam;module=trunk;protocol=http \ | 9 | SRC_URI = "svn://www.streamboard.tv/svn/oscam;module=trunk;protocol=http \ |
10 | file://respect-cflags.patch \ | 10 | file://0001-include-sys-sysmacros.h-for-major-minor-definitions.patch \ |
11 | " | 11 | " |
12 | SRCREV = "9164" | 12 | SRCREV = "11431" |
13 | PV = "1.10+${SRCPV}" | 13 | PV = "1.10+${SRCPV}" |
14 | 14 | ||
15 | S = "${WORKDIR}/trunk" | 15 | S = "${WORKDIR}/trunk" |