summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-multimedia/recipes-connectivity
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gssdp_1.2.3.bb2
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-av.inc2
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb2
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.10.0.bb2
-rw-r--r--meta-multimedia/recipes-connectivity/gupnp/gupnp.inc6
-rw-r--r--meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb20
6 files changed, 17 insertions, 17 deletions
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.2.3.bb b/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.2.3.bb
index 7d82c3e2e..8f27ae292 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.2.3.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gssdp_1.2.3.bb
@@ -17,4 +17,4 @@ PACKAGECONFIG[sniffer] = "-Dsniffer=true,-Dsniffer=false,gtk+3,"
17 17
18PACKAGES =+ "gssdp-tools" 18PACKAGES =+ "gssdp-tools"
19 19
20FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade" 20FILES:gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-av.inc b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av.inc
index 054450156..a06c98e15 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-av.inc
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-av.inc
@@ -7,7 +7,7 @@ inherit autotools pkgconfig gobject-introspection vala
7 7
8# Copy vapigen.m4 so that it doesn't get removed by vala class 8# Copy vapigen.m4 so that it doesn't get removed by vala class
9# (normally this would be the right thing to do, but in gupnp-av the vapigen.m4 has only a custom macro) 9# (normally this would be the right thing to do, but in gupnp-av the vapigen.m4 has only a custom macro)
10do_configure_prepend() { 10do_configure:prepend() {
11 cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true 11 cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true
12} 12}
13 13
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb
index 3cafd6976..7cb9ff91e 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-dlna_0.10.5.bb
@@ -16,4 +16,4 @@ inherit autotools pkgconfig gobject-introspection vala
16PACKAGECONFIG ?= "gstreamer" 16PACKAGECONFIG ?= "gstreamer"
17PACKAGECONFIG[gstreamer] = "--enable-gstreamer-metadata-backend,--disable-gstreamer-metadata-backend,gstreamer1.0 gstreamer1.0-plugins-base" 17PACKAGECONFIG[gstreamer] = "--enable-gstreamer-metadata-backend,--disable-gstreamer-metadata-backend,gstreamer1.0 gstreamer1.0-plugins-base"
18 18
19FILES_${PN} += "${datadir}/gupnp-dlna-2.0/dlna-profiles" 19FILES:${PN} += "${datadir}/gupnp-dlna-2.0/dlna-profiles"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.10.0.bb b/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.10.0.bb
index bf84e7b73..20129c70f 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.10.0.bb
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp-tools_0.10.0.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
4 file://src/network-light/main.c;beginline=1;endline=21;md5=2c39b3a000495dabd4932f231c7efed8" 4 file://src/network-light/main.c;beginline=1;endline=21;md5=2c39b3a000495dabd4932f231c7efed8"
5DEPENDS = "gupnp gupnp-av gtk+3 glib-2.0-native intltool-native" 5DEPENDS = "gupnp gupnp-av gtk+3 glib-2.0-native intltool-native"
6RRECOMMENDS_${PN} = "adwaita-icon-theme" 6RRECOMMENDS:${PN} = "adwaita-icon-theme"
7 7
8SRC_URI = "http://download.gnome.org/sources/${BPN}/0.10/${BPN}-${PV}.tar.xz" 8SRC_URI = "http://download.gnome.org/sources/${BPN}/0.10/${BPN}-${PV}.tar.xz"
9SRC_URI[md5sum] = "8c66d4aca756478615761a26ed7c8dba" 9SRC_URI[md5sum] = "8c66d4aca756478615761a26ed7c8dba"
diff --git a/meta-multimedia/recipes-connectivity/gupnp/gupnp.inc b/meta-multimedia/recipes-connectivity/gupnp/gupnp.inc
index 2920581c5..a959751e0 100644
--- a/meta-multimedia/recipes-connectivity/gupnp/gupnp.inc
+++ b/meta-multimedia/recipes-connectivity/gupnp/gupnp.inc
@@ -6,10 +6,10 @@ DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2"
6 6
7inherit meson pkgconfig vala gobject-introspection 7inherit meson pkgconfig vala gobject-introspection
8 8
9FILES_${PN} = "${libdir}/*.so.*" 9FILES:${PN} = "${libdir}/*.so.*"
10FILES_${PN}-dev += "${bindir}/gupnp-binding-tool*" 10FILES:${PN}-dev += "${bindir}/gupnp-binding-tool*"
11 11
12RDEPENDS_${PN}-dev = "python3 python3-xml" 12RDEPENDS:${PN}-dev = "python3 python3-xml"
13 13
14SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess" 14SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
15 15
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb
index 01705a8f7..c08ab11b2 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb
@@ -9,8 +9,8 @@ LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10 10
11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native" 11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native"
12RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info" 12RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
13RRECOMMENDS_${PN} = "rygel-plugin-media-export" 13RRECOMMENDS:${PN} = "rygel-plugin-media-export"
14 14
15inherit gnomebase vala gobject-introspection gettext systemd features_check 15inherit gnomebase vala gobject-introspection gettext systemd features_check
16 16
@@ -24,7 +24,7 @@ EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer"
24 24
25PACKAGECONFIG ?= "external mpris ruih media-export gst-launch" 25PACKAGECONFIG ?= "external mpris ruih media-export gst-launch"
26 26
27PACKAGECONFIG_append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}" 27PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
28 28
29PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin" 29PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
30PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin" 30PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
@@ -36,7 +36,7 @@ PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin"
36 36
37LIBV = "2.6" 37LIBV = "2.6"
38 38
39do_install_append() { 39do_install:append() {
40 # Remove .la files for loadable modules 40 # Remove .la files for loadable modules
41 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la 41 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
42 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la 42 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
@@ -49,17 +49,17 @@ do_install_append() {
49 fi 49 fi
50} 50}
51 51
52FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons" 52FILES:${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
53FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug" 53FILES:${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
54 54
55PACKAGES += "${PN}-meta" 55PACKAGES += "${PN}-meta"
56ALLOW_EMPTY_${PN}-meta = "1" 56ALLOW_EMPTY:${PN}-meta = "1"
57 57
58PACKAGES_DYNAMIC = "${PN}-plugin-*" 58PACKAGES_DYNAMIC = "${PN}-plugin-*"
59 59
60SYSTEMD_SERVICE_${PN} = "rygel.service" 60SYSTEMD_SERVICE:${PN} = "rygel.service"
61 61
62python populate_packages_prepend () { 62python populate_packages:prepend () {
63 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}') 63 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
64 postinst = d.getVar('plugin_postinst') 64 postinst = d.getVar('plugin_postinst')
65 pkgs = [] 65 pkgs = []
@@ -68,5 +68,5 @@ python populate_packages_prepend () {
68 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) 68 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
69 69
70 metapkg = d.getVar('PN') + '-meta' 70 metapkg = d.getVar('PN') + '-meta'
71 d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs)) 71 d.setVar('RDEPENDS:' + metapkg, ' '.join(pkgs))
72} 72}