summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-24 21:46:21 -0700
committerKhem Raj <raj.khem@gmail.com>2022-08-25 23:08:11 -0700
commit07fd046936d3d74c885bfe62de46c593ea502d05 (patch)
treeab14a2f6045e49087a030dada3058c9c5aa0b294 /meta-multimedia/recipes-connectivity
parent6147241ebe971737c6e4a922c09dda4163befa66 (diff)
downloadmeta-openembedded-07fd046936d3d74c885bfe62de46c593ea502d05.tar.gz
rygel: Upgrade to 0.40.4
Switch to meson build system Fix build with clang Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-multimedia/recipes-connectivity')
-rw-r--r--meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb (renamed from meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb)49
1 files changed, 35 insertions, 14 deletions
diff --git a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb b/meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb
index ec7824b60..8bc8767d8 100644
--- a/meta-multimedia/recipes-connectivity/rygel/rygel_0.38.3.bb
+++ b/meta-multimedia/recipes-connectivity/rygel/rygel_0.40.4.bb
@@ -8,34 +8,55 @@ HOMEPAGE = "http://live.gnome.org/Rygel"
8LICENSE = "LGPL-2.1-only" 8LICENSE = "LGPL-2.1-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10 10
11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native" 11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 \
12 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 \
13 libunistring sqlite3 intltool-native gst-editing-services"
14
12RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info" 15RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
13RRECOMMENDS:${PN} = "rygel-plugin-media-export" 16RRECOMMENDS:${PN} = "rygel-plugin-media-export"
14 17
15inherit gnomebase vala gobject-introspection gettext systemd features_check 18inherit gnomebase features_check vala gobject-introspection gettext systemd meson
16 19
17# gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured 20# gobject-introspection is mandatory for libmediaart-2.0 and cannot be configured
18REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" 21REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
19 22
20SRC_URI[archive.md5sum] = "7f95401903a3f855b464d5152b9d4c07" 23SRC_URI[archive.sha256sum] = "736d8adbe8615f6cbc8fcfff9845dc985fd10e16629da236b4b52dbedf0a348b"
21SRC_URI[archive.sha256sum] = "08c21a577f7bdad26446a75ffa32778b26842c3b1188165f0b19818559747d00"
22
23EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer"
24 24
25PACKAGECONFIG ?= "external mpris ruih media-export gst-launch" 25GNOMEBASEBUILDCLASS = "meson"
26GIR_MESON_ENABLE_FLAG = 'enabled'
27GIR_MESON_DISABLE_FLAG = 'disabled'
26 28
29EXTRA_OEMESON = "-Dengines=gstreamer -Dplugins=${@strip_comma('${RYGEL_PLUGINS}')}"
27PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}" 30PACKAGECONFIG:append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
28 31
29PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin" 32PACKAGECONFIG ?= "external mpris ruih media-export gst-launch"
30PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin" 33
31PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin" 34PACKAGECONFIG[external] = ""
32PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin" 35PACKAGECONFIG[mpris] = ""
33PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin" 36PACKAGECONFIG[ruih] = ""
34PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3" 37PACKAGECONFIG[media-export] = ""
35PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin" 38PACKAGECONFIG[gst-launch] = ""
39PACKAGECONFIG[lms] = ""
40PACKAGECONFIG[tracker3] = ""
41PACKAGECONFIG[gtk+3] = ",-Dgtk=false,gtk+3"
42
43RYGEL_PLUGINS = ""
44RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'external', ',external', '', d)}"
45RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'mpris', ',mpris', '', d)}"
46RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'ruih', ',ruih', '', d)}"
47RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'gst-launch', ',gst-launch', '', d)}"
48RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'lms', ',lms', '', d)}"
49RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'media-export', ',media-export', '', d)}"
50RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'tracker3', ',tracker3', '', d)}"
51RYGEL_PLUGINS:append ="${@bb.utils.contains('PACKAGECONFIG', 'playbin', ',playbin', '', d)}"
36 52
37LIBV = "2.6" 53LIBV = "2.6"
38 54
55CFLAGS:append:toolchain-clang = " -Wno-error=int-conversion"
56
57def strip_comma(s):
58 return s.strip(',')
59
39do_install:append() { 60do_install:append() {
40 # Remove .la files for loadable modules 61 # Remove .la files for loadable modules
41 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la 62 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la