summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-31 14:49:11 -0800
committerKhem Raj <raj.khem@gmail.com>2022-12-31 14:50:37 -0800
commit944e9dcdc8a05294f79a69c2f2b6ed8c5bdb0819 (patch)
tree963e30574072e6d5ed5bdf0748b613399884dc1d /meta-initramfs
parentc8a56b2ce0d00d078bd46f2265a9cd2ad38d0b85 (diff)
downloadmeta-openembedded-944e9dcdc8a05294f79a69c2f2b6ed8c5bdb0819.tar.gz
dracut: Do not undefine _FILE_OFFSET_BITS
Fixes build with 64bit time_t Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut/0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch32
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_056.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut/0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch b/meta-initramfs/recipes-devtools/dracut/dracut/0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch
new file mode 100644
index 000000000..170df7119
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/dracut/dracut/0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,32 @@
1From 7f8ef553b7c433af153d48c6a16b2943780abf67 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 31 Dec 2022 14:41:52 -0800
4Subject: [PATCH] install: Do not undef _FILE_OFFSET_BITS
5
6_FILE_OFFSET_BITS is a feature test macro to determine largefile
7support. Usually its set to 64 on systems supporting LFS. Its also
8needed to be set to 64 for supporting 64bit time_t on glibc on 32bit
9systems. If its undefined explicitly, then 64bit time_t can not be
10enabled.
11
12Upstream-Status: Submitted [https://github.com/dracutdevs/dracut/pull/2157]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/install/dracut-install.c | 1 -
16 1 file changed, 1 deletion(-)
17
18diff --git a/src/install/dracut-install.c b/src/install/dracut-install.c
19index dda0caca..05a67a03 100644
20--- a/src/install/dracut-install.c
21+++ b/src/install/dracut-install.c
22@@ -22,7 +22,6 @@
23 #ifndef _GNU_SOURCE
24 #define _GNU_SOURCE
25 #endif
26-#undef _FILE_OFFSET_BITS
27 #include <ctype.h>
28 #include <errno.h>
29 #include <fcntl.h>
30--
312.39.0
32
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_056.bb b/meta-initramfs/recipes-devtools/dracut/dracut_056.bb
index 7b8900610..364beec5d 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_056.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_056.bb
@@ -11,6 +11,7 @@ SRCREV = "631d5f72a223288aa1f48bb8e8d0313e75947400"
11SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http;branch=master \ 11SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http;branch=master \
12 file://0001-util.h-include-sys-reg.h-when-libc-glibc.patch \ 12 file://0001-util.h-include-sys-reg.h-when-libc-glibc.patch \
13 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \ 13 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
14 file://0001-install-Do-not-undef-_FILE_OFFSET_BITS.patch \
14 " 15 "
15 16
16DEPENDS += "kmod" 17DEPENDS += "kmod"