summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-01-30 10:05:50 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-02-19 13:12:36 +0000
commit90045a49e50eb0177a8aee5cc318caf037ac603d (patch)
treea974257da50e3b0ae6da7e401ff5c0e191a5ee53 /meta-initramfs
parent398f30aa0689e483ae196cc035643a854d169947 (diff)
downloadmeta-openembedded-90045a49e50eb0177a8aee5cc318caf037ac603d.tar.gz
dracut: update to 036
* Patch was applied upstream, delete it * Add coreutils dep to stop scripts from erroring out * bump PE to since 'git' > '036' Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch39
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb13
2 files changed, 8 insertions, 44 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
deleted file mode 100644
index 7dc62ded7..000000000
--- a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From c92ea797c43aa811e98b6bd8fb4aae921fa08592 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 10 Jan 2014 21:11:40 +0100
4Subject: [PATCH] Use builtin xz/lzma option to use all cores for multihreaded
5 compression
6
7This removes the dependency on 'getconf' as well, which is not installed by default on my embedded systems.
8
9Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
10Upstream-status: Submitted
11
12---
13 dracut.sh | 6 ++----
14 1 file changed, 2 insertions(+), 4 deletions(-)
15
16diff --git a/dracut.sh b/dracut.sh
17index 11dcd0e..2e6ea67 100755
18--- a/dracut.sh
19+++ b/dracut.sh
20@@ -697,14 +697,12 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
21 # eliminate IFS hackery when messing with fw_dir
22 fw_dir=${fw_dir//:/ }
23
24-cpu_count=$(getconf _NPROCESSORS_ONLN)
25-
26 # handle compression options.
27 [[ $compress ]] || compress="gzip"
28 case $compress in
29 bzip2) compress="bzip2 -9";;
30- lzma) compress="lzma -9 ${cpu_count:+-T$cpu_count}";;
31- xz) compress="xz --check=crc32 --lzma2=dict=1MiB ${cpu_count:+-T$cpu_count}";;
32+ lzma) compress="lzma -9 -T0";;
33+ xz) compress="xz --check=crc32 --lzma2=dict=1MiB -T0";;
34 gzip) compress="gzip -9"; command -v pigz > /dev/null 2>&1 && compress="pigz -9";;
35 lzo) compress="lzop -9";;
36 lz4) compress="lz4 -9";;
37--
381.8.0
39
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index ccc4e7d6b..945ba0f21 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -4,10 +4,12 @@ DESCRIPTION = "Dracut is an event driven initramfs infrastructure. dracut (the t
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6 6
7SRCREV = "bb1ba3a1ca9dd6284f6319eb197de4a757a7f99d" 7PE = "1"
8SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git \ 8PV = "036"
9 file://0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch \ 9
10 " 10# v036 tag
11SRCREV = "d50a99c5ceeb7107f624c5d3238d37509b2217a8"
12SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git"
11 13
12S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
13 15
@@ -34,5 +36,6 @@ FILES_${PN} += "${datadir}/bash-completion \
34RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid bash ldd" 36RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid bash ldd"
35# This could be optimized a bit, but let's avoid non-booting systems :) 37# This could be optimized a bit, but let's avoid non-booting systems :)
36RRECOMMENDS_${PN} = " \ 38RRECOMMENDS_${PN} = " \
37 kernel-modules \ 39 kernel-modules \
40 coreutils \
38 " 41 "