summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-initramfs/recipes-kernel
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-initramfs/recipes-kernel')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/arm_crashdump.patch12
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/cflags_static.patch11
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ifdown_errno.patch11
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-elf-rel.patch61
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-syscall.patch44
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ppc__lshrdi3.patch18
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_flags.patch21
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_string.patch9
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sha256.patch13
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sysconf_nrprocessors.patch13
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_basename.patch14
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_kexec_test.patch13
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_sys_io.patch21
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_vfscanf.patch27
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb37
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bb26
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bb26
17 files changed, 377 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/arm_crashdump.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/arm_crashdump.patch
new file mode 100644
index 000000000..0ff61e543
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/arm_crashdump.patch
@@ -0,0 +1,12 @@
1--- a/kexec/arch/arm/crashdump-arm.c
2+++ b/kexec/arch/arm/crashdump-arm.c
3@@ -20,7 +20,7 @@
4 * along with this program; if not, write to the Free Software
5 * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
6 */
7-#include <elf.h>
8+#include "../../../include/elf.h"
9 #include <errno.h>
10 #include <stdio.h>
11 #include <stdlib.h>
12
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/cflags_static.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/cflags_static.patch
new file mode 100644
index 000000000..35100a3b4
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/cflags_static.patch
@@ -0,0 +1,11 @@
1--- a/Makefile.in
2+++ b/Makefile.in
3@@ -46,7 +46,7 @@
4 # where necessary.
5 CPPFLAGS = @CPPFLAGS@ -I$(srcdir)/include -I$(srcdir)/util_lib/include \
6 -Iinclude/
7-CFLAGS = @CFLAGS@ -fno-strict-aliasing -Wall -Wstrict-prototypes
8+CFLAGS = @CFLAGS@ -static -fno-strict-aliasing -Wall -Wstrict-prototypes
9 PURGATORY_EXTRA_CFLAGS = @PURGATORY_EXTRA_CFLAGS@
10 ASFLAGS = @ASFLAGS@
11 LDFLAGS = @LDFLAGS@
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ifdown_errno.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ifdown_errno.patch
new file mode 100644
index 000000000..7f8cddd35
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ifdown_errno.patch
@@ -0,0 +1,11 @@
1--- a/kexec/ifdown.c
2+++ b/kexec/ifdown.c
3@@ -14,7 +14,7 @@
4 #include <sys/ioctl.h>
5 #include <sys/socket.h>
6 #include <sys/time.h>
7-#include <sys/errno.h>
8+#include <errno.h>
9
10 #include <net/if.h>
11 #include <netinet/in.h>
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-elf-rel.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-elf-rel.patch
new file mode 100644
index 000000000..c666afcac
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-elf-rel.patch
@@ -0,0 +1,61 @@
1--- a/kexec/kexec-elf-rel.c
2+++ b/kexec/kexec-elf-rel.c
3@@ -4,7 +4,7 @@
4 #include <stdio.h>
5 #include <errno.h>
6 #include <stdlib.h>
7-#include "elf.h"
8+#include "../include/elf.h"
9 #include <boot/elf_boot.h>
10 #include "kexec.h"
11 #include "kexec-elf.h"
12
13--- a/kexec/arch/arm/kexec-elf-rel-arm.c
14+++ b/kexec/arch/arm/kexec-elf-rel-arm.c
15@@ -1,5 +1,5 @@
16 #include <stdio.h>
17-#include <elf.h>
18+#include "../../../include/elf.h"
19 #include "../../kexec.h"
20 #include "../../kexec-elf.h"
21
22
23--- a/kexec/arch/i386/kexec-elf-rel-x86.c
24+++ b/kexec/arch/i386/kexec-elf-rel-x86.c
25@@ -1,5 +1,5 @@
26 #include <stdio.h>
27-#include <elf.h>
28+#include "../../../include/elf.h"
29 #include "../../kexec.h"
30 #include "../../kexec-elf.h"
31
32
33--- a/kexec/arch/ppc/kexec-elf-rel-ppc.c
34+++ b/kexec/arch/ppc/kexec-elf-rel-ppc.c
35@@ -1,5 +1,5 @@
36 #include <stdio.h>
37-#include <elf.h>
38+#include "../../../include/elf.h"
39 #include "../../kexec.h"
40 #include "../../kexec-elf.h"
41
42
43--- a/kexec/arch/ppc64/kexec-elf-rel-ppc64.c
44+++ b/kexec/arch/ppc64/kexec-elf-rel-ppc64.c
45@@ -1,5 +1,5 @@
46 #include <stdio.h>
47-#include <elf.h>
48+#include "../../../include/elf.h"
49 #include <string.h>
50 #include "../../kexec.h"
51 #include "../../kexec-elf.h"
52
53--- a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
54+++ b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
55@@ -1,5 +1,5 @@
56 #include <stdio.h>
57-#include <elf.h>
58+#include "../../../include/elf.h"
59 #include "../../kexec.h"
60 #include "../../kexec-elf.h"
61
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-syscall.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-syscall.patch
new file mode 100644
index 000000000..081de1bb5
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/kexec-syscall.patch
@@ -0,0 +1,44 @@
1--- a/kexec/kexec-syscall.h
2+++ b/kexec/kexec-syscall.h
3@@ -2,7 +2,7 @@
4 #define KEXEC_SYSCALL_H
5
6 #define __LIBRARY__
7-#include <syscall.h>
8+/*#include <syscall.h>*/
9 #include <sys/syscall.h>
10 #include <unistd.h>
11
12@@ -23,6 +23,7 @@
13 #define LINUX_REBOOT_CMD_KEXEC 0x45584543
14
15 #ifndef __NR_kexec_load
16+/*
17 #ifdef __i386__
18 #define __NR_kexec_load 283
19 #endif
20@@ -61,19 +62,21 @@
21 #ifndef __NR_kexec_load
22 #error Unknown processor architecture. Needs a kexec_load syscall number.
23 #endif
24+*/
25 #endif /*ifndef __NR_kexec_load*/
26
27 struct kexec_segment;
28-
29+/*
30 static inline long kexec_load(void *entry, unsigned long nr_segments,
31 struct kexec_segment *segments, unsigned long flags)
32 {
33 return (long) syscall(__NR_kexec_load, entry, nr_segments, segments, flags);
34 }
35-
36+*/
37 static inline long kexec_reboot(void)
38 {
39- return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
40+ //return (long) syscall(__NR_reboot, LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
41+ return __reboot(LINUX_REBOOT_MAGIC1, LINUX_REBOOT_MAGIC2, LINUX_REBOOT_CMD_KEXEC, 0);
42 }
43
44
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ppc__lshrdi3.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ppc__lshrdi3.patch
new file mode 100644
index 000000000..56cdfb08d
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/ppc__lshrdi3.patch
@@ -0,0 +1,18 @@
1--- a/purgatory/arch/ppc/crt.S
2+++ b/purgatory/arch/ppc/crt.S
3@@ -249,6 +249,7 @@
4 *
5 */
6
7+/* already defined in misc.S
8 _GLOBAL(__lshrdi3)
9 subfic 6,5,32
10 srw 4,4,5 # LSW = count > 31 ? 0 : LSW >> count
11@@ -259,5 +260,7 @@
12 srw 3,3,5 # MSW = MSW >> count
13 or 4,4,7 # LSW |= t2
14 blr
15+*/
16+
17 #endif
18 #endif
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_flags.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_flags.patch
new file mode 100644
index 000000000..41fc1168f
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_flags.patch
@@ -0,0 +1,21 @@
1--- a/purgatory/Makefile
2+++ b/purgatory/Makefile
3@@ -47,7 +47,7 @@
4 $(PURGATORY): CC=$(TARGET_CC)
5 $(PURGATORY): CFLAGS+=$(PURGATORY_EXTRA_CFLAGS) \
6 $($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
7- -Os -fno-builtin -ffreestanding
8+ -Os -fno-builtin -ffreestanding -nostdinc
9
10 $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
11 -I$(srcdir)/purgatory/include \
12@@ -61,7 +61,8 @@
13
14 $(PURGATORY): $(PURGATORY_OBJS)
15 $(MKDIR) -p $(@D)
16- $(CC) $(LDFLAGS) -o $@ $^
17+# $(CC) $(LDFLAGS) -o $@ $^
18+ $(LD) $(LDFLAGS) -o $@ $^
19
20 # $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
21
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_string.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_string.patch
new file mode 100644
index 000000000..5710561b1
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/purgatory_string.patch
@@ -0,0 +1,9 @@
1--- a/purgatory/string.c
2+++ b/purgatory/string.c
3@@ -1,5 +1,5 @@
4 #include <stddef.h>
5-#include <string.h>
6+/* #include <string.h> */
7
8 size_t strnlen(const char *s, size_t max)
9 {
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sha256.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sha256.patch
new file mode 100644
index 000000000..85bf7aa4f
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sha256.patch
@@ -0,0 +1,13 @@
1--- a/util_lib/include/sha256.h
2+++ b/util_lib/include/sha256.h
3@@ -1,7 +1,8 @@
4 #ifndef SHA256_H
5 #define SHA256_H
6
7-#include <sys/types.h>
8+//#include <sys/types.h>
9+#include <stddef.h>
10 #include <stdint.h>
11
12 typedef struct
13
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sysconf_nrprocessors.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sysconf_nrprocessors.patch
new file mode 100644
index 000000000..04a97e6bc
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/sysconf_nrprocessors.patch
@@ -0,0 +1,13 @@
1--- a/kexec/crashdump-elf.c
2+++ b/kexec/crashdump-elf.c
3@@ -47,7 +47,8 @@
4 if (xen_present())
5 nr_cpus = xen_get_nr_phys_cpus();
6 else
7- nr_cpus = sysconf(_SC_NPROCESSORS_CONF);
8+ /*nr_cpus = sysconf(_SC_NPROCESSORS_CONF);*/
9+ nr_cpus = 1;
10
11 if (nr_cpus < 0) {
12 return -1;
13
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_basename.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_basename.patch
new file mode 100644
index 000000000..77a1c01a1
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_basename.patch
@@ -0,0 +1,14 @@
1--- a/kexec/arch/i386/x86-linux-setup.c
2+++ b/kexec/arch/i386/x86-linux-setup.c
3@@ -280,9 +280,9 @@ static int add_edd_entry(struct x86_linu
4 memset(edd_info, 0, sizeof(struct edd_info));
5
6 /* extract the device number */
7- if (sscanf(basename(sysfs_name), "int13_dev%hhx", &devnum) != 1) {
8+ if (sscanf(strrchr(sysfs_name,'/') + 1, "int13_dev%hhx", &devnum) != 1) {
9 fprintf(stderr, "Invalid format of int13_dev dir "
10- "entry: %s\n", basename(sysfs_name));
11+ "entry: %s\n", strrchr(sysfs_name,'/') + 1);
12 return -1;
13 }
14
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_kexec_test.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_kexec_test.patch
new file mode 100644
index 000000000..9500bd604
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_kexec_test.patch
@@ -0,0 +1,13 @@
1--- a/Makefile.in
2+++ b/Makefile.in
3@@ -106,8 +106,8 @@
4
5 MAN_PAGES:= kexec/kexec.8
6 MAN_PAGES+= kdump/kdump.8
7-BINARIES_i386:= $(SBINDIR)/kexec $(PKGLIBDIR)/kexec_test
8-BINARIES_x86_64:=$(SBINDIR)/kexec $(PKGLIBDIR)/kexec_test
9+BINARIES_i386:= $(SBINDIR)/kexec
10+BINARIES_x86_64:=$(SBINDIR)/kexec
11 BINARIES:=$(SBINDIR)/kexec $(SBINDIR)/kdump $(BINARIES_$(ARCH))
12
13 TARGETS:=$(BINARIES) $(MAN_PAGES)
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_sys_io.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_sys_io.patch
new file mode 100644
index 000000000..a497c9a63
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_sys_io.patch
@@ -0,0 +1,21 @@
1--- a/purgatory/arch/i386/pic.c
2+++ b/purgatory/arch/i386/pic.c
3@@ -16,7 +16,7 @@
4 * along with this program; if not, write to the Free Software
5 * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
6 */
7-#include <sys/io.h>
8+#include "include/arch/io.h"
9 #include <purgatory.h>
10 #include "purgatory-x86.h"
11
12
13--- a/purgatory/arch/i386/vga.c
14+++ b/purgatory/arch/i386/vga.c
15@@ -1,4 +1,4 @@
16-#include <sys/io.h>
17+#include "include/arch/io.h"
18 #include <purgatory.h>
19 #include "purgatory-x86.h"
20
21
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_vfscanf.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_vfscanf.patch
new file mode 100644
index 000000000..cad695154
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/x86_vfscanf.patch
@@ -0,0 +1,27 @@
1--- a/kexec/arch/i386/x86-linux-setup.c
2+++ b/kexec/arch/i386/x86-linux-setup.c
3@@ -176,6 +176,8 @@ static int file_scanf(const char *dir, c
4 FILE *fp;
5 int retno;
6 char filename[PATH_MAX];
7+ long line_size = MAX_LINE;
8+ char *line;
9
10 snprintf(filename, PATH_MAX, "%s/%s", dir, file);
11 filename[PATH_MAX-1] = 0;
12@@ -186,7 +188,14 @@ static int file_scanf(const char *dir, c
13 }
14
15 va_start(argptr, scanf_line);
16- retno = vfscanf(fp, scanf_line, argptr);
17+
18+ line = xmalloc(sizeof(line) * line_size);
19+ while(fgets(line, sizeof(line), fp) != NULL ) {
20+ line_size += MAX_LINE;
21+ line = xrealloc(line,line_size);
22+ }
23+ retno = vsscanf(line, scanf_line, argptr);
24+
25 va_end(argptr);
26
27 fclose(fp);
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
new file mode 100644
index 000000000..b1b6ffca4
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc_2.0.2.bb
@@ -0,0 +1,37 @@
1# the binaries are statically linked against klibc
2require recipes-kernel/kexec/kexec-tools.inc
3SUMMARY = "Kexec tools, statically compiled against klibc"
4SRC_URI[md5sum] = "92eff93b097475b7767f8c98df84408a"
5SRC_URI[sha256sum] = "09e180ff36dee087182cdc939ba6c6917b6adbb5fc12d589f31fd3659b6471f2"
6
7inherit klibc
8
9FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
10
11SRC_URI += " \
12 file://kexec-elf-rel.patch \
13 file://kexec-syscall.patch \
14 file://cflags_static.patch \
15 file://ifdown_errno.patch \
16 file://purgatory_flags.patch \
17 file://purgatory_string.patch \
18 file://sha256.patch \
19 file://sysconf_nrprocessors.patch \
20 "
21
22SRC_URI_append_arm = " file://arm_crashdump.patch"
23SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch"
24SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
25SRC_URI_append_x86-64 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
26
27S = "${WORKDIR}/kexec-tools-${PV}"
28
29EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
30
31CFLAGS += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32"
32CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64"
33
34PACKAGES =+ "kexec-klibc kdump-klibc"
35
36FILES_kexec-klibc = "${sbindir}/kexec"
37FILES_kdump-klibc = "${sbindir}/kdump"
diff --git a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bb b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bb
new file mode 100644
index 000000000..a823e0fb3
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.10.bb
@@ -0,0 +1,26 @@
1require recipes-kernel/linux/linux-yocto-tiny_3.10.bb
2SUMMARY = "Yocto tiny kernel embedding a minimalistic kexecboot initramfs"
3
4PACKAGES = ""
5PROVIDES = ""
6
7KERNEL_IMAGE_BASE_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${PV}-${MACHINE}"
8KERNEL_IMAGE_SYMLINK_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${MACHINE}"
9
10INITRAMFS_IMAGE = "initramfs-kexecboot-klibc-image"
11INITRAMFS_TASK = "${INITRAMFS_IMAGE}:do_rootfs"
12
13# disable unneeded tasks
14do_install[noexec] = "1"
15do_package[noexec] = "1"
16do_package_qa[noexec] = "1"
17do_packagedata[noexec] = "1"
18do_package_deb[noexec] = "1"
19do_package_ipk[noexec] = "1"
20do_package_rpm[noexec] = "1"
21do_package_tar[noexec] = "1"
22do_package_write_deb[noexec] = "1"
23do_package_write_ipk[noexec] = "1"
24do_package_write_rpm[noexec] = "1"
25do_package_write_tar[noexec] = "1"
26do_populate_sysroot[noexec] = "1"
diff --git a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bb b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bb
new file mode 100644
index 000000000..f3296c7e8
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_3.17.bb
@@ -0,0 +1,26 @@
1require recipes-kernel/linux/linux-yocto-tiny_3.17.bb
2SUMMARY = "Yocto tiny kernel embedding a minimalistic kexecboot initramfs"
3
4PACKAGES = ""
5PROVIDES = ""
6
7KERNEL_IMAGE_BASE_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${PV}-${MACHINE}"
8KERNEL_IMAGE_SYMLINK_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${MACHINE}"
9
10INITRAMFS_IMAGE = "initramfs-kexecboot-klibc-image"
11INITRAMFS_TASK = "${INITRAMFS_IMAGE}:do_rootfs"
12
13# disable unneeded tasks
14do_install[noexec] = "1"
15do_package[noexec] = "1"
16do_package_qa[noexec] = "1"
17do_packagedata[noexec] = "1"
18do_package_deb[noexec] = "1"
19do_package_ipk[noexec] = "1"
20do_package_rpm[noexec] = "1"
21do_package_tar[noexec] = "1"
22do_package_write_deb[noexec] = "1"
23do_package_write_ipk[noexec] = "1"
24do_package_write_rpm[noexec] = "1"
25do_package_write_tar[noexec] = "1"
26do_populate_sysroot[noexec] = "1"