diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-09-17 03:51:25 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-23 16:10:57 +0200 |
commit | ea86048c8e0241753466a134790b77bdb193c7c2 (patch) | |
tree | c06502c87cc25bc346e2255890a21dc6ac992a76 /meta-initramfs/recipes-devtools | |
parent | 2ab254ce1afcb3747a9f1b571df75eae2378c7eb (diff) | |
download | meta-openembedded-ea86048c8e0241753466a134790b77bdb193c7c2.tar.gz |
dracut: RDEPEND on systemd optionally
Use PACKAGECONFIG to depend on systemd optionally.
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
-rw-r--r-- | meta-initramfs/recipes-devtools/dracut/dracut_git.bb | 11 |
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb index b7d88fd629..3be78ed34d 100644 --- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb +++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb | |||
@@ -13,9 +13,6 @@ SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git" | |||
13 | 13 | ||
14 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
15 | 15 | ||
16 | inherit distro_features_check | ||
17 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
18 | |||
19 | EXTRA_OECONF = "--prefix=${prefix} \ | 16 | EXTRA_OECONF = "--prefix=${prefix} \ |
20 | --libdir=${libdir} \ | 17 | --libdir=${libdir} \ |
21 | --datadir=${datadir} \ | 18 | --datadir=${datadir} \ |
@@ -25,7 +22,11 @@ EXTRA_OECONF = "--prefix=${prefix} \ | |||
25 | --bindir=${bindir} \ | 22 | --bindir=${bindir} \ |
26 | --includedir=${includedir} \ | 23 | --includedir=${includedir} \ |
27 | --localstatedir=${localstatedir} \ | 24 | --localstatedir=${localstatedir} \ |
28 | --systemdsystemunitdir=${systemd_unitdir}/system" | 25 | " |
26 | |||
27 | # RDEPEND on systemd optionally | ||
28 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" | ||
29 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,systemd" | ||
29 | 30 | ||
30 | do_configure() { | 31 | do_configure() { |
31 | ./configure ${EXTRA_OECONF} | 32 | ./configure ${EXTRA_OECONF} |
@@ -44,7 +45,7 @@ FILES_${PN} += " ${libdir}/kernel \ | |||
44 | " | 45 | " |
45 | CONFFILES_${PN} += "${sysconfdir}/dracut.conf" | 46 | CONFFILES_${PN} += "${sysconfdir}/dracut.conf" |
46 | 47 | ||
47 | RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid util-linux-getopt bash ldd" | 48 | RDEPENDS_${PN} = "findutils cpio util-linux-blkid util-linux-getopt bash ldd" |
48 | RDEPENDS_${PN}-bash-completion = "bash-completion" | 49 | RDEPENDS_${PN}-bash-completion = "bash-completion" |
49 | 50 | ||
50 | # This could be optimized a bit, but let's avoid non-booting systems :) | 51 | # This could be optimized a bit, but let's avoid non-booting systems :) |