summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2014-01-11 17:41:17 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:38 +0100
commit039b0190d9049768876af892cf9e18324a8d7c63 (patch)
tree102c55107b92d2240ced0173ebe7ce4583b9739c /meta-initramfs/recipes-devtools
parentee2c76b2ad0a3e7e720246fff50ba933462c8f1a (diff)
downloadmeta-openembedded-039b0190d9049768876af892cf9e18324a8d7c63.tar.gz
dracut: add git version
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools')
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch39
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb38
2 files changed, 77 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
new file mode 100644
index 000000000..7dc62ded7
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/dracut/dracut/0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch
@@ -0,0 +1,39 @@
1From c92ea797c43aa811e98b6bd8fb4aae921fa08592 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 10 Jan 2014 21:11:40 +0100
4Subject: [PATCH] Use builtin xz/lzma option to use all cores for multihreaded
5 compression
6
7This removes the dependency on 'getconf' as well, which is not installed by default on my embedded systems.
8
9Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
10Upstream-status: Submitted
11
12---
13 dracut.sh | 6 ++----
14 1 file changed, 2 insertions(+), 4 deletions(-)
15
16diff --git a/dracut.sh b/dracut.sh
17index 11dcd0e..2e6ea67 100755
18--- a/dracut.sh
19+++ b/dracut.sh
20@@ -697,14 +697,12 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
21 # eliminate IFS hackery when messing with fw_dir
22 fw_dir=${fw_dir//:/ }
23
24-cpu_count=$(getconf _NPROCESSORS_ONLN)
25-
26 # handle compression options.
27 [[ $compress ]] || compress="gzip"
28 case $compress in
29 bzip2) compress="bzip2 -9";;
30- lzma) compress="lzma -9 ${cpu_count:+-T$cpu_count}";;
31- xz) compress="xz --check=crc32 --lzma2=dict=1MiB ${cpu_count:+-T$cpu_count}";;
32+ lzma) compress="lzma -9 -T0";;
33+ xz) compress="xz --check=crc32 --lzma2=dict=1MiB -T0";;
34 gzip) compress="gzip -9"; command -v pigz > /dev/null 2>&1 && compress="pigz -9";;
35 lzo) compress="lzop -9";;
36 lz4) compress="lz4 -9";;
37--
381.8.0
39
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
new file mode 100644
index 000000000..ccc4e7d6b
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Initramfs generator using udev"
2DESCRIPTION = "Dracut is an event driven initramfs infrastructure. dracut (the tool) is used to create an initramfs image by copying tools and files from an installed system and combining it with the dracut framework, usually found in /usr/lib/dracut/modules.d."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRCREV = "bb1ba3a1ca9dd6284f6319eb197de4a757a7f99d"
8SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git \
9 file://0001-Use-builtin-xz-lzma-option-to-use-all-cores-for-mult.patch \
10 "
11
12S = "${WORKDIR}/git"
13
14do_configure() {
15 ./configure --prefix=${prefix} \
16 --libdir=${libdir} \
17 --datadir=${datadir} \
18 --sysconfdir=${sysconfdir} \
19 --sbindir=${sbindir} \
20 --disable-documentation \
21 --bindir=${bindir} \
22 --includedir=${includedir} \
23 --localstatedir=${localstatedir} \
24}
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30FILES_${PN} += "${datadir}/bash-completion \
31 ${libdir}/kernel \
32 "
33
34RDEPENDS_${PN} = "systemd findutils cpio util-linux-blkid bash ldd"
35# This could be optimized a bit, but let's avoid non-booting systems :)
36RRECOMMENDS_${PN} = " \
37 kernel-modules \
38 "