diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2018-01-29 00:05:07 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-02-11 11:50:56 -0800 |
commit | edbe41f53ec15eeae4673498c41a1f3a42ac813b (patch) | |
tree | d27d63b3249b2d4ebfee8ad5e837466d256e7ac2 /meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch | |
parent | 75356b6a76e965f6e282e8219e88afc1ab4f3240 (diff) | |
download | meta-openembedded-edbe41f53ec15eeae4673498c41a1f3a42ac813b.tar.gz |
ubi-utils-klibc_1.5.2: fix build for qemuarm
Building the recipe with TUNE_FEATURES = "aarch64" and TARGET_FPU = ""
fails. See patch headers for more details.
Patch sent upstream for master, here rebased for 1.5.2.
Tested runtime on armv5.
While there backport one more patch fixing warnings in libmtd.c and
move the patches in their specific dir, preparing for v2.0.1.
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch')
-rw-r--r-- | meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch | 84 |
1 files changed, 0 insertions, 84 deletions
diff --git a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch b/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch deleted file mode 100644 index 6e1b9ff10..000000000 --- a/meta-initramfs/recipes-devtools/mtd/ubi-utils-klibc/0001-Makefile-only-build-ubi-utils.patch +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | From c4e6bd9378645d577e9d9f85da85f1438afe7c50 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrea Adami <andrea.adami@gmail.com> | ||
3 | Date: Sun, 29 Jun 2014 00:32:29 +0200 | ||
4 | Subject: [PATCH 1/6] Makefile: build ubi-utils only | ||
5 | |||
6 | We build all the static ubi-utils but actually only ubiattach is needed in | ||
7 | a minimalistic initramfs for the mount of ubi volumes. | ||
8 | |||
9 | More fixes are needed in order to build the full mtd-utils. | ||
10 | The first issue is: | ||
11 | |||
12 | | mkfs.jffs2.c:64:20: fatal error: libgen.h: No such file or directory | ||
13 | | #include <libgen.h> | ||
14 | |||
15 | Removing the include then the second error is: | ||
16 | |||
17 | | mkfs.jffs2.c:1570:22: error: '_SC_PAGESIZE' undeclared | ||
18 | | (first use in this function) | ||
19 | | page_size = sysconf(_SC_PAGESIZE); | ||
20 | |||
21 | Upstream-Status: Inappropriate [embedded specific] | ||
22 | |||
23 | Signed-off-by: Andrea Adami <andrea.adami@gmail.com> | ||
24 | --- | ||
25 | Makefile | 24 ++---------------------- | ||
26 | 1 file changed, 2 insertions(+), 22 deletions(-) | ||
27 | |||
28 | Index: git/Makefile | ||
29 | =================================================================== | ||
30 | --- git.orig/Makefile | ||
31 | +++ git/Makefile | ||
32 | @@ -16,28 +16,11 @@ endif | ||
33 | |||
34 | TESTS = tests | ||
35 | |||
36 | -MTD_BINS = \ | ||
37 | - ftl_format flash_erase nanddump doc_loadbios \ | ||
38 | - ftl_check mkfs.jffs2 flash_lock flash_unlock \ | ||
39 | - flash_otp_info flash_otp_dump flash_otp_lock flash_otp_write \ | ||
40 | - mtd_debug flashcp nandwrite nandtest mtdpart \ | ||
41 | - jffs2dump \ | ||
42 | - nftldump nftl_format docfdisk \ | ||
43 | - rfddump rfdformat \ | ||
44 | - serve_image recv_image \ | ||
45 | - sumtool jffs2reader | ||
46 | UBI_BINS = \ | ||
47 | ubiupdatevol ubimkvol ubirmvol ubicrc32 ubinfo ubiattach \ | ||
48 | ubidetach ubinize ubiformat ubirename mtdinfo ubirsvol ubiblock | ||
49 | |||
50 | -BINS = $(MTD_BINS) | ||
51 | -BINS += mkfs.ubifs/mkfs.ubifs | ||
52 | -BINS += $(addprefix ubi-utils/,$(UBI_BINS)) | ||
53 | -SCRIPTS = flash_eraseall | ||
54 | - | ||
55 | -TARGETS = $(BINS) | ||
56 | -TARGETS += lib/libmtd.a | ||
57 | -TARGETS += ubi-utils/libubi.a | ||
58 | +BINS = $(addprefix ubi-utils/,$(UBI_BINS)) | ||
59 | |||
60 | OBJDEPS = $(BUILDDIR)/include/version.h | ||
61 | |||
62 | @@ -61,12 +44,9 @@ endif | ||
63 | rm -f $(BUILDDIR)/include/version.h | ||
64 | $(MAKE) -C $(TESTS) clean | ||
65 | |||
66 | -install:: $(addprefix $(BUILDDIR)/,${BINS}) ${SCRIPTS} | ||
67 | +install:: $(addprefix $(BUILDDIR)/,${BINS}) | ||
68 | mkdir -p ${DESTDIR}/${SBINDIR} | ||
69 | install -m 0755 $^ ${DESTDIR}/${SBINDIR}/ | ||
70 | - mkdir -p ${DESTDIR}/${MANDIR}/man1 | ||
71 | - install -m 0644 mkfs.jffs2.1 ${DESTDIR}/${MANDIR}/man1/ | ||
72 | - -gzip -9f ${DESTDIR}/${MANDIR}/man1/*.1 | ||
73 | |||
74 | tests:: | ||
75 | $(MAKE) -C $(TESTS) | ||
76 | @@ -91,8 +71,6 @@ LDLIBS_mkfs.jffs2 = -lz $(LZOLDLIBS) | ||
77 | LDFLAGS_jffs2reader = $(ZLIBLDFLAGS) $(LZOLDFLAGS) | ||
78 | LDLIBS_jffs2reader = -lz $(LZOLDLIBS) | ||
79 | |||
80 | -$(foreach v,$(MTD_BINS),$(eval $(call mkdep,,$(v)))) | ||
81 | - | ||
82 | # | ||
83 | # Common libmtd | ||
84 | # | ||