summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/klibc/klibc.inc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-01 07:15:56 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:20:57 +0200
commit8f65c719c77484da9a9bef5a6dbca5373bdcf680 (patch)
treef0ec9e8fba2c3bc2f184b0c32ed2b7e40c9138c3 /meta-initramfs/recipes-devtools/klibc/klibc.inc
parent04c3bc04cda280ee7cf01e7c179157931af7a4f2 (diff)
downloadmeta-openembedded-8f65c719c77484da9a9bef5a6dbca5373bdcf680.tar.gz
klibc: Fix build with clang
Remove gcc specific options use common one instead Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-devtools/klibc/klibc.inc')
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc.inc5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc
index cd3f39808..45dc6baef 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc.inc
+++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc
@@ -17,6 +17,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/libs/klibc/klibc.git \
17 file://0001-include-linux-sysinfo.h-directly.patch \ 17 file://0001-include-linux-sysinfo.h-directly.patch \
18 file://0001-mkfifo-Implement-mkfifo.patch \ 18 file://0001-mkfifo-Implement-mkfifo.patch \
19 file://0001-always-use-bfd-linker.patch \ 19 file://0001-always-use-bfd-linker.patch \
20 file://0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch \
20" 21"
21 22
22ARMPATCHES ?= "" 23ARMPATCHES ?= ""
@@ -48,6 +49,10 @@ do_configure () {
48 ln -sf "${STAGING_DIR_TARGET}${exec_prefix}" linux 49 ln -sf "${STAGING_DIR_TARGET}${exec_prefix}" linux
49} 50}
50 51
52do_configure_prepend_toolchain-clang() {
53 sed -i -e 's#$(KLIBCROSS)gcc#$(KLIBCROSS)clang#g' ${S}/Makefile
54}
55
51INHIBIT_PACKAGE_STRIP = "1" 56INHIBIT_PACKAGE_STRIP = "1"
52INHIBIT_PACKAGE_DEBUG_SPLIT = "1" 57INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
53INSANE_SKIP_${PN} = "already-stripped" 58INSANE_SKIP_${PN} = "already-stripped"