diff options
author | Andrea Adami <andrea.adami@gmail.com> | 2021-06-13 00:53:59 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-06-12 23:02:49 -0700 |
commit | 93e139c998857048182ed4169f04cfe350eab013 (patch) | |
tree | 2b2b1b360e92af2ec9f303fe1c1feec0bc2a049d /meta-initramfs/recipes-core | |
parent | cdce92b4e9e82327fe2b3118384c424d7f08cc0c (diff) | |
download | meta-openembedded-93e139c998857048182ed4169f04cfe350eab013.tar.gz |
initramfs-debug-image: support cases where machines override IMAGE_FSTYPES
As done for initramfs-kexecboot-image we need to use python to get the
desired value for IMAGE_FSTYPES.
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-initramfs/recipes-core')
-rw-r--r-- | meta-initramfs/recipes-core/images/initramfs-debug-image.bb | 7 |
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb index c3dcd2b821..601056b7e5 100644 --- a/meta-initramfs/recipes-core/images/initramfs-debug-image.bb +++ b/meta-initramfs/recipes-core/images/initramfs-debug-image.bb | |||
@@ -11,7 +11,12 @@ IMAGE_FEATURES = "" | |||
11 | export IMAGE_BASENAME = "initramfs-debug-image" | 11 | export IMAGE_BASENAME = "initramfs-debug-image" |
12 | IMAGE_LINGUAS = "" | 12 | IMAGE_LINGUAS = "" |
13 | 13 | ||
14 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" | 14 | # Some BSPs use IMAGE_FSTYPES_<machine override> which would override |
15 | # an assignment to IMAGE_FSTYPES so we need anon python | ||
16 | python () { | ||
17 | d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES")) | ||
18 | } | ||
19 | |||
15 | inherit core-image | 20 | inherit core-image |
16 | 21 | ||
17 | IMAGE_ROOTFS_SIZE = "8192" | 22 | IMAGE_ROOTFS_SIZE = "8192" |