summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-07 17:21:02 -0800
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:28 -0800
commitd8511c2432ca4ba75bca6e7f71f3c4c3f6098aae (patch)
tree9d2c3df79c610af475c5532e230e2e67c8612321 /meta-gnome
parenta60e2b87ca34a1bf6df8bcef4f0cd34b3a40d8cd (diff)
downloadmeta-openembedded-d8511c2432ca4ba75bca6e7f71f3c4c3f6098aae.tar.gz
gnome-commander: Fix build with taglib 2.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch37
-rw-r--r--meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch
new file mode 100644
index 000000000..8f6920c2c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander/0001-Build-fix-needed-with-taglib-2.0.patch
@@ -0,0 +1,37 @@
1From dc3aa0ff5a41114b17816f1f36f6bb5631c6ab5c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 7 Mar 2024 17:17:29 -0800
4Subject: [PATCH] Build fix needed with taglib 2.0
5
6Fixes
7| ../gnome-commander-1.16.1/src/tags/gnome-cmd-tags-taglib.cc:153:29: error: no member named 'sampleWidth' in 'TagLib::FLAC::Properties'
8| 153 | if (flacProperties->sampleWidth())
9| | ~~~~~~~~~~~~~~ ^
10| ../gnome-commander-1.16.1/src/tags/gnome-cmd-tags-taglib.cc:154:67: error: no member named 'sampleWidth' in 'TagLib::FLAC::Properties'
11| 154 | cout << "Audio.FLAC.SampleWidth " << flacProperties->sampleWidth()<< endl;
12| | ~~~~~~~~~~~~~~ ^
13
14Upstream-Status: Pending
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16---
17 src/tags/gnome-cmd-tags-taglib.cc | 4 ++--
18 1 file changed, 2 insertions(+), 2 deletions(-)
19
20diff --git a/src/tags/gnome-cmd-tags-taglib.cc b/src/tags/gnome-cmd-tags-taglib.cc
21index 9e65836..573f5eb 100644
22--- a/src/tags/gnome-cmd-tags-taglib.cc
23+++ b/src/tags/gnome-cmd-tags-taglib.cc
24@@ -150,8 +150,8 @@ bool getAudioProperties(GnomeCmdFileMetadata &metadata, const TagLib::AudioPrope
25 if (flacProperties)
26 {
27 metadata.add(TAG_AUDIO_CODEC,"FLAC");
28- if (flacProperties->sampleWidth())
29- cout << "Audio.FLAC.SampleWidth " << flacProperties->sampleWidth()<< endl;
30+ if (flacProperties->bitsPerSample())
31+ cout << "Audio.FLAC.BitsPerSample " << flacProperties->bitsPerSample()<< endl;
32
33 return true;
34 }
35--
362.44.0
37
diff --git a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
index 474512daa..bb36d59e5 100644
--- a/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-commander/gnome-commander_1.16.1.bb
@@ -16,6 +16,7 @@ ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
16GIR_MESON_ENABLE_FLAG = 'enabled' 16GIR_MESON_ENABLE_FLAG = 'enabled'
17GIR_MESON_DISABLE_FLAG = 'disabled' 17GIR_MESON_DISABLE_FLAG = 'disabled'
18 18
19SRC_URI += "file://0001-Build-fix-needed-with-taglib-2.0.patch"
19SRC_URI[archive.sha256sum] = "3f1d00c4a650fe7902167648286b32c9ca4ef86e31a5d8ccca0139f12d10d0b3" 20SRC_URI[archive.sha256sum] = "3f1d00c4a650fe7902167648286b32c9ca4ef86e31a5d8ccca0139f12d10d0b3"
20 21
21PACKAGECONFIG ??= "exiv2 taglib libgsf poppler" 22PACKAGECONFIG ??= "exiv2 taglib libgsf poppler"