diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-02-06 12:29:26 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-06 12:31:31 -0800 |
commit | c58581e03ad78dd0c905bb479e4f70b7687956db (patch) | |
tree | ecffda682058eefacb44677ccaa4774c03af6a6a /meta-gnome | |
parent | 5904daf1a51f0ba0a7c7403d4a38e9b3a9f3364e (diff) | |
download | meta-openembedded-c58581e03ad78dd0c905bb479e4f70b7687956db.tar.gz |
gimp: Fix build with autoconf-2.70+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch | 58 | ||||
-rw-r--r-- | meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb | 4 |
2 files changed, 61 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch new file mode 100644 index 000000000..7e12487c7 --- /dev/null +++ b/meta-gnome/recipes-gimp/gimp/gimp/0001-configure.ac-fix-with-linux-input-handling-with-upco.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 1b66e4cca6d95f4607599bcbdd4afeb601aee84e Mon Sep 17 00:00:00 2001 | ||
2 | From: Sergei Trofimovich <slyfox@gentoo.org> | ||
3 | Date: Sun, 25 Oct 2020 18:09:21 +0000 | ||
4 | Subject: [PATCH] configure.ac: fix `--with-linux-input` handling with upcoming autoconf-2.70 | ||
5 | |||
6 | Upcoming autoconf-2.70 exposes deficiency in configure.ac: | ||
7 | |||
8 | ``` | ||
9 | $ autoconf-2.70_beta2 && ./configure --host=x86_64-pc-linux-gnu | ||
10 | ./configure: line 1430: 5: Bad file descriptor | ||
11 | checking whether is declared... ./configure: line 1432: ${+y}: bad | ||
12 | ``` | ||
13 | |||
14 | It happens because macros are called with parameters using insufficient quoting. | ||
15 | |||
16 | More details at https://lists.gnu.org/archive/html/bug-autoconf/2020-10/msg00027.html | ||
17 | |||
18 | The fix only amends `--with-linux-input`. Other cases of underquoting | ||
19 | will need to be handled separately. | ||
20 | |||
21 | Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gimp/-/commit/cebeb90a87105cd6e35bcb357d53cc04c828ca21] | ||
22 | Fix-by: Zack Weinberg | ||
23 | Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> | ||
24 | --- | ||
25 | configure.ac | 17 ++++++++--------- | ||
26 | 1 file changed, 8 insertions(+), 9 deletions(-) | ||
27 | |||
28 | diff --git a/configure.ac b/configure.ac | ||
29 | index 6e2c193..afbcdd8 100644 | ||
30 | --- a/configure.ac | ||
31 | +++ b/configure.ac | ||
32 | @@ -2138,15 +2138,14 @@ fi | ||
33 | AC_ARG_WITH(linux-input, [ --without-linux-input don't build linux input event controller module]) | ||
34 | |||
35 | have_linux_input="no (linux input support disabled)" | ||
36 | -if test "x$with_linux_input" != "xno"; then | ||
37 | - AC_CHECK_HEADER(linux/input.h, | ||
38 | - AC_CHECK_DECL(KEY_OK, | ||
39 | - have_linux_input=yes, | ||
40 | - have_linux_input="no (needs Linux 2.6)", | ||
41 | - [#include <linux/input.h>])) | ||
42 | -fi | ||
43 | - | ||
44 | -AM_CONDITIONAL(HAVE_LINUX_INPUT, test "x$have_linux_input" = xyes) | ||
45 | +AS_IF([test "x$with_linux_input" != "xno"], | ||
46 | + [AC_CHECK_HEADER([linux/input.h], | ||
47 | + [AC_CHECK_DECL([KEY_OK], | ||
48 | + [have_linux_input=yes], | ||
49 | + [have_linux_input="no (needs Linux 2.6)"], | ||
50 | + [#include <linux/input.h>])])]) | ||
51 | + | ||
52 | +AM_CONDITIONAL([HAVE_LINUX_INPUT], [test "x$have_linux_input" = xyes]) | ||
53 | |||
54 | |||
55 | ############################### | ||
56 | -- | ||
57 | 2.30.0 | ||
58 | |||
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb index aec1ebf7b..070ed1904 100644 --- a/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb +++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.22.bb | |||
@@ -37,7 +37,9 @@ REQUIRED_DISTRO_FEATURES = "x11" | |||
37 | 37 | ||
38 | SHPV = "${@gnome_verdir("${PV}")}" | 38 | SHPV = "${@gnome_verdir("${PV}")}" |
39 | 39 | ||
40 | SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2" | 40 | SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2 \ |
41 | file://0001-configure.ac-fix-with-linux-input-handling-with-upco.patch \ | ||
42 | " | ||
41 | SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb" | 43 | SRC_URI[sha256sum] = "2db84b57f3778d80b3466d7c21a21d22e315c7b062de2883cbaaeda9a0f618bb" |
42 | 44 | ||
43 | EXTRA_OECONF = "--disable-python \ | 45 | EXTRA_OECONF = "--disable-python \ |