diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-05-20 15:16:06 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-23 08:44:41 -0700 |
commit | a7c72b59b4d1fda788c9dca0f7dcf024eb8c8444 (patch) | |
tree | b054f7ed033d03ff5505b845ee5899799f8c2b88 /meta-gnome | |
parent | 5413301d49e647ba6fc4eeb3ff574466a98537eb (diff) | |
download | meta-openembedded-a7c72b59b4d1fda788c9dca0f7dcf024eb8c8444.tar.gz |
gnome-font-viewer: Fix build with GCC-14
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer/0001-window-Fix-function-callback-definition.patch b/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer/0001-window-Fix-function-callback-definition.patch new file mode 100644 index 0000000000..be4c002fc3 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer/0001-window-Fix-function-callback-definition.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From ac4a07e7ef3d9d046a4ca2a803c5b649b6f7ddf4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Matt Turner <mattst88@gmail.com> | ||
3 | Date: Sat, 8 Jul 2023 00:01:07 -0400 | ||
4 | Subject: [PATCH] window: Fix function callback definition | ||
5 | |||
6 | Without this, the build fails with clang with | ||
7 | CFLAGS=-Werror=incompatible-function-pointer-types | ||
8 | |||
9 | ``` | ||
10 | ../src/font-view-window.c:864:77: error: incompatible function pointer types passing 'void (FontViewWindow *)' (aka 'void (struct _FontViewWindow *)') to parameter of type 'GtkWidgetActionActivateFunc' (aka 'void (*)(struct _GtkWidget *, const char *, struct _GVariant *)') [-Wincompatible-function-pointer-types] | ||
11 | gtk_widget_class_install_action (widget_class, "win.toggle-search", NULL, action_toggle_search_cb); | ||
12 | ^~~~~~~~~~~~~~~~~~~~~~~ | ||
13 | /usr/include/gtk-4.0/gtk/gtkwidget.h:956:87: note: passing argument to parameter 'activate' here | ||
14 | GtkWidgetActionActivateFunc activate); | ||
15 | ^ | ||
16 | ``` | ||
17 | |||
18 | Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gnome-font-viewer/-/merge_requests/54] | ||
19 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
20 | --- | ||
21 | src/font-view-window.c | 5 ++++- | ||
22 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/src/font-view-window.c b/src/font-view-window.c | ||
25 | index 639ac33..24461f7 100644 | ||
26 | --- a/src/font-view-window.c | ||
27 | +++ b/src/font-view-window.c | ||
28 | @@ -758,8 +758,11 @@ font_view_window_show_overview (FontViewWindow *self) | ||
29 | } | ||
30 | |||
31 | static void | ||
32 | -action_toggle_search_cb (FontViewWindow *self) | ||
33 | +action_toggle_search_cb (GtkWidget *widget, | ||
34 | + const char *action_name, | ||
35 | + GVariant *parameter) | ||
36 | { | ||
37 | + FontViewWindow *self = FONT_VIEW_WINDOW (widget); | ||
38 | |||
39 | gtk_toggle_button_set_active (self->search_button, | ||
40 | !gtk_toggle_button_get_active (self->search_button)); | ||
41 | -- | ||
42 | 2.45.1 | ||
43 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer_46.0.bb b/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer_46.0.bb index dbce71d121..ccf8262dcd 100644 --- a/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer_46.0.bb +++ b/meta-gnome/recipes-gnome/gnome-font-viewer/gnome-font-viewer_46.0.bb | |||
@@ -15,6 +15,7 @@ inherit gnomebase gtk-icon-cache gettext features_check mime-xdg | |||
15 | 15 | ||
16 | REQUIRED_DISTRO_FEATURES = "x11 opengl" | 16 | REQUIRED_DISTRO_FEATURES = "x11 opengl" |
17 | 17 | ||
18 | SRC_URI += "file://0001-window-Fix-function-callback-definition.patch" | ||
18 | SRC_URI[archive.sha256sum] = "592f401e485d02cc044d487bb5c8e04c961da6856216768a59f1ff98bd2d537c" | 19 | SRC_URI[archive.sha256sum] = "592f401e485d02cc044d487bb5c8e04c961da6856216768a59f1ff98bd2d537c" |
19 | 20 | ||
20 | FILES:${PN} += " \ | 21 | FILES:${PN} += " \ |