diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-02-07 23:35:28 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-02-15 10:21:35 +0100 |
commit | 5f5b1b6667346dbb1477ddfa1fb54aae391bb14e (patch) | |
tree | 185ca6e25ba8811ada7b824da7308d7fa5ff04d3 /meta-gnome | |
parent | e6647cf8f8e4d8eb7403334ec6b8c1da52a9d770 (diff) | |
download | meta-openembedded-5f5b1b6667346dbb1477ddfa1fb54aae391bb14e.tar.gz |
abiword: update to 3.0.1
* sources checked for debian_patches_boost54.patch: seems applied
* removing tailored configure does not show effects - plugins are build properly
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch | 39 | ||||
-rwxr-xr-x | meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh | 28 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch | 32 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb (renamed from meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb) | 18 |
4 files changed, 44 insertions, 73 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch b/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch new file mode 100644 index 0000000000..0dff1411d4 --- /dev/null +++ b/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From c646159ce817506131b58fdab1cdc1cd6364df7a Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Sun, 7 Feb 2016 21:45:20 +0100 | ||
4 | Subject: [PATCH] plugins/aiksaurus/Makefile.am: remove uncomplete options | ||
5 | WITH_BUILTIN_AIKSAURUS_GTK | ||
6 | MIME-Version: 1.0 | ||
7 | Content-Type: text/plain; charset=UTF-8 | ||
8 | Content-Transfer-Encoding: 8bit | ||
9 | |||
10 | * with gtk2 we won't use it | ||
11 | * it is missing in configure.ac causing | ||
12 | |||
13 | | plugins/aiksaurus/Makefile.am:5: error: WITH_BUILTIN_AIKSAURUS_GTK does not appear in AM_CONDITIONAL | ||
14 | |||
15 | Upstream-Status: Pending | ||
16 | |||
17 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
18 | --- | ||
19 | plugins/aiksaurus/Makefile.am | 4 ---- | ||
20 | 1 file changed, 4 deletions(-) | ||
21 | |||
22 | diff --git a/plugins/aiksaurus/Makefile.am b/plugins/aiksaurus/Makefile.am | ||
23 | index d402c58..1034e2a 100644 | ||
24 | --- a/plugins/aiksaurus/Makefile.am | ||
25 | +++ b/plugins/aiksaurus/Makefile.am | ||
26 | @@ -2,10 +2,6 @@ SUBDIRS = | ||
27 | |||
28 | if TOOLKIT_GTK | ||
29 | |||
30 | -if WITH_BUILTIN_AIKSAURUS_GTK | ||
31 | -SUBDIRS += aiksaurusgtk3 | ||
32 | -platform_lib = aiksaurusgtk3/libAiksaurusGtk3.la | ||
33 | -endif | ||
34 | |||
35 | endif | ||
36 | |||
37 | -- | ||
38 | 2.5.0 | ||
39 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh b/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh deleted file mode 100755 index c1f10e1a4d..0000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/autogen-common.sh +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | # find plugins Makefile templates | ||
4 | find plugins -name Makefile.am | sed 's|.am$||g' > plugin-makefiles.m4 | ||
5 | |||
6 | # create plugin list | ||
7 | (cd plugins && find . -maxdepth 1 -type d | grep -v '^\.$' | grep -v '\./\.' | sed 's|\./||g' | xargs echo) > plugin-list.m4 | ||
8 | |||
9 | # create conditionals for builtin plugins | ||
10 | (for plugin in `cat plugin-list.m4`; do | ||
11 | u=`echo $plugin | tr '[:lower:]' '[:upper:]'` | ||
12 | echo 'AM_CONDITIONAL(['$u'_BUILTIN], test "$enable_'$plugin'_builtin" == "yes")' | ||
13 | done) > plugin-builtin.m4 | ||
14 | |||
15 | # create plugin configuration | ||
16 | find plugins -name plugin.m4 | xargs cat > plugin-configure.m4 | ||
17 | #to debug if plugin configuration code misbehaves (instead of the above line): | ||
18 | #rm plugin-configure.m4 | ||
19 | #for f in $(find plugins -name plugin.m4); do | ||
20 | # echo "AC_MSG_RESULT([plugin: $f])" >> plugin-configure.m4 | ||
21 | # cat $f >> plugin-configure.m4 | ||
22 | #done | ||
23 | |||
24 | # find extra m4 files provided by plugins and symlink them | ||
25 | for f in ` find ./plugins -name '*.m4' | grep -v 'plugin\.m4'`; do | ||
26 | ln -sf $f | ||
27 | done | ||
28 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch b/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch deleted file mode 100644 index cf50cb2c90..0000000000 --- a/meta-gnome/recipes-gnome/abiword/abiword/debian_patches_boost54.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | Last-Update: 2014-02-05 | ||
2 | Forwarded: yes | ||
3 | Author: Dmitry Smirnov <onlyjob@member.fsf.org> | ||
4 | Bug-Debian: http://bugs.debian.org/737551 | ||
5 | Bug-Abiword: http://bugzilla.abisource.com/13602 | ||
6 | Description: fix FTBFS with libboost1.54-dev | ||
7 | Upstream-Status: Applied | ||
8 | |||
9 | --- a/plugins/collab/core/sync/xp/SynchronizedQueue.h | ||
10 | +++ b/plugins/collab/core/sync/xp/SynchronizedQueue.h | ||
11 | @@ -21,8 +21,9 @@ | ||
12 | |||
13 | #include <deque> | ||
14 | #include <boost/bind.hpp> | ||
15 | #include <boost/function.hpp> | ||
16 | +#include <boost/noncopyable.hpp> | ||
17 | #include <sync/xp/lock.h> | ||
18 | #include <sync/xp/Synchronizer.h> | ||
19 | |||
20 | class EmptyQueueException {}; | ||
21 | --- a/plugins/collab/backends/tcp/xp/Session.h | ||
22 | +++ b/plugins/collab/backends/tcp/xp/Session.h | ||
23 | @@ -21,8 +21,9 @@ | ||
24 | |||
25 | #include <boost/function.hpp> | ||
26 | #include <boost/bind.hpp> | ||
27 | #include <boost/enable_shared_from_this.hpp> | ||
28 | +#include <boost/noncopyable.hpp> | ||
29 | #include <deque> | ||
30 | #include <sync/xp/lock.h> | ||
31 | #include <sync/xp/Synchronizer.h> | ||
32 | |||
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb index eb4bba2175..d4c8c56c9e 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb | |||
@@ -9,15 +9,15 @@ RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \ | |||
9 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" | 9 | glibc-gconv-iso8859-15 glibc-gconv-iso8859-1" |
10 | RCONFLICTS_${PN} = "${PN}-embedded" | 10 | RCONFLICTS_${PN} = "${PN}-embedded" |
11 | 11 | ||
12 | SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ | 12 | SRC_URI = " \ |
13 | file://debian_patches_boost54.patch \ | 13 | http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \ |
14 | file://autogen-common.sh \ | 14 | file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \ |
15 | " | 15 | " |
16 | 16 | ||
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a" | 17 | LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a" |
18 | 18 | ||
19 | SRC_URI[md5sum] = "8d9c41cff3a8fbef8d0c835c65600e65" | 19 | SRC_URI[md5sum] = "f3f8052e7b4979a43b75775a381e6cb8" |
20 | SRC_URI[sha256sum] = "d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b89081fac01" | 20 | SRC_URI[sha256sum] = "e094f6fbf0afc5c5538b4894888e7c346f8ee8f49c9d24821dd696d0734865c6" |
21 | 21 | ||
22 | #want 3.x from 3.x.y for the installation directory | 22 | #want 3.x from 3.x.y for the installation directory |
23 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 23 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" |
@@ -41,14 +41,6 @@ EXTRA_OECONF = " --disable-static \ | |||
41 | --with-libwmf-config=${STAGING_DIR} \ | 41 | --with-libwmf-config=${STAGING_DIR} \ |
42 | " | 42 | " |
43 | 43 | ||
44 | # AbiWord configure.ac does not play nicely with autoreconf | ||
45 | # so use the autogen.sh script that comes with AbiWord | ||
46 | do_configure() { | ||
47 | install -m 0755 ${WORKDIR}/autogen-common.sh ${B}/autogen-common.sh | ||
48 | ./autogen-common.sh | ||
49 | autotools_do_configure | ||
50 | } | ||
51 | |||
52 | do_compile() { | 44 | do_compile() { |
53 | cd goffice-bits2 | 45 | cd goffice-bits2 |
54 | make goffice-paths.h | 46 | make goffice-paths.h |