summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-08-12 00:32:18 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-11 19:52:47 -0700
commit4e0538516b1e0ef42dc79bd08f7895f0052063ac (patch)
treef9f1aa4b1f1172cd62df222c62a100f6df28ca41 /meta-gnome
parent870571196e440408e296836f6bed25f71f59acac (diff)
downloadmeta-openembedded-4e0538516b1e0ef42dc79bd08f7895f0052063ac.tar.gz
abiword: remove
Last release was 2016. For sentimental reasons it was added to meta-office as a place for retirement. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/0001-Bug-13770-Require-C-11-from-now-on.patch180
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch39
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb142
3 files changed, 0 insertions, 361 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/0001-Bug-13770-Require-C-11-from-now-on.patch b/meta-gnome/recipes-gnome/abiword/abiword/0001-Bug-13770-Require-C-11-from-now-on.patch
deleted file mode 100644
index 3731a23f1..000000000
--- a/meta-gnome/recipes-gnome/abiword/abiword/0001-Bug-13770-Require-C-11-from-now-on.patch
+++ /dev/null
@@ -1,180 +0,0 @@
1From f6d0dc338fe867c1b064682ae7f15bffe019b306 Mon Sep 17 00:00:00 2001
2From: Hubert Figuiere <hub@figuiere.net>
3Date: Tue, 12 Apr 2016 02:55:47 +0000
4Subject: [PATCH] Bug 13770 - Require C++11 from now on.
5
6git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/trunk@35197 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
7
8Upstream-Status: Backport
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 ax_cxx_compile_stdcxx_11.m4 | 133 +++++++++++++++++++++++++++++++++++
12 configure.ac | 1 +
13 src/wp/ap/gtk/ap_UnixApp.cpp | 2 +-
14 3 files changed, 135 insertions(+), 1 deletion(-)
15 create mode 100644 ax_cxx_compile_stdcxx_11.m4
16
17diff --git a/ax_cxx_compile_stdcxx_11.m4 b/ax_cxx_compile_stdcxx_11.m4
18new file mode 100644
19index 0000000..af37acd
20--- /dev/null
21+++ b/ax_cxx_compile_stdcxx_11.m4
22@@ -0,0 +1,133 @@
23+# ============================================================================
24+# http://www.gnu.org/software/autoconf-archive/ax_cxx_compile_stdcxx_11.html
25+# ============================================================================
26+#
27+# SYNOPSIS
28+#
29+# AX_CXX_COMPILE_STDCXX_11([ext|noext],[mandatory|optional])
30+#
31+# DESCRIPTION
32+#
33+# Check for baseline language coverage in the compiler for the C++11
34+# standard; if necessary, add switches to CXXFLAGS to enable support.
35+#
36+# The first argument, if specified, indicates whether you insist on an
37+# extended mode (e.g. -std=gnu++11) or a strict conformance mode (e.g.
38+# -std=c++11). If neither is specified, you get whatever works, with
39+# preference for an extended mode.
40+#
41+# The second argument, if specified 'mandatory' or if left unspecified,
42+# indicates that baseline C++11 support is required and that the macro
43+# should error out if no mode with that support is found. If specified
44+# 'optional', then configuration proceeds regardless, after defining
45+# HAVE_CXX11 if and only if a supporting mode is found.
46+#
47+# LICENSE
48+#
49+# Copyright (c) 2008 Benjamin Kosnik <bkoz@redhat.com>
50+# Copyright (c) 2012 Zack Weinberg <zackw@panix.com>
51+# Copyright (c) 2013 Roy Stogner <roystgnr@ices.utexas.edu>
52+#
53+# Copying and distribution of this file, with or without modification, are
54+# permitted in any medium without royalty provided the copyright notice
55+# and this notice are preserved. This file is offered as-is, without any
56+# warranty.
57+
58+#serial 3
59+
60+m4_define([_AX_CXX_COMPILE_STDCXX_11_testbody], [
61+ template <typename T>
62+ struct check
63+ {
64+ static_assert(sizeof(int) <= sizeof(T), "not big enough");
65+ };
66+
67+ typedef check<check<bool>> right_angle_brackets;
68+
69+ int a;
70+ decltype(a) b;
71+
72+ typedef check<int> check_type;
73+ check_type c;
74+ check_type&& cr = static_cast<check_type&&>(c);
75+
76+ auto d = a;
77+])
78+
79+AC_DEFUN([AX_CXX_COMPILE_STDCXX_11], [dnl
80+ m4_if([$1], [], [],
81+ [$1], [ext], [],
82+ [$1], [noext], [],
83+ [m4_fatal([invalid argument `$1' to AX_CXX_COMPILE_STDCXX_11])])dnl
84+ m4_if([$2], [], [ax_cxx_compile_cxx11_required=true],
85+ [$2], [mandatory], [ax_cxx_compile_cxx11_required=true],
86+ [$2], [optional], [ax_cxx_compile_cxx11_required=false],
87+ [m4_fatal([invalid second argument `$2' to AX_CXX_COMPILE_STDCXX_11])])dnl
88+ AC_LANG_PUSH([C++])dnl
89+ ac_success=no
90+ AC_CACHE_CHECK(whether $CXX supports C++11 features by default,
91+ ax_cv_cxx_compile_cxx11,
92+ [AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
93+ [ax_cv_cxx_compile_cxx11=yes],
94+ [ax_cv_cxx_compile_cxx11=no])])
95+ if test x$ax_cv_cxx_compile_cxx11 = xyes; then
96+ ac_success=yes
97+ fi
98+
99+ m4_if([$1], [noext], [], [dnl
100+ if test x$ac_success = xno; then
101+ for switch in -std=gnu++11 -std=gnu++0x; do
102+ cachevar=AS_TR_SH([ax_cv_cxx_compile_cxx11_$switch])
103+ AC_CACHE_CHECK(whether $CXX supports C++11 features with $switch,
104+ $cachevar,
105+ [ac_save_CXXFLAGS="$CXXFLAGS"
106+ CXXFLAGS="$CXXFLAGS $switch"
107+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
108+ [eval $cachevar=yes],
109+ [eval $cachevar=no])
110+ CXXFLAGS="$ac_save_CXXFLAGS"])
111+ if eval test x\$$cachevar = xyes; then
112+ CXXFLAGS="$CXXFLAGS $switch"
113+ ac_success=yes
114+ break
115+ fi
116+ done
117+ fi])
118+
119+ m4_if([$1], [ext], [], [dnl
120+ if test x$ac_success = xno; then
121+ for switch in -std=c++11 -std=c++0x; do
122+ cachevar=AS_TR_SH([ax_cv_cxx_compile_cxx11_$switch])
123+ AC_CACHE_CHECK(whether $CXX supports C++11 features with $switch,
124+ $cachevar,
125+ [ac_save_CXXFLAGS="$CXXFLAGS"
126+ CXXFLAGS="$CXXFLAGS $switch"
127+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([_AX_CXX_COMPILE_STDCXX_11_testbody])],
128+ [eval $cachevar=yes],
129+ [eval $cachevar=no])
130+ CXXFLAGS="$ac_save_CXXFLAGS"])
131+ if eval test x\$$cachevar = xyes; then
132+ CXXFLAGS="$CXXFLAGS $switch"
133+ ac_success=yes
134+ break
135+ fi
136+ done
137+ fi])
138+ AC_LANG_POP([C++])
139+ if test x$ax_cxx_compile_cxx11_required = xtrue; then
140+ if test x$ac_success = xno; then
141+ AC_MSG_ERROR([*** A compiler with support for C++11 language features is required.])
142+ fi
143+ else
144+ if test x$ac_success = xno; then
145+ HAVE_CXX11=0
146+ AC_MSG_NOTICE([No compiler with C++11 support was found])
147+ else
148+ HAVE_CXX11=1
149+ AC_DEFINE(HAVE_CXX11,1,
150+ [define if the compiler supports basic C++11 syntax])
151+ fi
152+
153+ AC_SUBST(HAVE_CXX11)
154+ fi
155+])
156diff --git a/configure.ac b/configure.ac
157index 48228be..f7be7de 100644
158--- a/configure.ac
159+++ b/configure.ac
160@@ -131,6 +131,7 @@ win_pkgs="$enchant_req"
161
162 AC_PROG_CC
163 AC_PROG_CXX
164+AX_CXX_COMPILE_STDCXX_11(noext,mandatory)
165 #AC_PROG_OBJC
166 AC_PROG_INSTALL
167 # For libtool 1.5.x compatability (AC_PROG_LIBTOOL is deprecated version of LT_INIT)
168diff --git a/src/wp/ap/gtk/ap_UnixApp.cpp b/src/wp/ap/gtk/ap_UnixApp.cpp
169index 061a304..260f8e5 100644
170--- a/src/wp/ap/gtk/ap_UnixApp.cpp
171+++ b/src/wp/ap/gtk/ap_UnixApp.cpp
172@@ -863,7 +863,7 @@ static bool is_so (const char *file) {
173 if (len < (strlen(G_MODULE_SUFFIX) + 2)) // this is ".so" and at least one char for the filename
174 return false;
175 const char *suffix = file+(len-3);
176- if(0 == strcmp (suffix, "."G_MODULE_SUFFIX))
177+ if(0 == strcmp (suffix, "." G_MODULE_SUFFIX))
178 return true;
179 return false;
180 }
diff --git a/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch b/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch
deleted file mode 100644
index 0dff1411d..000000000
--- a/meta-gnome/recipes-gnome/abiword/abiword/0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From c646159ce817506131b58fdab1cdc1cd6364df7a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 7 Feb 2016 21:45:20 +0100
4Subject: [PATCH] plugins/aiksaurus/Makefile.am: remove uncomplete options
5 WITH_BUILTIN_AIKSAURUS_GTK
6MIME-Version: 1.0
7Content-Type: text/plain; charset=UTF-8
8Content-Transfer-Encoding: 8bit
9
10* with gtk2 we won't use it
11* it is missing in configure.ac causing
12
13| plugins/aiksaurus/Makefile.am:5: error: WITH_BUILTIN_AIKSAURUS_GTK does not appear in AM_CONDITIONAL
14
15Upstream-Status: Pending
16
17Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
18---
19 plugins/aiksaurus/Makefile.am | 4 ----
20 1 file changed, 4 deletions(-)
21
22diff --git a/plugins/aiksaurus/Makefile.am b/plugins/aiksaurus/Makefile.am
23index d402c58..1034e2a 100644
24--- a/plugins/aiksaurus/Makefile.am
25+++ b/plugins/aiksaurus/Makefile.am
26@@ -2,10 +2,6 @@ SUBDIRS =
27
28 if TOOLKIT_GTK
29
30-if WITH_BUILTIN_AIKSAURUS_GTK
31-SUBDIRS += aiksaurusgtk3
32-platform_lib = aiksaurusgtk3/libAiksaurusGtk3.la
33-endif
34
35 endif
36
37--
382.5.0
39
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb
deleted file mode 100644
index 36b056fdd..000000000
--- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.2.bb
+++ /dev/null
@@ -1,142 +0,0 @@
1SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = " \
7 perl-native \
8 gtk+ \
9 gtkmathview \
10 wv \
11 fribidi \
12 jpeg \
13 libpng \
14 librsvg \
15 libwmf-native \
16 asio \
17 evolution-data-server \
18 libxslt \
19 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'redland rasqal', '', d)} \
20"
21RDEPENDS_${PN}_append_libc-glibc = " \
22 glibc-gconv-ibm850 glibc-gconv-cp1252 \
23 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1 \
24"
25RCONFLICTS_${PN} = "${PN}-embedded"
26
27SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
28 file://0001-plugins-aiksaurus-Makefile.am-remove-uncomplete-opti.patch \
29 file://0001-Bug-13770-Require-C-11-from-now-on.patch \
30 "
31
32LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
33
34SRC_URI[md5sum] = "cda6dd58c747c133b421cc7eb18f5796"
35SRC_URI[sha256sum] = "afbfd458fd02989d8b0c6362ba8a4c14686d89666f54cfdb5501bd2090cf3522"
36
37#want 3.x from 3.x.y for the installation directory
38SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
39
40inherit distro_features_check autotools-brokensep pkgconfig
41
42REQUIRED_DISTRO_FEATURES = "x11"
43
44PACKAGECONFIG ??= " \
45 collab-backend-xmpp collab-backend-tcp \
46 ${@bb.utils.contains('BBFILE_COLLECTIONS', 'office-layer', 'libical', '', d)} \
47"
48PACKAGECONFIG[libical] = "--with-libical,--without-libical,libical raptor2"
49PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
50PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
51PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
52PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
53PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
54PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
55
56EXTRA_OECONF = " --disable-static \
57 --enable-plugins \
58 --enable-clipart \
59 --enable-templates \
60 --without-gnomevfs \
61 --with-gtk2 \
62 --with-libwmf-config=${STAGING_DIR} \
63"
64
65LDFLAGS += "-lgmodule-2.0"
66
67do_compile() {
68 cd goffice-bits2
69 make goffice-paths.h
70 make libgoffice.la
71 cd ${B}
72 oe_runmake
73}
74
75PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
76
77FILES_${PN} += " \
78 ${libdir}/lib${PN}-*.so \
79 ${datadir}/mime-info \
80 ${datadir}/icons/* \
81 ${datadir}/${PN}-${SHRT_VER}/glade \
82 ${datadir}/${PN}-${SHRT_VER}/scripts \
83 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
84 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
85 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
86 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
87 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
88 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
89 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
90 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
91 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
92 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
93 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
94 ${datadir}/${PN}-${SHRT_VER}/certs \
95 ${datadir}/${PN}-${SHRT_VER}/ui \
96 ${datadir}/${PN}-${SHRT_VER}/xsl* \
97 ${datadir}/${PN}-${SHRT_VER}/mime-info \
98 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
99"
100
101# don't steal /usr/lib/libabiword-3.0.so from ${PN}
102# in this case it's needed in ${PN}
103FILES_${PN}-dev = " \
104 ${includedir} \
105 ${libdir}/pkgconfig \
106 ${libdir}/${PN}*.la \
107 ${libdir}/lib${PN}*.la \
108 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
109"
110FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
111FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
112
113FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
114FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
115FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
116FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
117FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
118FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
119
120PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
121
122python populate_packages_prepend () {
123 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
124 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
125
126 metapkg = "abiword-meta"
127 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
128 d.setVar('FILES_' + metapkg, "")
129 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
130 metapkg_rdepends = []
131 packages = d.getVar('PACKAGES').split()
132 for pkg in packages[1:]:
133 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
134 print("Modifying %s" % pkg)
135 metapkg_rdepends.append(pkg)
136 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
137 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
138 packages.append(metapkg)
139 d.setVar('PACKAGES', ' '.join(packages))
140}
141
142FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"