summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-04-29 13:53:16 +0200
committerKhem Raj <raj.khem@gmail.com>2024-04-29 11:11:51 -0700
commit4c40897893f43a99e6ae12e652c0cf789d89df90 (patch)
tree00bb0e3bc8a4b5c3ff5c6f400e8e06e7c89fd49f /meta-gnome
parent956ebe0cdc153ebe83835bf81a33d916416ab497 (diff)
downloadmeta-openembedded-4c40897893f43a99e6ae12e652c0cf789d89df90.tar.gz
libgweather: fix build with gobject-introspection 1.80.0
gweather build is running a python script build-aux/meson/gen_locations_variant.py which imports g-i data at build time: from gi.repository import GLib Previously this would import the typelib file installed by native g-i (which would likely not match the cross target, but nvm). New g-i version no longer installs those files, so the options are: - run the python script with target python inside qemu - copy the needed typelib from target sysroot into the native one. I took the easy way out. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
index acf288528..e0c8724a3 100644
--- a/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
+++ b/meta-gnome/recipes-gnome/libgweather/libgweather4_4.4.2.bb
@@ -28,3 +28,7 @@ FILES:${PN} += " \
28 ${datadir}/libgweather-4 \ 28 ${datadir}/libgweather-4 \
29 ${libdir}/libgweather-4 \ 29 ${libdir}/libgweather-4 \
30" 30"
31
32do_configure:prepend() {
33 cp -f ${STAGING_LIBDIR}/girepository-1.0/GLib*typelib ${STAGING_LIBDIR_NATIVE}/girepository-1.0/
34}