summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorPeter Marko <peter.marko@siemens.com>2024-05-09 23:34:34 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-12 08:43:20 -0700
commit11ad4a7fb10d0c3155cfe247da5a0703d3a260f9 (patch)
tree02aa99ff6a0a524b17aee428017875b2ac94ee9c /meta-gnome
parentde813392cf464bfadf7df67adfbb0e928f5f663d (diff)
downloadmeta-openembedded-11ad4a7fb10d0c3155cfe247da5a0703d3a260f9.tar.gz
gnome-shell: correct regression with glib-2.0 2.78.5
Backport fix to work with new glib-2.0. Signed-off-by: Peter Marko <peter.marko@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0002-screencast-Correct-expected-bus-name-for-streams.patch38
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb1
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0002-screencast-Correct-expected-bus-name-for-streams.patch b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0002-screencast-Correct-expected-bus-name-for-streams.patch
new file mode 100644
index 000000000..736594716
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell/0002-screencast-Correct-expected-bus-name-for-streams.patch
@@ -0,0 +1,38 @@
1From 50a011a19dcc6997ea6173c07bb80b2d9888d363 Mon Sep 17 00:00:00 2001
2From: Simon McVittie <smcv@debian.org>
3Date: Mon, 6 May 2024 21:58:09 +0100
4Subject: [PATCH] screencast: Correct expected bus name for streams
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Previously, this only worked because GDBusConnection was not filtering
10signals by their sender correctly (GNOME/glib#3268).
11
12Thanks: Alicia Boya GarcĂ­a
13Signed-off-by: Simon McVittie <smcv@debian.org>
14Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/3303>
15
16Upstream-Status: Backport [https://gitlab.gnome.org/GNOME/gnome-shell/-/commit/50a011a19dcc6997ea6173c07bb80b2d9888d363]
17
18Signed-off-by: Peter Marko <peter.marko@siemens.com>
19---
20 js/dbusServices/screencast/screencastService.js | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/js/dbusServices/screencast/screencastService.js b/js/dbusServices/screencast/screencastService.js
24index d664a51b083..0645811fa0a 100644
25--- a/js/dbusServices/screencast/screencastService.js
26+++ b/js/dbusServices/screencast/screencastService.js
27@@ -340,7 +340,7 @@ class Recorder extends Signals.EventEmitter {
28 });
29
30 this._streamProxy = new ScreenCastStreamProxy(Gio.DBus.session,
31- 'org.gnome.ScreenCast.Stream',
32+ 'org.gnome.Mutter.ScreenCast',
33 streamPath);
34
35 this._streamProxy.connectSignal('PipeWireStreamAdded',
36--
372.30.2
38
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
index ed86cbcb6..1bc9b6b39 100644
--- a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
@@ -34,6 +34,7 @@ REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
34 34
35SRC_URI[archive.sha256sum] = "64f999844c101e63bf294d45b138de56319ad2f326282721aad0fa860653b369" 35SRC_URI[archive.sha256sum] = "64f999844c101e63bf294d45b138de56319ad2f326282721aad0fa860653b369"
36SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch" 36SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
37SRC_URI += "file://0002-screencast-Correct-expected-bus-name-for-streams.patch"
37 38
38PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 39PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
39PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth" 40PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"