summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-03-28 17:12:58 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-28 11:45:02 -0700
commit0586dd9f1343424be9dae9faa5d1e3e7dadd05d2 (patch)
tree167639b1f53795bda507f71b7c694b2ce4455249 /meta-gnome
parent6665650b2a66117d5770eecee5bdee69cc4a7a4c (diff)
downloadmeta-openembedded-0586dd9f1343424be9dae9faa5d1e3e7dadd05d2.tar.gz
gnome-user-share: add recipe
- add it as runtime dependency to gnome-control-center because without it, the file sharing options are hidden. - configure the paths to fit to openembedded env - add mod_dnssd runtime dependency for apache2 as this is a requirement To enable the feature, PACKAGECONFIG httpd needs to be added. This is not done by default to avoid apache2 runtime dependency just by including this recipe. NOTE: Apache2 httpd doesn't need to be running. It'll get started and stopped on demand by systemd. Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb24
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
index a691b8d3f..fe9f1efbc 100644
--- a/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-control-center/gnome-control-center_46.0.bb
@@ -69,4 +69,4 @@ FILES:${PN} += " \
69 69
70FILES:${PN}-dev += "${datadir}/gettext" 70FILES:${PN}-dev += "${datadir}/gettext"
71 71
72RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper" 72RDEPENDS:${PN} += "gsettings-desktop-schemas tecla system-config-printer cups-pk-helper ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'gnome-user-share', '' , d)}"
diff --git a/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
new file mode 100644
index 000000000..3ff8f938a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-user-share/gnome-user-share_43.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "This is gnome-user-share 43.0, a system for easy sharing of user files."
2LICENSE="GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
4
5
6DEPENDS = " \
7 glib-2.0-native \
8 glib-2.0 \
9 systemd \
10"
11
12inherit gnomebase gsettings features_check
13
14REQUIRED_DISTRO_FEATURES = "systemd"
15
16SRC_URI = "git://gitlab.gnome.org/GNOME/gnome-user-share.git;protocol=https;branch=master"
17SRCREV = "a0e790aa9494db9d1b1f48b4fc0d2f78e112044d"
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG ??= "modules"
21PACKAGECONFIG[httpd] = "-Dhttpd=/usr/sbin/httpd,,,apache2 mod-dnssd"
22PACKAGECONFIG[modules] = "-Dmodules_path=/usr/libexec/apache2/modules"
23
24FILES:${PN} += "${systemd_user_unitdir}"