diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-05-24 20:00:21 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-25 08:56:32 -0700 |
commit | fe0e3d77eb1a992c487038e64b734b2b8b395647 (patch) | |
tree | 9c485f39b1db23d382059d4196fb15e266fbac4b /meta-gnome/recipes-support | |
parent | ee2f57c7c3b489ddaab3343b9501f6257c65dcee (diff) | |
download | meta-openembedded-fe0e3d77eb1a992c487038e64b734b2b8b395647.tar.gz |
ibus: Point python interpreter to target location
it encoded PYTHON variable during build which otherwise points to python
on build host which is not correct for cross compiled packages.
Add missing dependency on python3-core which is needed for ibus-setup
script to run
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r-- | meta-gnome/recipes-support/ibus/ibus.bb | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-support/ibus/ibus.inc | 3 |
2 files changed, 4 insertions, 1 deletions
diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb index 7156081499..141341e341 100644 --- a/meta-gnome/recipes-support/ibus/ibus.bb +++ b/meta-gnome/recipes-support/ibus/ibus.bb | |||
@@ -38,4 +38,4 @@ FILES:${PN} += " \ | |||
38 | FILES:${PN}-dev += " \ | 38 | FILES:${PN}-dev += " \ |
39 | ${datadir}/gettext \ | 39 | ${datadir}/gettext \ |
40 | " | 40 | " |
41 | 41 | RDEPENDS:${PN} += "python3-core" | |
diff --git a/meta-gnome/recipes-support/ibus/ibus.inc b/meta-gnome/recipes-support/ibus/ibus.inc index bb662f2ec9..9579404b3e 100644 --- a/meta-gnome/recipes-support/ibus/ibus.inc +++ b/meta-gnome/recipes-support/ibus/ibus.inc | |||
@@ -31,6 +31,9 @@ EXTRA_OECONF = " \ | |||
31 | --disable-emoji-dict \ | 31 | --disable-emoji-dict \ |
32 | --disable-python2 \ | 32 | --disable-python2 \ |
33 | " | 33 | " |
34 | EXTRA_OECONF:append:class-target = "\ | ||
35 | --with-python=${bindir}/python3 \ | ||
36 | " | ||
34 | 37 | ||
35 | do_configure:prepend() { | 38 | do_configure:prepend() { |
36 | touch ${S}/ChangeLog | 39 | touch ${S}/ChangeLog |