diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2021-07-29 17:04:53 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-03 10:21:25 -0700 |
commit | c61dc077bbd81260e4f167fa2251643ba0ba6974 (patch) | |
tree | 66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-gnome/recipes-support | |
parent | c5f7cfb8db54cfa4257797db5bd87828dea43296 (diff) | |
download | meta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz |
Convert to new override syntax
This is the result of automated script (0.9.1) conversion:
oe-core/scripts/contrib/convert-overrides.py .
converting the metadata to use ":" as the override character instead of "_".
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-support')
11 files changed, 19 insertions, 19 deletions
diff --git a/meta-gnome/recipes-support/accountsservice/accountsservice_0.6.55.bb b/meta-gnome/recipes-support/accountsservice/accountsservice_0.6.55.bb index edc4890005..a19102e8f6 100644 --- a/meta-gnome/recipes-support/accountsservice/accountsservice_0.6.55.bb +++ b/meta-gnome/recipes-support/accountsservice/accountsservice_0.6.55.bb | |||
@@ -13,7 +13,7 @@ inherit meson gobject-introspection gtk-doc features_check systemd | |||
13 | REQUIRED_DISTRO_FEATURES = "polkit" | 13 | REQUIRED_DISTRO_FEATURES = "polkit" |
14 | 14 | ||
15 | SRC_URI = "https://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz" | 15 | SRC_URI = "https://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz" |
16 | SRC_URI_append_libc-musl = " \ | 16 | SRC_URI:append:libc-musl = " \ |
17 | file://0001-musl-Hack-to-fix-build.patch \ | 17 | file://0001-musl-Hack-to-fix-build.patch \ |
18 | file://0002-musl-add-missing-fgetspent_r.patch \ | 18 | file://0002-musl-add-missing-fgetspent_r.patch \ |
19 | " | 19 | " |
@@ -25,9 +25,9 @@ GTKDOC_MESON_OPTION = "gtk_doc" | |||
25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
26 | PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false -Dsystemdsystemunitdir='no', systemd" | 26 | PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false -Dsystemdsystemunitdir='no', systemd" |
27 | 27 | ||
28 | SYSTEMD_SERVICE_${PN} = "accounts-daemon.service" | 28 | SYSTEMD_SERVICE:${PN} = "accounts-daemon.service" |
29 | 29 | ||
30 | FILES_${PN} += " \ | 30 | FILES:${PN} += " \ |
31 | ${datadir}/dbus-1 \ | 31 | ${datadir}/dbus-1 \ |
32 | ${datadir}/polkit-1 \ | 32 | ${datadir}/polkit-1 \ |
33 | " | 33 | " |
diff --git a/meta-gnome/recipes-support/appstream-glib/appstream-glib_0.7.18.bb b/meta-gnome/recipes-support/appstream-glib/appstream-glib_0.7.18.bb index e40354f56c..11d1442783 100644 --- a/meta-gnome/recipes-support/appstream-glib/appstream-glib_0.7.18.bb +++ b/meta-gnome/recipes-support/appstream-glib/appstream-glib_0.7.18.bb | |||
@@ -26,9 +26,9 @@ EXTRA_OEMESON = " \ | |||
26 | -Drpm=false \ | 26 | -Drpm=false \ |
27 | " | 27 | " |
28 | 28 | ||
29 | FILES_${PN} += "${libdir}/asb-plugins-5" | 29 | FILES:${PN} += "${libdir}/asb-plugins-5" |
30 | 30 | ||
31 | FILES_${PN}-dev += " \ | 31 | FILES:${PN}-dev += " \ |
32 | ${datadir}/installed-tests \ | 32 | ${datadir}/installed-tests \ |
33 | ${datadir}/gettext \ | 33 | ${datadir}/gettext \ |
34 | " | 34 | " |
diff --git a/meta-gnome/recipes-support/colord-gtk/colord-gtk_0.2.0.bb b/meta-gnome/recipes-support/colord-gtk/colord-gtk_0.2.0.bb index 7845509ba2..d5fd6a1326 100644 --- a/meta-gnome/recipes-support/colord-gtk/colord-gtk_0.2.0.bb +++ b/meta-gnome/recipes-support/colord-gtk/colord-gtk_0.2.0.bb | |||
@@ -22,4 +22,4 @@ REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" | |||
22 | # colord | 22 | # colord |
23 | REQUIRED_DISTRO_FEATURES += "polkit" | 23 | REQUIRED_DISTRO_FEATURES += "polkit" |
24 | 24 | ||
25 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" | 25 | UNKNOWN_CONFIGURE_WHITELIST:append = " introspection" |
diff --git a/meta-gnome/recipes-support/ibus/ibus.bb b/meta-gnome/recipes-support/ibus/ibus.bb index caec455b6d..2d733ce53e 100644 --- a/meta-gnome/recipes-support/ibus/ibus.bb +++ b/meta-gnome/recipes-support/ibus/ibus.bb | |||
@@ -19,19 +19,19 @@ PACKAGECONFIG ??= " \ | |||
19 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \ | 19 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)} \ |
20 | " | 20 | " |
21 | 21 | ||
22 | do_configure_prepend() { | 22 | do_configure:prepend() { |
23 | # run native unicode-parser | 23 | # run native unicode-parser |
24 | sed -i 's:$(builddir)/unicode-parser:unicode-parser:g' ${S}/src/Makefile.am | 24 | sed -i 's:$(builddir)/unicode-parser:unicode-parser:g' ${S}/src/Makefile.am |
25 | } | 25 | } |
26 | 26 | ||
27 | FILES_${PN} += " \ | 27 | FILES:${PN} += " \ |
28 | ${datadir}/dbus-1 \ | 28 | ${datadir}/dbus-1 \ |
29 | ${datadir}/GConf \ | 29 | ${datadir}/GConf \ |
30 | ${datadir}/glib-2.0 \ | 30 | ${datadir}/glib-2.0 \ |
31 | ${libdir}/gtk-3.0 \ | 31 | ${libdir}/gtk-3.0 \ |
32 | " | 32 | " |
33 | 33 | ||
34 | FILES_${PN}-dev += " \ | 34 | FILES:${PN}-dev += " \ |
35 | ${datadir}/gettext \ | 35 | ${datadir}/gettext \ |
36 | " | 36 | " |
37 | 37 | ||
diff --git a/meta-gnome/recipes-support/ibus/ibus.inc b/meta-gnome/recipes-support/ibus/ibus.inc index ea413cf4bd..810f369dd0 100644 --- a/meta-gnome/recipes-support/ibus/ibus.inc +++ b/meta-gnome/recipes-support/ibus/ibus.inc | |||
@@ -30,7 +30,7 @@ EXTRA_OECONF = " \ | |||
30 | --disable-python2 \ | 30 | --disable-python2 \ |
31 | " | 31 | " |
32 | 32 | ||
33 | do_configure_prepend() { | 33 | do_configure:prepend() { |
34 | touch ${S}/ChangeLog | 34 | touch ${S}/ChangeLog |
35 | touch ${S}/ABOUT-NLS | 35 | touch ${S}/ABOUT-NLS |
36 | } | 36 | } |
diff --git a/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb b/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb index d567d00d3f..e64fcf1ee6 100644 --- a/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb +++ b/meta-gnome/recipes-support/keybinder/keybinder_3.0.bb | |||
@@ -16,12 +16,12 @@ PV = "3.0+git${SRCPV}" | |||
16 | SRC_URI = "git://github.com/engla/keybinder.git;branch=keybinder-3.0 \ | 16 | SRC_URI = "git://github.com/engla/keybinder.git;branch=keybinder-3.0 \ |
17 | " | 17 | " |
18 | 18 | ||
19 | RDEPENDS_${PN} = "gtk+" | 19 | RDEPENDS:${PN} = "gtk+" |
20 | 20 | ||
21 | inherit features_check autotools gtk-doc gobject-introspection | 21 | inherit features_check autotools gtk-doc gobject-introspection |
22 | 22 | ||
23 | REQUIRED_DISTRO_FEATURES = "x11" | 23 | REQUIRED_DISTRO_FEATURES = "x11" |
24 | do_configure_prepend() { | 24 | do_configure:prepend() { |
25 | touch ${S}/ChangeLog | 25 | touch ${S}/ChangeLog |
26 | } | 26 | } |
27 | 27 | ||
diff --git a/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb b/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb index c1a06c0d0d..b169afcf14 100644 --- a/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb +++ b/meta-gnome/recipes-support/libstemmer/libstemmer_git.bb | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "https://snowballstem.org/" | |||
3 | LICENSE = "BSD-3-Clause" | 3 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=19139aaf3c8c8fa1ca6edd59c072fb9f" |
5 | 5 | ||
6 | DEPENDS_class-target = "${BPN}-native" | 6 | DEPENDS:class-target = "${BPN}-native" |
7 | 7 | ||
8 | SRC_URI = "\ | 8 | SRC_URI = "\ |
9 | git://github.com/snowballstem/snowball.git \ | 9 | git://github.com/snowballstem/snowball.git \ |
@@ -18,7 +18,7 @@ inherit lib_package | |||
18 | 18 | ||
19 | BBCLASSEXTEND = "native" | 19 | BBCLASSEXTEND = "native" |
20 | 20 | ||
21 | do_compile_prepend_class-target() { | 21 | do_compile:prepend:class-target() { |
22 | # use native tools | 22 | # use native tools |
23 | sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile | 23 | sed -i 's:./snowball :snowball :g' ${S}/GNUmakefile |
24 | } | 24 | } |
diff --git a/meta-gnome/recipes-support/libuser/libuser_0.62.bb b/meta-gnome/recipes-support/libuser/libuser_0.62.bb index 2c580f8727..722b647f21 100644 --- a/meta-gnome/recipes-support/libuser/libuser_0.62.bb +++ b/meta-gnome/recipes-support/libuser/libuser_0.62.bb | |||
@@ -30,5 +30,5 @@ EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" | |||
30 | 30 | ||
31 | PACKAGES += "${PN}-python " | 31 | PACKAGES += "${PN}-python " |
32 | 32 | ||
33 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" | 33 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
34 | 34 | ||
diff --git a/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb b/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb index 1eb4a100c5..e7733bf8b3 100644 --- a/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb +++ b/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb | |||
@@ -14,14 +14,14 @@ inherit features_check setuptools3 pkgconfig gtk-icon-cache gsettings mime-xdg | |||
14 | 14 | ||
15 | REQUIRED_DISTRO_FEATURES = "x11" | 15 | REQUIRED_DISTRO_FEATURES = "x11" |
16 | 16 | ||
17 | FILES_${PN} += " \ | 17 | FILES:${PN} += " \ |
18 | ${datadir}/dbus-1 \ | 18 | ${datadir}/dbus-1 \ |
19 | ${datadir}/icons \ | 19 | ${datadir}/icons \ |
20 | ${datadir}/gnome-shell \ | 20 | ${datadir}/gnome-shell \ |
21 | ${datadir}/help \ | 21 | ${datadir}/help \ |
22 | " | 22 | " |
23 | 23 | ||
24 | RDEPENDS_${PN} += " \ | 24 | RDEPENDS:${PN} += " \ |
25 | ncurses \ | 25 | ncurses \ |
26 | python3-dbus \ | 26 | python3-dbus \ |
27 | python3-pycairo \ | 27 | python3-pycairo \ |
diff --git a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-apps.bb b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-apps.bb index a45dfdeda2..d47d847a59 100644 --- a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-apps.bb +++ b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-apps.bb | |||
@@ -6,7 +6,7 @@ inherit packagegroup features_check | |||
6 | 6 | ||
7 | REQUIRED_DISTRO_FEATURES = "x11 polkit gobject-introspection-data" | 7 | REQUIRED_DISTRO_FEATURES = "x11 polkit gobject-introspection-data" |
8 | 8 | ||
9 | RDEPENDS_${PN} = " \ | 9 | RDEPENDS:${PN} = " \ |
10 | evolution-data-server \ | 10 | evolution-data-server \ |
11 | evince \ | 11 | evince \ |
12 | file-roller \ | 12 | file-roller \ |
diff --git a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb index 3c333fe005..95ef6901f1 100644 --- a/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb +++ b/meta-gnome/recipes-support/packagegroups/packagegroup-gnome-desktop.bb | |||
@@ -6,7 +6,7 @@ inherit packagegroup features_check | |||
6 | 6 | ||
7 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data" | 7 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data" |
8 | 8 | ||
9 | RDEPENDS_${PN} = " \ | 9 | RDEPENDS:${PN} = " \ |
10 | adwaita-icon-theme \ | 10 | adwaita-icon-theme \ |
11 | adwaita-icon-theme-cursors \ | 11 | adwaita-icon-theme-cursors \ |
12 | evolution-data-server \ | 12 | evolution-data-server \ |