summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-05-16 01:38:44 +0200
committerKhem Raj <raj.khem@gmail.com>2021-05-17 09:00:36 -0700
commit38578caab6405dd2e19d1e68f700ef8966c25ee0 (patch)
treedf361cca367c690fc50a44be154e3de320694768 /meta-gnome/recipes-gnome
parent8400df63c0f2282ee1693cc5a0d1bd82ec633344 (diff)
downloadmeta-openembedded-38578caab6405dd2e19d1e68f700ef8966c25ee0.tar.gz
dconf-editor: upgrade 3.38.2 -> 3.38.3
Backported patch can go Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/dconf/dconf-editor/0001-Don-t-alter-or-try-to-write-GtkChild-fields.patch522
-rw-r--r--meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.3.bb (renamed from meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.2.bb)4
2 files changed, 1 insertions, 525 deletions
diff --git a/meta-gnome/recipes-gnome/dconf/dconf-editor/0001-Don-t-alter-or-try-to-write-GtkChild-fields.patch b/meta-gnome/recipes-gnome/dconf/dconf-editor/0001-Don-t-alter-or-try-to-write-GtkChild-fields.patch
deleted file mode 100644
index 7c83ae339..000000000
--- a/meta-gnome/recipes-gnome/dconf/dconf-editor/0001-Don-t-alter-or-try-to-write-GtkChild-fields.patch
+++ /dev/null
@@ -1,522 +0,0 @@
1From ba4a39b74067b73c9bed64dad7be3d53e837dd8d Mon Sep 17 00:00:00 2001
2From: Rico Tzschichholz <ricotz@ubuntu.com>
3Date: Sat, 16 Jan 2021 13:26:32 +0100
4Subject: [PATCH] Don't alter or try to write GtkChild fields
5
6See https://gitlab.gnome.org/GNOME/vala/issues/1121
7
8Upstream-Status: Backport [https://github.com/GNOME/dconf-editor/commit/9272e9fb6867e71426bfd0aa5edce5ec39cf0ad4]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 editor/bookmarks-headerbar.vala | 4 +--
12 editor/bookmarks-list.vala | 4 +--
13 editor/bookmarks.vala | 12 +++----
14 editor/delayed-setting-view.vala | 54 ++++++++++++++++----------------
15 editor/overlayed-list.vala | 38 +++++++++++-----------
16 editor/pathentry.vala | 24 +++++++-------
17 editor/registry-list.vala | 6 ++--
18 editor/registry-search.vala | 6 ++--
19 editor/registry-view.vala | 2 +-
20 9 files changed, 75 insertions(+), 75 deletions(-)
21
22diff --git a/editor/bookmarks-headerbar.vala b/editor/bookmarks-headerbar.vala
23index 54848a5..0522c37 100644
24--- a/editor/bookmarks-headerbar.vala
25+++ b/editor/bookmarks-headerbar.vala
26@@ -24,7 +24,7 @@ private abstract class BookmarksHeaderBar : BrowserHeaderBar, AdaptativeWidget
27 install_action_entries ();
28
29 add_bookmarks_revealer (out bookmarks_revealer,
30- out bookmarks_button, ref center_box);
31+ out bookmarks_button, center_box);
32 connect_bookmarks_signals ();
33 add_bookmarks_controller (out bookmarks_controller, ref this);
34
35@@ -58,7 +58,7 @@ private abstract class BookmarksHeaderBar : BrowserHeaderBar, AdaptativeWidget
36 private Bookmarks bookmarks_button;
37 private BookmarksController bookmarks_controller;
38
39- private static void add_bookmarks_revealer (out Revealer bookmarks_revealer, out Bookmarks bookmarks_button, ref Box center_box)
40+ private static void add_bookmarks_revealer (out Revealer bookmarks_revealer, out Bookmarks bookmarks_button, Box center_box)
41 {
42 bookmarks_revealer = new Revealer ();
43 bookmarks_revealer.transition_type = RevealerTransitionType.SLIDE_LEFT;
44diff --git a/editor/bookmarks-list.vala b/editor/bookmarks-list.vala
45index 393973b..c9280d5 100644
46--- a/editor/bookmarks-list.vala
47+++ b/editor/bookmarks-list.vala
48@@ -146,10 +146,10 @@ private class BookmarksList : OverlayedList
49
50 internal bool create_bookmark_rows (Variant bookmarks_variant)
51 {
52- _create_bookmark_rows (bookmarks_variant, view_mode, ref main_list_store, ref main_list_box, ref bookmarks_hashtable);
53+ _create_bookmark_rows (bookmarks_variant, view_mode, ref main_list_store, main_list_box, ref bookmarks_hashtable);
54 return n_items == 0;
55 }
56- private static void _create_bookmark_rows (Variant bookmarks_variant, bool view_mode, ref GLib.ListStore main_list_store, ref ListBox main_list_box, ref HashTable<string, Bookmark> bookmarks_hashtable)
57+ private static void _create_bookmark_rows (Variant bookmarks_variant, bool view_mode, ref GLib.ListStore main_list_store, ListBox main_list_box, ref HashTable<string, Bookmark> bookmarks_hashtable)
58 {
59 string saved_bookmark_name = "";
60 ListBoxRow? selected_row = main_list_box.get_selected_row ();
61diff --git a/editor/bookmarks.vala b/editor/bookmarks.vala
62index 153af10..d8cea7c 100644
63--- a/editor/bookmarks.vala
64+++ b/editor/bookmarks.vala
65@@ -84,7 +84,7 @@ private class Bookmarks : MenuButton
66
67 construct
68 {
69- update_switch_label (ViewType.SEARCH, ViewType.FOLDER, ref switch_label); // init text with "Bookmark this Location"
70+ update_switch_label (ViewType.SEARCH, ViewType.FOLDER, switch_label); // init text with "Bookmark this Location"
71
72 install_action_entries ();
73
74@@ -184,7 +184,7 @@ private class Bookmarks : MenuButton
75
76 internal void set_path (ViewType type, string path)
77 {
78- update_switch_label (current_type, type, ref switch_label);
79+ update_switch_label (current_type, type, switch_label);
80
81 current_path = path;
82 current_type = type;
83@@ -392,7 +392,7 @@ private class Bookmarks : MenuButton
84 * * Bookmarks management
85 \*/
86
87- private static void update_switch_label (ViewType old_type, ViewType new_type, ref Label switch_label)
88+ private static void update_switch_label (ViewType old_type, ViewType new_type, Label switch_label)
89 {
90 if (new_type == ViewType.SEARCH && old_type != ViewType.SEARCH)
91 switch_label.label = bookmark_this_search_text;
92@@ -414,18 +414,18 @@ private class Bookmarks : MenuButton
93 {
94 if (bookmarks_icon.icon_name != "starred-symbolic")
95 bookmarks_icon.icon_name = "starred-symbolic";
96- update_switch_state (true, ref bookmarked_switch);
97+ update_switch_state (true, bookmarked_switch);
98 bookmarked_switch.set_detailed_action_name ("bookmarks.unbookmark(" + variant.print (true) + ")");
99 }
100 else
101 {
102 if (bookmarks_icon.icon_name != "non-starred-symbolic")
103 bookmarks_icon.icon_name = "non-starred-symbolic";
104- update_switch_state (false, ref bookmarked_switch);
105+ update_switch_state (false, bookmarked_switch);
106 bookmarked_switch.set_detailed_action_name ("bookmarks.bookmark(" + variant.print (true) + ")");
107 }
108 }
109- private static void update_switch_state (bool bookmarked, ref Switch bookmarked_switch)
110+ private static void update_switch_state (bool bookmarked, Switch bookmarked_switch)
111 {
112 if (bookmarked == bookmarked_switch.active)
113 return;
114diff --git a/editor/delayed-setting-view.vala b/editor/delayed-setting-view.vala
115index add6852..b1f774c 100644
116--- a/editor/delayed-setting-view.vala
117+++ b/editor/delayed-setting-view.vala
118@@ -41,24 +41,24 @@ private class DelayedSettingView : OverlayedListRow
119 {
120 // at row creation, key is never ghost
121 _update_dconf_key_current_value (key_value,
122- ref key_value_label,
123- ref key_value_default);
124+ key_value_label,
125+ key_value_default);
126
127 _update_dconf_key_planned_value (cool_planned_value,
128- ref planned_value_label,
129- ref planned_value_default);
130+ planned_value_label,
131+ planned_value_default);
132 }
133 else
134 {
135 _update_gsettings_key_current_value (key_value,
136 has_schema_and_is_default,
137- ref key_value_label,
138- ref key_value_default);
139+ key_value_label,
140+ key_value_default);
141
142 _update_gsettings_key_planned_value (cool_planned_value,
143 (!) cool_default_value,
144- ref planned_value_label,
145- ref planned_value_default);
146+ planned_value_label,
147+ planned_value_default);
148 }
149 }
150
151@@ -74,23 +74,23 @@ private class DelayedSettingView : OverlayedListRow
152
153 private static inline void _update_gsettings_key_planned_value (string? cool_planned_value,
154 string cool_default_value,
155- ref Label planned_value_label,
156- ref Label planned_value_default)
157+ Label planned_value_label,
158+ Label planned_value_default)
159 {
160 bool is_default = cool_planned_value == null;
161 planned_value_label.label = is_default ? cool_default_value : (!) cool_planned_value;
162- update_value_default_label (is_default, ref planned_value_default);
163+ update_value_default_label (is_default, planned_value_default);
164 }
165
166 private static inline void _update_dconf_key_planned_value (string? cool_planned_value,
167- ref Label planned_value_label,
168- ref Label planned_value_default)
169+ Label planned_value_label,
170+ Label planned_value_default)
171 {
172 if (cool_planned_value == null)
173- update_labels_dconf_key_erased (ref planned_value_label, ref planned_value_default);
174+ update_labels_dconf_key_erased (planned_value_label, planned_value_default);
175 else
176 update_labels_dconf_key_values ((!) cool_planned_value,
177- ref planned_value_label, ref planned_value_default);
178+ planned_value_label, planned_value_default);
179 }
180
181 /*\
182@@ -99,37 +99,37 @@ private class DelayedSettingView : OverlayedListRow
183
184 internal void update_gsettings_key_current_value (Variant key_value, bool is_default)
185 {
186- _update_gsettings_key_current_value (key_value, is_default, ref key_value_label, ref key_value_default);
187+ _update_gsettings_key_current_value (key_value, is_default, key_value_label, key_value_default);
188 }
189 private static void _update_gsettings_key_current_value (Variant key_value,
190 bool is_default,
191- ref Label key_value_label,
192- ref Label key_value_default)
193+ Label key_value_label,
194+ Label key_value_default)
195 {
196 key_value_label.label = Key.cool_text_value_from_variant (key_value);
197- update_value_default_label (is_default, ref key_value_default);
198+ update_value_default_label (is_default, key_value_default);
199 }
200
201 internal void update_dconf_key_current_value (Variant? key_value_or_null)
202 {
203- _update_dconf_key_current_value (key_value_or_null, ref key_value_label, ref key_value_default);
204+ _update_dconf_key_current_value (key_value_or_null, key_value_label, key_value_default);
205 }
206 private static void _update_dconf_key_current_value (Variant? key_value_or_null,
207- ref Label key_value_label,
208- ref Label key_value_default)
209+ Label key_value_label,
210+ Label key_value_default)
211 {
212 if (key_value_or_null == null)
213- update_labels_dconf_key_erased (ref key_value_label, ref key_value_default);
214+ update_labels_dconf_key_erased (key_value_label, key_value_default);
215 else
216 update_labels_dconf_key_values (Key.cool_text_value_from_variant ((!) key_value_or_null),
217- ref key_value_label, ref key_value_default);
218+ key_value_label, key_value_default);
219 }
220
221 /*\
222 * * common utilities
223 \*/
224
225- private static void update_labels_dconf_key_erased (ref Label value_label, ref Label value_default)
226+ private static void update_labels_dconf_key_erased (Label value_label, Label value_default)
227 {
228 value_label.visible = false;
229 /* Translators: displayed in the list of pending changes (could be an in-window panel, or in the popover of the bottom bar); for dconf keys */
230@@ -137,14 +137,14 @@ private class DelayedSettingView : OverlayedListRow
231 value_default.visible = true;
232 }
233
234- private static void update_labels_dconf_key_values (string key_value, ref Label value_label, ref Label value_default)
235+ private static void update_labels_dconf_key_values (string key_value, Label value_label, Label value_default)
236 {
237 value_default.visible = false;
238 value_label.label = key_value; // TODO move Key.cool_text_value_from_variant here?
239 value_label.visible = true;
240 }
241
242- private static void update_value_default_label (bool is_default, ref Label value_default)
243+ private static void update_value_default_label (bool is_default, Label value_default)
244 {
245 if (is_default)
246 /* Translators: displayed in the list of pending changes (could be an in-window panel, or in the popover of the bottom bar); for gsettings keys */
247diff --git a/editor/overlayed-list.vala b/editor/overlayed-list.vala
248index 8b0ec51..bcdfc3a 100644
249--- a/editor/overlayed-list.vala
250+++ b/editor/overlayed-list.vala
251@@ -89,11 +89,11 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
252 internal void set_window_size (AdaptativeWidget.WindowSize new_size)
253 {
254 if (!AdaptativeWidget.WindowSize.is_extra_thin (new_size) && AdaptativeWidget.WindowSize.is_extra_flat (new_size))
255- set_horizontal (ref main_context, ref edit_mode_box);
256+ set_horizontal (ref main_context, edit_mode_box);
257 else
258- set_vertical (ref main_context, ref edit_mode_box);
259+ set_vertical (ref main_context, edit_mode_box);
260 }
261- private static inline void set_horizontal (ref StyleContext main_context, ref Box edit_mode_box)
262+ private static inline void set_horizontal (ref StyleContext main_context, Box edit_mode_box)
263 {
264 main_context.remove_class ("vertical");
265 edit_mode_box.halign = Align.END;
266@@ -102,7 +102,7 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
267 edit_mode_box.width_request = 160;
268 main_context.add_class ("horizontal");
269 }
270- private static inline void set_vertical (ref StyleContext main_context, ref Box edit_mode_box)
271+ private static inline void set_vertical (ref StyleContext main_context, Box edit_mode_box)
272 {
273 main_context.remove_class ("horizontal");
274 edit_mode_box.halign = Align.CENTER;
275@@ -118,9 +118,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
276
277 internal bool next_match ()
278 {
279- return _next_match (ref main_list_box);
280+ return _next_match (main_list_box);
281 }
282- private static inline bool _next_match (ref ListBox main_list_box)
283+ private static inline bool _next_match (ListBox main_list_box)
284 {
285 ListBoxRow? row = main_list_box.get_selected_row (); // TODO multiple rows and focus-only lists
286 if (row == null)
287@@ -130,7 +130,7 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
288
289 if (row == null)
290 {
291- _scroll_bottom (ref main_list_box);
292+ _scroll_bottom (main_list_box);
293 return false;
294 }
295 main_list_box.select_row ((!) row);
296@@ -140,9 +140,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
297
298 internal bool previous_match ()
299 {
300- return _previous_match (ref main_list_box);
301+ return _previous_match (main_list_box);
302 }
303- private static inline bool _previous_match (ref ListBox main_list_box)
304+ private static inline bool _previous_match (ListBox main_list_box)
305 {
306 uint n_items = main_list_box.get_children ().length (); // FIXME OverlayedList.n_items is unreliable
307 if (n_items == 0)
308@@ -189,9 +189,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
309
310 protected int [] get_selected_rows_indices ()
311 {
312- return _get_selected_rows_indices (ref main_list_box);
313+ return _get_selected_rows_indices (main_list_box);
314 }
315- private static inline int [] _get_selected_rows_indices (ref ListBox main_list_box)
316+ private static inline int [] _get_selected_rows_indices (ListBox main_list_box)
317 {
318 int [] indices = new int [0];
319 main_list_box.selected_foreach ((_list_box, selected_row) => {
320@@ -205,9 +205,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
321
322 protected void scroll_top ()
323 {
324- _scroll_top (ref main_list_box);
325+ _scroll_top (main_list_box);
326 }
327- private static inline void _scroll_top (ref ListBox main_list_box)
328+ private static inline void _scroll_top (ListBox main_list_box)
329 {
330 Adjustment adjustment = main_list_box.get_adjustment ();
331 adjustment.set_value (adjustment.get_lower ());
332@@ -215,9 +215,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
333
334 protected void scroll_bottom ()
335 {
336- _scroll_bottom (ref main_list_box);
337+ _scroll_bottom (main_list_box);
338 }
339- private static inline void _scroll_bottom (ref ListBox main_list_box)
340+ private static inline void _scroll_bottom (ListBox main_list_box)
341 {
342 Adjustment adjustment = main_list_box.get_adjustment ();
343 adjustment.set_value (adjustment.get_upper ());
344@@ -225,9 +225,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
345
346 internal bool handle_copy_text (out string copy_text)
347 {
348- return _handle_copy_text (out copy_text, ref main_list_box);
349+ return _handle_copy_text (out copy_text, main_list_box);
350 }
351- private static inline bool _handle_copy_text (out string copy_text, ref ListBox main_list_box)
352+ private static inline bool _handle_copy_text (out string copy_text, ListBox main_list_box)
353 {
354 List<weak ListBoxRow> selected_rows = main_list_box.get_selected_rows ();
355 OverlayedListRow row;
356@@ -283,9 +283,9 @@ private abstract class OverlayedList : Overlay, AdaptativeWidget
357
358 internal SelectionState get_selection_state ()
359 {
360- return _get_selection_state (ref main_list_box, ref main_list_store);
361+ return _get_selection_state (main_list_box, ref main_list_store);
362 }
363- private static inline SelectionState _get_selection_state (ref ListBox main_list_box, ref GLib.ListStore main_list_store)
364+ private static inline SelectionState _get_selection_state (ListBox main_list_box, ref GLib.ListStore main_list_store)
365 {
366 List<weak ListBoxRow> selected_rows = main_list_box.get_selected_rows ();
367 uint n_selected_rows = selected_rows.length ();
368diff --git a/editor/pathentry.vala b/editor/pathentry.vala
369index 5000b21..5c7efc5 100644
370--- a/editor/pathentry.vala
371+++ b/editor/pathentry.vala
372@@ -133,9 +133,9 @@ private class PathEntry : Box, AdaptativeWidget
373
374 internal void entry_grab_focus_without_selecting ()
375 {
376- _entry_grab_focus_without_selecting (ref search_entry);
377+ _entry_grab_focus_without_selecting (search_entry);
378 }
379- private static void _entry_grab_focus_without_selecting (ref BrowserEntry search_entry)
380+ private static void _entry_grab_focus_without_selecting (BrowserEntry search_entry)
381 {
382 if (search_entry.text_length != 0)
383 {
384@@ -172,36 +172,36 @@ private class PathEntry : Box, AdaptativeWidget
385 requires (search_changed_handler != 0)
386 {
387 SignalHandler.block (search_entry, search_changed_handler);
388- _prepare (mode, nullable_search, ref current_path, ref search_entry);
389+ _prepare (mode, nullable_search, ref current_path, search_entry);
390 SignalHandler.unblock (search_entry, search_changed_handler);
391 }
392
393 private static inline void _prepare (SearchMode mode,
394 string? nullable_search,
395 ref string current_path,
396- ref BrowserEntry search_entry)
397+ BrowserEntry search_entry)
398 {
399 string search;
400 switch (mode)
401 {
402 case SearchMode.EDIT_PATH_MOVE_END:
403 search = nullable_search == null ? current_path : (!) nullable_search;
404- _prepare_move_end (ref search, ref search_entry);
405+ _prepare_move_end (ref search, search_entry);
406 return;
407
408 case SearchMode.EDIT_PATH_SELECT_ALL:
409 search = nullable_search == null ? current_path : (!) nullable_search;
410- _prepare_search (ref search, ref search_entry);
411+ _prepare_search (ref search, search_entry);
412 return;
413
414 case SearchMode.EDIT_PATH_SELECT_LAST_WORD:
415 search = current_path;
416- _prepare_select_last_word (ref search, ref search_entry);
417+ _prepare_select_last_word (ref search, search_entry);
418 return;
419
420 case SearchMode.SEARCH:
421 search = "";
422- _prepare_search (ref search, ref search_entry);
423+ _prepare_search (ref search, search_entry);
424 return;
425
426 case SearchMode.UNCLEAR:
427@@ -210,19 +210,19 @@ private class PathEntry : Box, AdaptativeWidget
428 }
429 }
430
431- private static inline void _prepare_move_end (ref string text, ref BrowserEntry search_entry)
432+ private static inline void _prepare_move_end (ref string text, BrowserEntry search_entry)
433 {
434 search_entry.text = text;
435- _entry_grab_focus_without_selecting (ref search_entry);
436+ _entry_grab_focus_without_selecting (search_entry);
437 }
438
439- private static inline void _prepare_search (ref string text, ref BrowserEntry search_entry)
440+ private static inline void _prepare_search (ref string text, BrowserEntry search_entry)
441 {
442 search_entry.text = text;
443 search_entry.grab_focus ();
444 }
445
446- private static inline void _prepare_select_last_word (ref string current_path, ref BrowserEntry search_entry)
447+ private static inline void _prepare_select_last_word (ref string current_path, BrowserEntry search_entry)
448 {
449 search_entry.move_cursor (MovementStep.DISPLAY_LINE_ENDS, -1, false);
450 search_entry.text = current_path;
451diff --git a/editor/registry-list.vala b/editor/registry-list.vala
452index 74b7f99..54aa6fa 100644
453--- a/editor/registry-list.vala
454+++ b/editor/registry-list.vala
455@@ -291,9 +291,9 @@ private abstract class RegistryList : Grid, BrowsableView, AdaptativeWidget
456
457 internal bool handle_copy_text (out string copy_text) // can compile with "private", but is public 1/2
458 {
459- return _handle_copy_text (out copy_text, ref key_list_box);
460+ return _handle_copy_text (out copy_text, key_list_box);
461 }
462- private bool _handle_copy_text (out string copy_text, ref ListBox key_list_box)
463+ private bool _handle_copy_text (out string copy_text, ListBox key_list_box)
464 {
465 ListBoxRow? selected_row = (ListBoxRow?) key_list_box.get_selected_row ();
466 if (selected_row == null)
467@@ -1138,7 +1138,7 @@ private abstract class RegistryList : Grid, BrowsableView, AdaptativeWidget
468 * * headers
469 \*/
470
471- protected static bool is_first_row (int row_index, ref unowned ListBoxRow? before)
472+ protected static bool is_first_row (int row_index, ListBoxRow? before)
473 {
474 bool is_first_row = row_index == 0;
475 if (is_first_row != (before == null))
476diff --git a/editor/registry-search.vala b/editor/registry-search.vala
477index 220583f..eb8e6f2 100644
478--- a/editor/registry-search.vala
479+++ b/editor/registry-search.vala
480@@ -48,7 +48,7 @@ private class RegistrySearch : RegistryList
481
482 internal bool handle_alt_copy_text (out string copy_text)
483 {
484- return _handle_alt_copy_text (out copy_text, ref key_list_box);
485+ return _handle_alt_copy_text (out copy_text, key_list_box);
486 }
487
488 internal void clean ()
489@@ -145,7 +145,7 @@ private class RegistrySearch : RegistryList
490 * * Keyboard calls
491 \*/
492
493- private static bool _handle_alt_copy_text (out string copy_text, ref ListBox key_list_box)
494+ private static bool _handle_alt_copy_text (out string copy_text, ListBox key_list_box)
495 {
496 ListBoxRow? selected_row = key_list_box.get_selected_row ();
497 if (selected_row == null)
498@@ -521,7 +521,7 @@ private class RegistrySearch : RegistryList
499 private void update_row_header (ListBoxRow row, ListBoxRow? before)
500 {
501 int row_index = row.get_index ();
502- if (is_first_row (row_index, ref before))
503+ if (is_first_row (row_index, before))
504 return;
505
506 if (search_is_path_search)
507diff --git a/editor/registry-view.vala b/editor/registry-view.vala
508index e0ff379..7d9eb1f 100644
509--- a/editor/registry-view.vala
510+++ b/editor/registry-view.vala
511@@ -114,7 +114,7 @@ private class RegistryView : RegistryList
512
513 private void update_row_header (ListBoxRow row, ListBoxRow? before)
514 {
515- if (is_first_row (row.get_index (), ref before))
516+ if (is_first_row (row.get_index (), before))
517 return;
518 update_row_header_with_context (row, (!) before, modifications_handler.model, /* local search header */ false);
519 }
520--
5212.30.1
522
diff --git a/meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.2.bb b/meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.3.bb
index 776558ebf..5b68467a1 100644
--- a/meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.2.bb
+++ b/meta-gnome/recipes-gnome/dconf/dconf-editor_3.38.3.bb
@@ -8,9 +8,7 @@ DEPENDS = "dconf gtk+3"
8 8
9inherit gnomebase vala gettext gsettings bash-completion 9inherit gnomebase vala gettext gsettings bash-completion
10 10
11SRC_URI += "file://0001-Don-t-alter-or-try-to-write-GtkChild-fields.patch" 11SRC_URI[archive.sha256sum] = "571af4c7dad4f049b53e6cd728b79addf08c27ddab6bc57b396d211866ee79e3"
12
13SRC_URI[archive.sha256sum] = "1253dad87e6213fbf313ff9ec9dc4358aa1b10261f28072c1dc0e0997b92f835"
14 12
15FILES_${PN} += " \ 13FILES_${PN} += " \
16 ${datadir}/dbus-1 \ 14 ${datadir}/dbus-1 \