summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-01-17 09:34:20 +0100
committerArmin Kuster <akuster808@gmail.com>2018-01-22 19:40:02 -0800
commit2ce2e2f4d50d912eee79eaf0aae63dc98484c15d (patch)
tree373642fe4521dbd85594169c5a02f48851740630 /meta-gnome/recipes-gnome
parent52e348716a079e431b44789502d170f54b524cd3 (diff)
downloadmeta-openembedded-2ce2e2f4d50d912eee79eaf0aae63dc98484c15d.tar.gz
gtksourceview-classic-light: initial add 1.0
This theme is helpful when using dark themes as it keeps white background. Tested with: * oe-build gedit based on GTK2 * fedora's gedit based on GTK3 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light/classic-light.xml131
-rw-r--r--meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light_1.0.bb21
2 files changed, 152 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light/classic-light.xml b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light/classic-light.xml
new file mode 100644
index 000000000..23b4b9a22
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light/classic-light.xml
@@ -0,0 +1,131 @@
1<?xml version="1.0" encoding="UTF-8"?>
2<!--
3
4 Based on gtksourceview 'classic'
5
6 This file is part of GtkSourceView
7
8 Copyright (C) 2006-2007 GtkSourceView team
9 Author: Yevgen Muntyan <muntyan@tamu.edu>
10
11 GtkSourceView is free software; you can redistribute it and/or
12 modify it under the terms of the GNU Lesser General Public
13 License as published by the Free Software Foundation; either
14 version 2.1 of the License, or (at your option) any later version.
15
16 GtkSourceView is distributed in the hope that it will be useful,
17 but WITHOUT ANY WARRANTY; without even the implied warranty of
18 MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 Lesser General Public License for more details.
20
21 You should have received a copy of the GNU Lesser General Public
22 License along with this library; if not, write to the Free Software
23 Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
24
25-->
26<style-scheme id="classic-light" _name="Classic-Light" version="1.0">
27 <author>GtkSourceView team</author>
28 <_description>Classic color scheme light</_description>
29
30 <!-- The scheme tries to look like the default GVim scheme,
31 since it is also what the hardwired GtkSourceView 1 color
32 scheme did -->
33
34 <!-- Palette -->
35 <color name="black" value="#000000"/>
36 <color name="white" value="#FFFFFF"/>
37 <color name="blue" value="#0000FF"/>
38 <color name="magenta" value="#FF00FF"/>
39 <color name="violet" value="#6A5ACD"/>
40 <color name="cyan" value="#008A8C"/>
41 <color name="gray" value="#BEBEBE"/>
42 <color name="lightgray" value="#E0E0E0"/>
43 <color name="green" value="#2E8B57"/>
44 <color name="bordeaux" value="#A52A2A"/>
45 <color name="red" value="#FF0000"/>
46 <color name="yellow" value="#FFFF00"/>
47 <color name="purple" value="#A020F0"/>
48
49 <!-- Global Settings -->
50 <style name="current-line" background="#eeeeec"/>
51 <style name="current-line-number" background="#eeeeec"/>
52 <style name="draw-spaces" foreground="#babdb6"/>
53 <style name="background-pattern" background="#f3f3f3"/>
54 <style name="text" foreground="black" background="white"/>
55 <style name="selection" background="gray"/>
56 <style name="cursor" foreground="black"/>
57 <style name="line-numbers" foreground="black" background="gray"/>
58
59 <!-- Bracket Matching -->
60 <style name="bracket-match" foreground="white" background="gray"/>
61 <style name="bracket-mismatch" foreground="white" background="red"/>
62
63 <!-- Right Margin -->
64 <style name="right-margin" foreground="#000000" background="#000000"/>
65
66 <!-- Search Matching -->
67 <style name="search-match" background="yellow"/>
68
69 <!-- Comments -->
70 <style name="def:comment" foreground="blue"/>
71 <style name="def:shebang" foreground="blue" bold="true"/>
72 <style name="def:doc-comment-element" italic="true"/>
73
74 <!-- Constants -->
75 <style name="def:constant" foreground="magenta"/>
76 <style name="def:special-char" foreground="violet"/>
77
78 <!-- Identifiers -->
79 <style name="def:identifier" foreground="cyan"/>
80
81 <!-- Statements -->
82 <style name="def:statement" foreground="bordeaux" bold="true"/>
83
84 <!-- Types -->
85 <style name="def:type" foreground="green" bold="true"/>
86
87 <!-- Others -->
88 <style name="def:preprocessor" foreground="purple"/>
89 <style name="def:error" background="red" bold="true"/>
90 <style name="def:warning" background="yellow"/>
91 <style name="def:note" foreground="blue" background="yellow" bold="true"/>
92 <style name="def:underlined" italic="true" underline="single"/>
93
94 <!-- Heading styles, uncomment to enable -->
95 <!--
96 <style name="def:heading0" scale="5.0"/>
97 <style name="def:heading1" scale="2.5"/>
98 <style name="def:heading2" scale="2.0"/>
99 <style name="def:heading3" scale="1.7"/>
100 <style name="def:heading4" scale="1.5"/>
101 <style name="def:heading5" scale="1.3"/>
102 <style name="def:heading6" scale="1.2"/>
103 -->
104
105 <!-- Language specific styles -->
106 <style name="diff:added-line" foreground="#008B8B"/>
107 <style name="diff:removed-line" foreground="#6A5ACD"/>
108 <style name="diff:changed-line" use-style="def:preprocessor"/>
109 <style name="diff:special-case" use-style="def:constant"/>
110 <style name="diff:location" use-style="def:statement"/>
111 <style name="diff:diff-file" use-style="def:type"/>
112
113 <style name="xml:tags" foreground="cyan"/>
114 <style name="xml:attribute-name" foreground="violet"/>
115 <style name="xml:namespace" foreground="green" bold="true"/>
116
117 <style name="js:object" foreground="#2E8B57" bold="true"/>
118 <style name="js:constructors" foreground="#008B8B"/>
119
120 <style name="latex:display-math" foreground="#6A5ACD"/>
121 <style name="latex:command" foreground="#2E8B57" bold="true"/>
122 <style name="latex:include" use-style="def:preprocessor"/>
123
124 <style name="sh:variable" foreground="#6A5ACD"/>
125
126 <!-- legacy styles for old lang files -->
127 <style name="Others" foreground="#2E8B57" bold="true"/>
128 <style name="Others 2" foreground="#008B8B"/>
129 <style name="Others 3" foreground="#6A5ACD"/>
130
131</style-scheme>
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light_1.0.bb b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light_1.0.bb
new file mode 100644
index 000000000..e7dc0f865
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview-classic-light_1.0.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Gtksourceview Classic-Light theme"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://classic-light.xml;beginline=6;endline=23;md5=2b4f75364fad00a4d752214dcbd7d7c3"
4
5inherit allarch
6
7SRC_URI = "file://classic-light.xml"
8
9S = "${WORKDIR}"
10
11do_install() {
12 install -d ${D}${datadir}/gtksourceview-2.0/styles
13 install -m 0644 ${WORKDIR}/classic-light.xml ${D}${datadir}/gtksourceview-2.0/styles/
14 install -d ${D}${datadir}/gtksourceview-3.0/styles
15 install -m 0644 ${WORKDIR}/classic-light.xml ${D}${datadir}/gtksourceview-3.0/styles/
16}
17
18FILES_${PN} = " \
19 ${datadir}/gtksourceview-2.0/styles \
20 ${datadir}/gtksourceview-3.0/styles \
21"