summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/eds
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-11-27 07:54:40 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-27 12:44:58 +0100
commitb670b48220004890055e0a869794e67e51cfce71 (patch)
treebb1517041412b2bd799d77ae9c426797b2ea052b /meta-gnome/recipes-gnome/eds
parent3fd3b8153d2d90123682e603506559aae11c7ee3 (diff)
downloadmeta-openembedded-b670b48220004890055e0a869794e67e51cfce71.tar.gz
evolution-data-server: fix build with libxml2-2.9.0
* newer eds versions depend on external libgdata http://git.gnome.org/browse/evolution-data-server/commit/servers?h=gnome-2-32&id=28897beab5dcd4aab3586322a96280be92585db6 but for this one, we need this patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/eds')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-soup-adapt-to-new-libxml2-API-from-2.9.0.patch100
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb3
2 files changed, 102 insertions, 1 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-soup-adapt-to-new-libxml2-API-from-2.9.0.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
new file mode 100644
index 000000000..79058019b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
@@ -0,0 +1,100 @@
1From 5083b22669f0d2102b72956a2b8afd9432303ce5 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Tue, 27 Nov 2012 08:46:51 +0100
4Subject: [PATCH] soup: adapt to new libxml2 API from 2.9.0
5
6* for more info see
7 https://mail.gnome.org/archives/xml/2012-August/msg00005.html
8
9Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
10---
11 calendar/backends/caldav/e-cal-backend-caldav.c | 21 +++++++++++++++++++++
12 servers/google/libgdata/gdata-entry.c | 8 ++++++++
13 2 files changed, 29 insertions(+)
14
15diff --git a/calendar/backends/caldav/e-cal-backend-caldav.c b/calendar/backends/caldav/e-cal-backend-caldav.c
16index 5e7ecc4..b7f4afb 100644
17--- a/calendar/backends/caldav/e-cal-backend-caldav.c
18+++ b/calendar/backends/caldav/e-cal-backend-caldav.c
19@@ -1038,8 +1038,13 @@ check_calendar_changed_on_server (ECalBackendCalDAV *cbdav)
20 soup_message_set_request (message,
21 "application/xml",
22 SOUP_MEMORY_COPY,
23+#ifdef LIBXML2_NEW_BUFFER
24+ (gchar *) xmlOutputBufferGetContent(buf),
25+ xmlOutputBufferGetSize(buf));
26+#else
27 (gchar *) buf->buffer->content,
28 buf->buffer->use);
29+#endif
30
31 /* Send the request now */
32 send_and_handle_redirection (priv->session, message, NULL);
33@@ -1180,8 +1185,13 @@ caldav_server_list_objects (ECalBackendCalDAV *cbdav, CalDAVObject **objs, gint
34 soup_message_set_request (message,
35 "application/xml",
36 SOUP_MEMORY_COPY,
37+#ifdef LIBXML2_NEW_BUFFER
38+ (gchar *) xmlOutputBufferGetContent(buf),
39+ xmlOutputBufferGetSize(buf));
40+#else
41 (gchar *) buf->buffer->content,
42 buf->buffer->use);
43+#endif
44
45 /* Send the request now */
46 send_and_handle_redirection (priv->session, message, NULL);
47@@ -1502,8 +1512,14 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
48 soup_message_set_request (message,
49 "application/xml",
50 SOUP_MEMORY_COPY,
51+#ifdef LIBXML2_NEW_BUFFER
52+ (gchar *) xmlOutputBufferGetContent(buf),
53+ xmlOutputBufferGetSize(buf));
54+#else
55 (gchar *) buf->buffer->content,
56 buf->buffer->use);
57+#endif
58+
59
60 /* Send the request now */
61 send_and_handle_redirection (priv->session, message, NULL);
62@@ -1552,8 +1568,13 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
63 soup_message_set_request (message,
64 "application/xml",
65 SOUP_MEMORY_COPY,
66+#ifdef LIBXML2_NEW_BUFFER
67+ (gchar *) xmlOutputBufferGetContent(buf),
68+ xmlOutputBufferGetSize(buf));
69+#else
70 (gchar *) buf->buffer->content,
71 buf->buffer->use);
72+#endif
73
74 /* Send the request now */
75 send_and_handle_redirection (priv->session, message, NULL);
76diff --git a/servers/google/libgdata/gdata-entry.c b/servers/google/libgdata/gdata-entry.c
77index ab69eb0..3f05b17 100644
78--- a/servers/google/libgdata/gdata-entry.c
79+++ b/servers/google/libgdata/gdata-entry.c
80@@ -877,9 +877,17 @@ gdata_entry_new_from_xmlptr (xmlDocPtr doc, xmlNodePtr cur)
81 xmlOutputBufferFlush (buf);
82
83 if (buf->conv == NULL)
84+#ifdef LIBXML2_NEW_BUFFER
85+ xmlString = g_strdup ((gchar *) xmlOutputBufferGetContent(buf));
86+#else
87 xmlString = g_strdup ((gchar *)buf->buffer->content);
88+#endif
89 else
90+#ifdef LIBXML2_NEW_BUFFER
91+ xmlString = g_strdup ((gchar *) xmlBufContent(buf));
92+#else
93 xmlString = g_strdup ((gchar *)buf->conv->content);
94+#endif
95 xmlOutputBufferClose (buf);
96 }
97
98--
991.8.0
100
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
index 90642512d..958a90cca 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
@@ -13,7 +13,7 @@ DEPENDS = "intltool-native glib-2.0 gtk+ gconf dbus db gnome-common virtual/libi
13SRCREV = "3ca578d968d09785933ebbb45b66b3bccdbd5832" 13SRCREV = "3ca578d968d09785933ebbb45b66b3bccdbd5832"
14 14
15PV = "2.30+git${SRCPV}" 15PV = "2.30+git${SRCPV}"
16PR = "r3" 16PR = "r4"
17 17
18SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \ 18SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
19 file://oh-contact.patch;striplevel=0 \ 19 file://oh-contact.patch;striplevel=0 \
@@ -24,6 +24,7 @@ SRC_URI = "git://git.gnome.org/evolution-data-server;protocol=git \
24 file://depbuildfix.patch \ 24 file://depbuildfix.patch \
25 file://fix_for_automake-1.12.x.patch \ 25 file://fix_for_automake-1.12.x.patch \
26 file://avoid_automake_errors.patch \ 26 file://avoid_automake_errors.patch \
27 file://0001-soup-adapt-to-new-libxml2-API-from-2.9.0.patch \
27 file://iconv-detect.h" 28 file://iconv-detect.h"
28 29
29S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"