summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2014-04-01 17:10:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 10:40:28 +0200
commit0aaf18723d7280b62af3e66106859bc5c51a185a (patch)
treebd6905332eeb2a993dff50d598f578b7879a42d8 /meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
parent4328d8f4035fe3990eae7e877df6bdf65480c97a (diff)
downloadmeta-openembedded-0aaf18723d7280b62af3e66106859bc5c51a185a.tar.gz
abiword: update to 3.0.0 to fix build
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb120
1 files changed, 120 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
new file mode 100644
index 000000000..69d62efa1
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
@@ -0,0 +1,120 @@
1SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
7 librsvg libwmf-native gtkmathview asio gtk+"
8RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
9 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
10RCONFLICTS_${PN} = "${PN}-embedded"
11
12SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
13 file://debian_patches_boost54.patch \
14 file://autogen-common.sh \
15"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
18
19SRC_URI[md5sum] = "8d9c41cff3a8fbef8d0c835c65600e65"
20SRC_URI[sha256sum] = "d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b89081fac01"
21
22#want 3.x from 3.x.y for the installation directory
23SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
24
25inherit autotools pkgconfig
26
27PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp collab-backend-service"
28PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
29PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
30PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
31PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
32PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
33PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
34
35EXTRA_OECONF = " --disable-static \
36 --enable-plugins \
37 --enable-clipart \
38 --enable-templates \
39 --without-gnomevfs \
40 --with-gtk2 \
41 --with-libwmf-config=${STAGING_DIR} \
42"
43
44# AbiWord configure.ac does not play nicely with autoreconf
45# so use the autogen.sh script that comes with AbiWord
46do_configure() {
47 install -m 0755 ${WORKDIR}/autogen-common.sh ${S}/autogen-common.sh
48 cd ${S}
49 ./autogen-common.sh
50 autotools_do_configure
51}
52
53PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
54
55FILES_${PN} += " \
56 ${libdir}/lib${PN}-*.so \
57 ${datadir}/mime-info \
58 ${datadir}/icons/* \
59 ${datadir}/${PN}-${SHRT_VER}/glade \
60 ${datadir}/${PN}-${SHRT_VER}/scripts \
61 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
62 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
63 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
64 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
65 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
66 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
67 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
68 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
69 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
70 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
71 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
72 ${datadir}/${PN}-${SHRT_VER}/certs \
73 ${datadir}/${PN}-${SHRT_VER}/ui \
74 ${datadir}/${PN}-${SHRT_VER}/xsl* \
75 ${datadir}/${PN}-${SHRT_VER}/mime-info \
76 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
77"
78
79# don't steal /usr/lib/libabiword-3.0.so from ${PN}
80# in this case it's needed in ${PN}
81FILES_${PN}-dev = " \
82 ${includedir} \
83 ${libdir}/pkgconfig \
84 ${libdir}/${PN}*.la \
85 ${libdir}/lib${PN}*.la \
86 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
87"
88FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
89FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
90
91FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
92FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
93FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
94FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
95FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
96FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
97
98PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
99
100python populate_packages_prepend () {
101 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
102 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
103
104 metapkg = "abiword-meta"
105 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
106 d.setVar('FILES_' + metapkg, "")
107 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
108 metapkg_rdepends = []
109 packages = d.getVar('PACKAGES', 1).split()
110 for pkg in packages[1:]:
111 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
112 print "Modifying ", pkg
113 metapkg_rdepends.append(pkg)
114 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
115 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
116 packages.append(metapkg)
117 d.setVar('PACKAGES', ' '.join(packages))
118}
119
120FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"