summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-24 01:13:50 +0100
committerArmin Kuster <akuster808@gmail.com>2018-04-08 17:00:06 -0700
commitbf8ef0ac4a0edb84ad911020551c6b937aa1f3df (patch)
tree6cfda35211e3bc14a52b54b9d1b5664ebea654cd /meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
parenta20dd08a256af4de624845e9048137750598395d (diff)
downloadmeta-openembedded-bf8ef0ac4a0edb84ad911020551c6b937aa1f3df.tar.gz
gparted: update 0.30.0 -> 0.31.0
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb')
-rw-r--r--meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb b/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
new file mode 100644
index 000000000..58beaf6c5
--- /dev/null
+++ b/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A partition editor to graphically manage disk partitions "
2HOMEPAGE = "http://gparted.org/index.php"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5
6inherit distro_features_check autotools pkgconfig gtk-icon-cache
7
8REQUIRED_DISTRO_FEATURES = "x11"
9
10SRC_URI = " \
11 ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
12 file://org.yoctoproject.pkexec.run-gparted.policy \
13 file://gparted_polkit \
14"
15SRC_URI[md5sum] = "c554cc5734c50459dd551bd3fa10710e"
16SRC_URI[sha256sum] = "3b7b49a434d9e4b397bc41a1f5acab8539b9ff402b472dfd83ad77b2decd07ba"
17
18DEPENDS = "glib-2.0 glib-2.0-native gtkmm parted gnome-doc-utils intltool-native"
19
20do_install_append() {
21 # Add a script which checks if polkit is installed.
22 # If yes: a policy is requested from polkit / otherwise start as usual
23 install ${WORKDIR}/gparted_polkit ${D}${sbindir}
24 sed -i 's:%sbindir%:${sbindir}:g' ${D}${sbindir}/gparted_polkit
25 # relink menu entry to use our script
26 sed -i 's:${sbindir}/gparted:${sbindir}/gparted_polkit:g' ${D}${datadir}/applications/gparted.desktop
27
28 install -d ${D}${datadir}/polkit-1/actions
29 install ${WORKDIR}/org.yoctoproject.pkexec.run-gparted.policy ${D}${datadir}/polkit-1/actions/org.yoctoproject.pkexec.run-gparted.policy
30}
31
32EXTRA_OECONF = "--disable-scrollkeeper --disable-doc"
33
34FILES_${PN} += " \
35 ${datadir}/appdata \
36 ${datadir}/icons \
37 ${datadir}/polkit-1 \
38"
39
40RDEPENDS_${PN} = "dosfstools mtools e2fsprogs"