summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-apps
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-gnome/recipes-apps
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-gnome/recipes-apps')
-rw-r--r--meta-gnome/recipes-apps/cheese/cheese_2.30.1.bb21
-rw-r--r--meta-gnome/recipes-apps/gnome-mplayer/gmtk_1.0.5.bb16
-rw-r--r--meta-gnome/recipes-apps/gnome-mplayer/gnome-mplayer_1.0.5.bb32
-rw-r--r--meta-gnome/recipes-apps/nonworking/epdfview/epdfview/browser_command.patch17
-rw-r--r--meta-gnome/recipes-apps/nonworking/epdfview/epdfview/fix-format.patch19
-rw-r--r--meta-gnome/recipes-apps/nonworking/epdfview/epdfview/glib-single-include.patch17
-rw-r--r--meta-gnome/recipes-apps/nonworking/epdfview/epdfview/swap-colors.patch43
-rw-r--r--meta-gnome/recipes-apps/nonworking/epdfview/epdfview_0.1.8.bb21
-rw-r--r--meta-gnome/recipes-apps/pinpoint/pinpoint_git.bb21
9 files changed, 207 insertions, 0 deletions
diff --git a/meta-gnome/recipes-apps/cheese/cheese_2.30.1.bb b/meta-gnome/recipes-apps/cheese/cheese_2.30.1.bb
new file mode 100644
index 000000000..a54a3a220
--- /dev/null
+++ b/meta-gnome/recipes-apps/cheese/cheese_2.30.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Take photos and videos with your webcam, with fun graphical effects"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
4
5DEPENDS = "gtk+ gstreamer gst-plugins-base libcanberra udev librsvg gnome-desktop evolution-data-server intltool-native"
6
7PR = "r2"
8
9inherit gnome
10
11SRC_URI[archive.md5sum] = "1599fded8a1797ea51fb010af4e6c45b"
12SRC_URI[archive.sha256sum] = "48f03470c6f527caa0e3b269d3afcff86ae0939a74f66ce030d4eed3bc3cbd9a"
13
14FILES_${PN} += "${datadir}/dbus-1"
15RRECOMMENDS_${PN} = "gst-plugins-good-meta gst-plugins-base-meta"
16
17EXTRA_OECONF += "--disable-scrollkeeper"
18
19do_configure_prepend() {
20 sed -i -e "s: help : :g" ${S}/Makefile.am
21}
diff --git a/meta-gnome/recipes-apps/gnome-mplayer/gmtk_1.0.5.bb b/meta-gnome/recipes-apps/gnome-mplayer/gmtk_1.0.5.bb
new file mode 100644
index 000000000..d455f1447
--- /dev/null
+++ b/meta-gnome/recipes-apps/gnome-mplayer/gmtk_1.0.5.bb
@@ -0,0 +1,16 @@
1SUMMARY = "GTK+ widget and function libraries for gnome-mplayer"
2HOMEPAGE = "http://code.google.com/p/gmtk"
3SECTION = "libs"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8DEPENDS = "gtk+ alsa-lib glib-2.0 virtual/libx11 intltool-native pulseaudio gtk+3"
9
10SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz"
11SRC_URI[md5sum] = "e06e9ca8d61d74910343bb3ef4348f7f"
12SRC_URI[sha256sum] = "a07130d62719e8c1244f8405dd97445798df5204fc0f3f2f2b669b125114b468"
13
14EXTRA_OECONF = "--disable-gconf --with-gio --with-alsa --enable-keystore"
15
16inherit gettext pkgconfig autotools gconf
diff --git a/meta-gnome/recipes-apps/gnome-mplayer/gnome-mplayer_1.0.5.bb b/meta-gnome/recipes-apps/gnome-mplayer/gnome-mplayer_1.0.5.bb
new file mode 100644
index 000000000..ef460f13d
--- /dev/null
+++ b/meta-gnome/recipes-apps/gnome-mplayer/gnome-mplayer_1.0.5.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A GTK+ interface to MPlayer"
2HOMEPAGE = "http://code.google.com/p/gnome-mplayer"
3SECTION = "multimedia"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8PNBLACKLIST[gnome-mplayer] ?= "rdepends on blacklisted mplayer"
9PR = "r2"
10
11DEPENDS = "gmtk gtk+ alsa-lib libnotify glib-2.0 dbus-glib virtual/libx11 libxscrnsaver"
12
13SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz"
14SRC_URI[md5sum] = "1d3ab24c5501b5528e357931ca4dc6da"
15SRC_URI[sha256sum] = "ac3c179345baecb4ca5237782aa33e83253a87bf8b42ce6eb3a9207a340f61b2"
16
17EXTRA_OECONF = "--with-gio --with-alsa --with-dbus --with-libnotify"
18
19FILES_${PN} += "${datadir}/gnome-control-center/default-apps/${PN}.xml"
20PACKAGES =+ "${PN}-nautilus-extension"
21FILES_${PN}-nautilus-extension += "${libdir}/nautilus/extensions-2.0/*.so \
22 ${libdir}/nautilus/extensions-3.0/*.so"
23FILES_${PN}-dev += "${libdir}/nautilus/extensions-2.0/*.la \
24 ${libdir}/nautilus/extensions-3.0/*.la"
25FILES_${PN}-staticdev += "${libdir}/nautilus/extensions-2.0/*.a \
26 ${libdir}/nautilus/extensions-3.0/*.a"
27FILES_${PN}-dbg += "${libdir}/nautilus/extensions-2.0/.debug \
28 ${libdir}/nautilus/extensions-3.0/.debug"
29
30inherit gettext pkgconfig mime gtk-icon-cache autotools
31
32RDEPENDS_${PN} = "mplayer"
diff --git a/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/browser_command.patch b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/browser_command.patch
new file mode 100644
index 000000000..75e45e0ab
--- /dev/null
+++ b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/browser_command.patch
@@ -0,0 +1,17 @@
1Imported from Debian 0.1.8-3
2
3Upstream-Status: Pending
4
5diff --git a/src/Config.cxx b/src/Config.cxx
6index 28f37ab..bc58819 100644
7--- a/src/Config.cxx
8+++ b/src/Config.cxx
9@@ -22,7 +22,7 @@
10 using namespace ePDFView;
11
12 // Constants
13-static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "firefox %s";
14+static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "x-www-browser %s";
15 static const gchar *DEFAULT_OPEN_FILE_FOLDER = NULL;
16 static const gchar *DEFAULT_SAVE_FILE_FOLDER = NULL;
17 static const gboolean DEFAULT_SHOW_STATUSBAR = TRUE;
diff --git a/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/fix-format.patch b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/fix-format.patch
new file mode 100644
index 000000000..8ad5b97ca
--- /dev/null
+++ b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/fix-format.patch
@@ -0,0 +1,19 @@
1Imported from Debian 0.1.8-3
2
3Upstream-Status: Pending
4
5diff --git a/src/gtk/MainView.cxx b/src/gtk/MainView.cxx
6index b983bff..f87de28 100644
7--- a/src/gtk/MainView.cxx
8+++ b/src/gtk/MainView.cxx
9@@ -634,8 +634,9 @@ MainView::showErrorMessage (const gchar *title, const gchar *body)
10 GTK_DIALOG_DESTROY_WITH_PARENT,
11 GTK_MESSAGE_ERROR,
12 GTK_BUTTONS_OK,
13+ "%s",
14 title);
15- gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog),
16+ gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), "%s",
17 body);
18 gtk_dialog_run (GTK_DIALOG (errorDialog));
19 gtk_widget_destroy (errorDialog);
diff --git a/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/glib-single-include.patch b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/glib-single-include.patch
new file mode 100644
index 000000000..84a491386
--- /dev/null
+++ b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/glib-single-include.patch
@@ -0,0 +1,17 @@
1Imported from Debian 0.1.8-3
2
3Upstream-Status: Pending
4
5diff --git a/src/gtk/StockIcons.h b/src/gtk/StockIcons.h
6index c142a7a..58fcf2e 100644
7--- a/src/gtk/StockIcons.h
8+++ b/src/gtk/StockIcons.h
9@@ -18,7 +18,7 @@
10 #if !defined (__STOCK_ICONS_H__)
11 #define __STOCK_ICONS_H__
12
13-#include <glib/gmacros.h>
14+#include <glib.h>
15
16 G_BEGIN_DECLS
17
diff --git a/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/swap-colors.patch b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/swap-colors.patch
new file mode 100644
index 000000000..282bfb184
--- /dev/null
+++ b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview/swap-colors.patch
@@ -0,0 +1,43 @@
1Imported from Debian 0.1.8-3
2
3Upstream-Status: Pending
4
5Index: trunk/src/PDFDocument.cxx
6===================================================================
7--- trunk/src/PDFDocument.cxx (revision 361)
8+++ trunk/src/PDFDocument.cxx (revision 367)
9@@ -21,4 +21,5 @@
10 #include <poppler.h>
11 #include <unistd.h>
12+#include <algorithm>
13 #include "epdfview.h"
14
15@@ -33,4 +34,22 @@
16 static PageMode convertPageMode (gint pageMode);
17 static gchar *getAbsoluteFileName (const gchar *fileName);
18+
19+namespace
20+{
21+ void
22+ convert_bgra_to_rgba (guint8 *data, int width, int height)
23+ {
24+ using std::swap;
25+
26+ for (int y = 0; y < height; y++)
27+ {
28+ for (int x = 0; x < width; x++)
29+ {
30+ swap(data[0], data[2]);
31+ data += 4;
32+ }
33+ }
34+ }
35+}
36
37 ///
38@@ -651,4 +670,5 @@
39 cairo_destroy(context);
40 cairo_surface_destroy (surface);
41+ convert_bgra_to_rgba(renderedPage->getData (), width, height);
42 #else // !HAVE_POPPLER_0_17_0
43 // Create the pixbuf from the data and render to it.
diff --git a/meta-gnome/recipes-apps/nonworking/epdfview/epdfview_0.1.8.bb b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview_0.1.8.bb
new file mode 100644
index 000000000..9167cd3d7
--- /dev/null
+++ b/meta-gnome/recipes-apps/nonworking/epdfview/epdfview_0.1.8.bb
@@ -0,0 +1,21 @@
1SUMMARY = "A lightweight PDF viewer based on gtk and poppler"
2HOMEPAGE = "http://www.emma-soft.com/projects/epdfview/"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "x11/applications"
6DEPENDS = "gtk+ poppler"
7
8PR = "r3"
9
10EXTRA_OECONF += "--without-cups"
11
12inherit autotools gettext
13
14SRC_URI = "http://www.emma-soft.com/projects/${BPN}/chrome/site/releases/${BP}.tar.bz2 \
15 file://browser_command.patch \
16 file://fix-format.patch \
17 file://glib-single-include.patch \
18 file://swap-colors.patch \
19"
20SRC_URI[md5sum] = "e50285b01612169b2594fea375f53ae4"
21SRC_URI[sha256sum] = "948648ae7c9d7b3b408d738bd4f48d87375b1196cae1129d6b846a8de0f2f8f0"
diff --git a/meta-gnome/recipes-apps/pinpoint/pinpoint_git.bb b/meta-gnome/recipes-apps/pinpoint/pinpoint_git.bb
new file mode 100644
index 000000000..2b85ff436
--- /dev/null
+++ b/meta-gnome/recipes-apps/pinpoint/pinpoint_git.bb
@@ -0,0 +1,21 @@
1SUMMARY = "A simple presentation tool for hackers"
2DESCRIPTION = "Pinpoint is a simple presentation tool that hopes to avoid audience death \
3 by bullet point and instead encourage presentations containing beautiful \
4 images and small amounts of concise text in slides."
5SECTION = "x11/multimedia"
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24 \
8 file://pinpoint.c;beginline=6;endline=17;md5=201d438283607da393fae6aca085454c"
9
10DEPENDS = "gnome-common glib-2.0 gdk-pixbuf cogl-1.0 clutter-1.0 clutter-gst-1.0"
11
12inherit autotools gettext pkgconfig
13
14SRC_URI = "git://git.gnome.org/pinpoint"
15
16SRCREV = "80a056c57e819d0b75035424638813b0670830e1"
17PV = "0.1.4+gitr${SRCPV}"
18
19S = "${WORKDIR}/git"
20
21RRECOMMENDS_${PN} = "gdk-pixbuf-loader-jpeg gdk-pixbuf-loader-png"