summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-22 12:55:01 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-22 12:59:38 -0800
commitdaa0049d23906a87c9f6f57f2092153f6471480d (patch)
tree3623f0b41e9f8a6466ca1925fe01c40eb711ac2e /meta-filesystems
parentc2056112d462f1b3a9db4a5e66022621fa3965b1 (diff)
downloadmeta-openembedded-daa0049d23906a87c9f6f57f2092153f6471480d.tar.gz
sshfs-fuse: Fix ptest builds with python 3.12
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch34
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/a1d58ae1be99571a88b8439b027abe6349b74658.patch31
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb6
3 files changed, 70 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch
new file mode 100644
index 000000000..63cdc57b4
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch
@@ -0,0 +1,34 @@
1From 03ee1f8aa0899268ec02b2f54849352df92a3a1d Mon Sep 17 00:00:00 2001
2From: Gabriel Staples <ercaguy@gmail.com>
3Date: Tue, 22 Dec 2020 23:33:55 -0800
4Subject: [PATCH] pytest.ini: fix test warning
5
6Warning:
7
8```
9test/util.py:99
10 sshfs/build/test/util.py:99: PytestUnknownMarkWarning: Unknown pytest.mark.uses_fuse - is this a typo?
11 You can register custom marks to avoid this warning - for details, see https://docs.pytest.org/en/stable/mark.html
12 return pytest.mark.uses_fuse()
13```
14
15References for the fix:
16
171. https://stackoverflow.com/questions/60806473/pytestunknownmarkwarning-unknown-pytest-mark-xxx-is-this-a-typo/60813297#60813297
181. https://docs.pytest.org/en/stable/mark.html
19
20Upstream-Status: Submitted [https://github.com/libfuse/sshfs/pull/238]
21Signed-off-by: Khem Raj <raj.khem@gmail.com>
22---
23 test/pytest.ini | 2 ++
24 1 file changed, 2 insertions(+)
25
26diff --git a/test/pytest.ini b/test/pytest.ini
27index 95161546..7a7efed4 100644
28--- a/test/pytest.ini
29+++ b/test/pytest.ini
30@@ -1,2 +1,4 @@
31 [pytest]
32 addopts = --verbose --assert=rewrite --tb=native -x -r a
33+markers =
34+ uses_fuse
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/a1d58ae1be99571a88b8439b027abe6349b74658.patch b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/a1d58ae1be99571a88b8439b027abe6349b74658.patch
new file mode 100644
index 000000000..e76dbd505
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse/a1d58ae1be99571a88b8439b027abe6349b74658.patch
@@ -0,0 +1,31 @@
1From a1d58ae1be99571a88b8439b027abe6349b74658 Mon Sep 17 00:00:00 2001
2From: Gabriel Staples <ercaguy@gmail.com>
3Date: Tue, 22 Dec 2020 23:26:40 -0800
4Subject: [PATCH] Fix deprecated warning in conftest.py
5
6```
7test/conftest.py:66
8 sshfs/build/test/conftest.py:66: PytestDeprecationWarning: @pytest.yield_fixture is deprecated.
9 Use @pytest.fixture instead; they are the same.
10 @pytest.yield_fixture(autouse=True)
11```
12
13Upstream-Status: Submitted [https://github.com/libfuse/sshfs/pull/238]
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 test/conftest.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/test/conftest.py b/test/conftest.py
20index 70cd0c62..d58d45b2 100644
21--- a/test/conftest.py
22+++ b/test/conftest.py
23@@ -63,7 +63,7 @@ def register_output(self, pattern, count=1, flags=re.MULTILINE):
24 # relies on tests running sequential (i.e., don't dare to use e.g. the xdist
25 # plugin)
26 current_capfd = None
27-@pytest.yield_fixture(autouse=True)
28+@pytest.fixture(autouse=True)
29 def save_cap_fixtures(request, capfd):
30 global current_capfd
31 capfd.false_positives = []
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
index c85483759..5a926dac0 100644
--- a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
@@ -5,7 +5,10 @@ LICENSE = "GPL-2.0-only"
5DEPENDS = "glib-2.0 fuse3" 5DEPENDS = "glib-2.0 fuse3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7 7
8SRC_URI = "git://github.com/libfuse/sshfs;branch=master;protocol=https" 8SRC_URI = "git://github.com/libfuse/sshfs;branch=master;protocol=https \
9 file://03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch \
10 file://a1d58ae1be99571a88b8439b027abe6349b74658.patch \
11"
9SRCREV = "c91eb9a9a992f1a36c49a8e6f1146e45b5e1c8e7" 12SRCREV = "c91eb9a9a992f1a36c49a8e6f1146e45b5e1c8e7"
10S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
11 14
@@ -18,6 +21,7 @@ SRC_URI += " \
18RDEPENDS:${PN}-ptest += " \ 21RDEPENDS:${PN}-ptest += " \
19 python3-pytest \ 22 python3-pytest \
20 bash \ 23 bash \
24 fuse \
21" 25"
22 26
23do_install_ptest() { 27do_install_ptest() {