summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-05 08:33:41 -0800
committerKhem Raj <raj.khem@gmail.com>2023-11-06 08:49:52 -0800
commitad8a6570cafd512434af497f31f5d524af703622 (patch)
tree3aedf0f3670f3f9b21694a88b7efc939258c01cb /meta-filesystems
parent10e38d8f0057a305342709c95e613ed93dbe2955 (diff)
downloadmeta-openembedded-ad8a6570cafd512434af497f31f5d524af703622.tar.gz
xfstests: Fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests/0001-add-missing-FTW_-macros-when-not-available-in-libc.patch41
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2023.10.29.bb1
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests/0001-add-missing-FTW_-macros-when-not-available-in-libc.patch b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-add-missing-FTW_-macros-when-not-available-in-libc.patch
new file mode 100644
index 000000000..5e230e2cf
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-add-missing-FTW_-macros-when-not-available-in-libc.patch
@@ -0,0 +1,41 @@
1From 5facddc332c5ff8330f93c0a7e1b7f6d7bbd24a3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 5 Nov 2023 08:31:21 -0800
4Subject: [PATCH] add missing FTW_ macros when not available in libc
5
6Fixes build with musl
7
8| xfsfind.c:176:13: error: use of undeclared identifier 'FTW_STOP'
9| 176 | retval = FTW_STOP;
10| | ^
11
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/global.h | 12 ++++++++++++
16 1 file changed, 12 insertions(+)
17
18diff --git a/src/global.h b/src/global.h
19index 49570ef1..1c247488 100644
20--- a/src/global.h
21+++ b/src/global.h
22@@ -190,4 +190,16 @@ roundup_64(unsigned long long x, unsigned int y)
23 return rounddown_64(x + y - 1, y);
24 }
25
26+#ifndef FTW_ACTIONRETVAL
27+#define FTW_ACTIONRETVAL 16
28+#endif
29+
30+#ifndef FTW_CONTINUE
31+#define FTW_CONTINUE 0
32+#endif
33+
34+#ifndef FTW_STOP
35+#define FTW_STOP 1
36+#endif
37+
38 #endif /* GLOBAL_H */
39--
402.42.1
41
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.10.29.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.10.29.bb
index b8880e016..4e8e31840 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.10.29.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.10.29.bb
@@ -9,6 +9,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=for-next;
9 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ 9 git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
10 file://0001-ltp-fsx.h-Explicitly-use-int-for-return-type-for-aio.patch \ 10 file://0001-ltp-fsx.h-Explicitly-use-int-for-return-type-for-aio.patch \
11 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ 11 file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
12 file://0001-add-missing-FTW_-macros-when-not-available-in-libc.patch \
12 " 13 "
13 14
14SRCREV_xfstests = "f7765774a1b5cb98c2f21a892e82b3421f40e791" 15SRCREV_xfstests = "f7765774a1b5cb98c2f21a892e82b3421f40e791"