summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-05-10 07:47:08 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:27:51 -0700
commit7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62 (patch)
treef873f01541bce368873f89e89d6ae833692638b2 /meta-filesystems
parentc16704f6a38dabfccc7a0651fa9ba4c67b6f510a (diff)
downloadmeta-openembedded-7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62.tar.gz
fuse3: move from meta-filesystems to meta-oe
Technically flatpak and xdg-desktop-portal have a runtime dependency on fuse3-utils. I was worried that adding it might cause problems with CI since fuse3 is not included in meta-oe. Given that both packages also require fuse3 at buildtime it could be a good idea to move fuse3 to avoid a meta-filesystems dependency for meta-oe Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3/run-ptest3
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb84
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3/run-ptest b/meta-filesystems/recipes-support/fuse/fuse3/run-ptest
deleted file mode 100644
index b63c4de0d..000000000
--- a/meta-filesystems/recipes-support/fuse/fuse3/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
deleted file mode 100644
index 2b0797a6f..000000000
--- a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
+++ /dev/null
@@ -1,84 +0,0 @@
1SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = " \
11 file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
13 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66 \
14"
15
16SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz \
17"
18SRC_URI[sha256sum] = "f797055d9296b275e981f5f62d4e32e089614fc253d1ef2985851025b8a0ce87"
19
20S = "${WORKDIR}/fuse-${PV}"
21
22UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
23UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
24
25CVE_PRODUCT = "fuse_project:fuse"
26
27inherit meson pkgconfig ptest
28
29SRC_URI += " \
30 file://run-ptest \
31"
32
33RDEPENDS:${PN}-ptest += " \
34 python3-pytest \
35 python3-looseversion \
36 bash \
37"
38RRECOMMENDS:${PN}-ptest += " kernel-module-cuse"
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 install -d ${D}${PTEST_PATH}/example
43 install -d ${D}${PTEST_PATH}/util
44 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
45
46 example_excutables=`find ${B}/example -type f -executable`
47 util_excutables=`find ${B}/util -type f -executable`
48 test_excutables=`find ${B}/test -type f -executable`
49
50 for e in $example_excutables
51 do
52 cp -rf $e ${D}${PTEST_PATH}/example/
53 done
54
55 for e in $util_excutables
56 do
57 cp -rf $e ${D}${PTEST_PATH}/util/
58 done
59
60 for e in $test_excutables
61 do
62 cp -rf $e ${D}${PTEST_PATH}/test
63 done
64}
65
66DEPENDS = "udev"
67
68PACKAGES =+ "fuse3-utils"
69
70RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
71
72RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
73
74FILES:${PN} += "${libdir}/libfuse3.so.*"
75FILES:${PN}-dev += "${libdir}/libfuse3*.la"
76
77# Forbid auto-renaming to libfuse3-utils
78FILES:fuse3-utils = "${bindir} ${base_sbindir}"
79DEBIAN_NOAUTONAME:fuse3-utils = "1"
80DEBIAN_NOAUTONAME:${PN}-dbg = "1"
81
82do_install:append() {
83 rm -rf ${D}${base_prefix}/dev
84}