summaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2024-03-01 16:35:57 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-01 16:37:56 -0800
commit63266a461f4ad21472fa66fbeb6ccdda2e8ad265 (patch)
tree7d5bd56bd795c325cdbf7d1882b60170ded44cd2 /meta-filesystems
parent4992816e4fee10d6f3d6836b1b8a277f0782fa39 (diff)
downloadmeta-openembedded-63266a461f4ad21472fa66fbeb6ccdda2e8ad265.tar.gz
fuse3: use 4 spaces for indentation
* instead of mix of 8, 9 and 4 spaces Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb56
1 files changed, 29 insertions, 27 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
index 321851da5..7964621b5 100644
--- a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
@@ -7,9 +7,11 @@ DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspac
7HOMEPAGE = "https://github.com/libfuse/libfuse" 7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs" 8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only" 9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 10LIC_FILES_CHKSUM = " \
11 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \ 11 file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66" 12 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
13 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66 \
14"
13 15
14SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz \ 16SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz \
15" 17"
@@ -25,7 +27,7 @@ CVE_PRODUCT = "fuse_project:fuse"
25inherit meson pkgconfig ptest 27inherit meson pkgconfig ptest
26 28
27SRC_URI += " \ 29SRC_URI += " \
28 file://run-ptest \ 30 file://run-ptest \
29" 31"
30 32
31RDEPENDS:${PN}-ptest += " \ 33RDEPENDS:${PN}-ptest += " \
@@ -36,29 +38,29 @@ RDEPENDS:${PN}-ptest += " \
36" 38"
37 39
38do_install_ptest() { 40do_install_ptest() {
39 install -d ${D}${PTEST_PATH}/test 41 install -d ${D}${PTEST_PATH}/test
40 install -d ${D}${PTEST_PATH}/example 42 install -d ${D}${PTEST_PATH}/example
41 install -d ${D}${PTEST_PATH}/util 43 install -d ${D}${PTEST_PATH}/util
42 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ 44 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
43 45
44 example_excutables=`find ${B}/example -type f -executable` 46 example_excutables=`find ${B}/example -type f -executable`
45 util_excutables=`find ${B}/util -type f -executable` 47 util_excutables=`find ${B}/util -type f -executable`
46 test_excutables=`find ${B}/test -type f -executable` 48 test_excutables=`find ${B}/test -type f -executable`
47 49
48 for e in $example_excutables 50 for e in $example_excutables
49 do 51 do
50 cp -rf $e ${D}${PTEST_PATH}/example/ 52 cp -rf $e ${D}${PTEST_PATH}/example/
51 done 53 done
52 54
53 for e in $util_excutables 55 for e in $util_excutables
54 do 56 do
55 cp -rf $e ${D}${PTEST_PATH}/util/ 57 cp -rf $e ${D}${PTEST_PATH}/util/
56 done 58 done
57 59
58 for e in $test_excutables 60 for e in $test_excutables
59 do 61 do
60 cp -rf $e ${D}${PTEST_PATH}/test 62 cp -rf $e ${D}${PTEST_PATH}/test
61 done 63 done
62} 64}
63 65
64DEPENDS = "udev" 66DEPENDS = "udev"