summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-08-15 11:20:42 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-14 22:33:09 -0700
commita6eeacedd0f6444eef4efae3189f0a472fb9274d (patch)
treeadf5f7f87ea740882010457991ca68beed5c5a72 /meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
parentc95842cdca36bc2a7f62e5e995dfd1ca44e37e52 (diff)
downloadmeta-openembedded-a6eeacedd0f6444eef4efae3189f0a472fb9274d.tar.gz
xfsprogs: upgrade 5.1.0 -> 5.2.0
Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
new file mode 100644
index 000000000..10d1b70d5
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.0.bb
@@ -0,0 +1,73 @@
1SUMMARY = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv2.1"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038 \
7 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
8DEPENDS = "util-linux util-linux-native"
9SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
10 file://remove_flags_from_build_flags.patch \
11 file://0001-build-Check-for-sync_file_range-libc-function.patch \
12 file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \
13 file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \
14 "
15SRC_URI[md5sum] = "e38032818aa3b1ef224a69b6184fc12a"
16SRC_URI[sha256sum] = "e41cdaa43d92b38c8a12ce9cb612ab911ba0e019c2e0762c494a8a601f533fd6"
17
18inherit autotools-brokensep
19
20PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle"
21
22DEPENDS += "util-linux"
23
24RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair"
25
26FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
27FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
28FILES_${PN}-repair = "${base_sbindir}/xfs_repair"
29
30FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
31
32EXTRA_OECONF = "--enable-gettext=no \
33 --enable-scrub=no \
34 INSTALL_USER=root \
35 INSTALL_GROUP=root \
36 ac_cv_header_aio_h=yes \
37 ac_cv_lib_rt_lio_listio=yes \
38"
39
40DISABLE_STATIC = ""
41EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader"
42
43PACKAGECONFIG ??= "readline blkid"
44
45PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
46PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
47
48export DEBUG="-DNDEBUG"
49export BUILD_VERBOSE="1"
50export tagname="CC"
51
52EXTRA_OEMAKE = "DIST_ROOT='${D}'"
53
54do_configure () {
55 export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}"
56 # Prevent Makefile from calling configure without arguments,
57 # when do_configure gets called for a second time.
58 rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure
59 # Recreate configure script.
60 oe_runmake configure
61 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
62 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
63 oe_runconf
64}
65
66do_install_append() {
67 oe_runmake 'DESTDIR=${D}' install-dev
68 rm ${D}${libdir}/*.la
69 rmdir --ignore-fail-on-non-empty ${D}${libdir}
70
71 ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a
72 ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so
73}