summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2015-07-29 10:46:59 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-18 11:38:02 +0200
commit8979be15071a7c6f53371d0cbe209362c9620a45 (patch)
tree339aa343efb0f35647ba2bc81de3929eccc34d68 /meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
parent175fb665516874a0b196efd9a77795ee70083c68 (diff)
downloadmeta-openembedded-8979be15071a7c6f53371d0cbe209362c9620a45.tar.gz
xfsprogs: Uprev to 3.2.3 version
In the v3.2.3, the libhandle.so/libhandle.a paths have changed so that We need not rm them in the install processing. Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
new file mode 100644
index 000000000..8df7bc12e
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
@@ -0,0 +1,52 @@
1SUMMARY = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
7DEPENDS = "util-linux"
8
9SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${BP}.tar.gz \
10 file://xfsprogs-generate-crctable-which-is-moved-into-runti.patch \
11 file://remove-install-as-user.patch \
12 file://drop-configure-check-for-aio.patch \
13"
14
15SRC_URI[md5sum] = "9f383e36682709e62b12c125e5d8b895"
16SRC_URI[sha256sum] = "7a5124a880997939551b519610a2e54bd4cd0b0adfd563ce3f4de30827109ac9"
17
18inherit autotools-brokensep
19
20PACKAGES =+ "${PN}-fsck ${PN}-mkfs libhandle"
21
22RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs"
23
24FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
25FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
26FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
27
28EXTRA_OECONF = "--enable-gettext=no"
29do_configure () {
30 # Prevent Makefile from calling configure without arguments,
31 # when do_configure gets called for a second time.
32 rm -f include/builddefs include/platform_defs.h
33 # Recreate configure script.
34 rm -f configure
35 oe_runmake configure
36 # Configure.
37 export DEBUG="-DNDEBUG"
38 gnu-configize --force
39 oe_runconf
40}
41
42LIBTOOL = "${HOST_SYS}-libtool"
43EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
44TARGET_CC_ARCH += "${LDFLAGS}"
45PARALLEL_MAKE = ""
46
47do_install () {
48 export DIST_ROOT=${D}
49 oe_runmake install
50 # needed for xfsdump
51 oe_runmake install-dev
52}