summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-05-16 06:34:54 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-15 22:51:10 -0700
commitf6664bbc45a0c627f32fa35c2dfa94a20284ccfc (patch)
tree9812ef7b37c9664fb2fbb2162cc77a598194e0f6 /meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb
parentd477cbb5267f39846d129f27d0f6a7f2b001db7b (diff)
downloadmeta-openembedded-f6664bbc45a0c627f32fa35c2dfa94a20284ccfc.tar.gz
fuse3: update 3.12.0 -> 3.14.1
Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb
new file mode 100644
index 000000000..c8a820a09
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/fuse3_3.14.1.bb
@@ -0,0 +1,80 @@
1SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = "file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
12 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66"
13
14SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.xz \
15"
16SRC_URI[sha256sum] = "126919d72b46b3e0eb58a9c6933a2a50c36f2ea69f61fe9e78bdba9f463ffa20"
17
18S = "${WORKDIR}/fuse-${PV}"
19
20UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
21UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
22
23CVE_PRODUCT = "fuse_project:fuse"
24
25inherit meson pkgconfig ptest
26
27SRC_URI += " \
28 file://run-ptest \
29"
30
31RDEPENDS:${PN}-ptest += " \
32 ${PYTHON_PN}-pytest \
33 bash \
34"
35
36do_install_ptest() {
37 install -d ${D}${PTEST_PATH}/test
38 install -d ${D}${PTEST_PATH}/example
39 install -d ${D}${PTEST_PATH}/util
40 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
41
42 example_excutables=`find ${B}/example -type f -executable`
43 util_excutables=`find ${B}/util -type f -executable`
44 test_excutables=`find ${B}/test -type f -executable`
45
46 for e in $example_excutables
47 do
48 cp -rf $e ${D}${PTEST_PATH}/example/
49 done
50
51 for e in $util_excutables
52 do
53 cp -rf $e ${D}${PTEST_PATH}/util/
54 done
55
56 for e in $test_excutables
57 do
58 cp -rf $e ${D}${PTEST_PATH}/test
59 done
60}
61
62DEPENDS = "udev"
63
64PACKAGES =+ "fuse3-utils"
65
66RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
67
68RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
69
70FILES:${PN} += "${libdir}/libfuse3.so.*"
71FILES:${PN}-dev += "${libdir}/libfuse3*.la"
72
73# Forbid auto-renaming to libfuse3-utils
74FILES:fuse3-utils = "${bindir} ${base_sbindir}"
75DEBIAN_NOAUTONAME:fuse3-utils = "1"
76DEBIAN_NOAUTONAME:${PN}-dbg = "1"
77
78do_install:append() {
79 rm -rf ${D}${base_prefix}/dev
80}