summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems
diff options
context:
space:
mode:
authorLei YU <yulei.sh@bytedance.com>2020-06-08 07:44:25 +0000
committerKhem Raj <raj.khem@gmail.com>2020-06-08 22:00:37 -0700
commit3eb4c089a81de407eb80397abfba3f8856a2475d (patch)
tree887499a36898a19db6075ed00c98c2b2819bae6f /meta-filesystems/recipes-filesystems
parent8bec347159e6ad3bb8b376ccaff8df5b5591e228 (diff)
downloadmeta-openembedded-3eb4c089a81de407eb80397abfba3f8856a2475d.tar.gz
httpfs2: mount a http url as a file based on FUSE
Signed-off-by: Lei YU <yulei.sh@bytedance.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
new file mode 100644
index 000000000..2fa5ec1fb
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
@@ -0,0 +1,25 @@
1SUMMARY = "This is a filesystem client based on the HTTP using FUSE"
2HOMEPAGE = "http://httpfs.sourceforge.net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7"
5
6inherit pkgconfig
7
8DEPENDS += "fuse"
9RDEPENDS_${PN} += "fuse"
10
11SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
12SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
13
14S = "${WORKDIR}/httpfs2-${PV}"
15
16do_compile() {
17 cd ${S}
18 oe_runmake httpfs2
19}
20
21do_install() {
22 cd ${S}
23 install -d ${D}${bindir}
24 install -m 0755 httpfs2 ${D}${bindir}
25}