diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-20 11:31:41 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-02-23 23:21:14 +0100 |
commit | 29a37034c1205cd468815be33c69dcb560e77b67 (patch) | |
tree | a442a28a5e6a311ea76bd137e63fe332dd18808b /meta-efl | |
parent | 6153ff53f944a7c0b733bbeda78020227e37f721 (diff) | |
download | meta-openembedded-29a37034c1205cd468815be33c69dcb560e77b67.tar.gz |
efl: Adjust packaging to match more with old 1.7 separate recipes
* it improves upgrade-path, it's not perfect and I was testing it only on
my SHR images which include lot of efl stuff, but not all, so some packages
can still be a bit different
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r-- | meta-efl/recipes-efl/efl/efl.inc | 111 |
1 files changed, 107 insertions, 4 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc index 0d149660f7..4e25389c97 100644 --- a/meta-efl/recipes-efl/efl/efl.inc +++ b/meta-efl/recipes-efl/efl/efl.inc | |||
@@ -52,8 +52,23 @@ do_configure_prepend_class-native() { | |||
52 | sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac | 52 | sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac |
53 | } | 53 | } |
54 | 54 | ||
55 | PACKAGES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus" | 55 | PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus" |
56 | RPROVIDES_edje += "edje-utils" | 56 | |
57 | # upgrade path from 1.7 | ||
58 | DEBIAN_NOAUTONAME_ecore-audio = "1" | ||
59 | DEBIAN_NOAUTONAME_ecore-input-evas = "1" | ||
60 | DEBIAN_NOAUTONAME_ecore-input = "1" | ||
61 | DEBIAN_NOAUTONAME_ecore-imf-evas = "1" | ||
62 | DEBIAN_NOAUTONAME_ecore-imf = "1" | ||
63 | DEBIAN_NOAUTONAME_ecore-file = "1" | ||
64 | DEBIAN_NOAUTONAME_ecore-con = "1" | ||
65 | DEBIAN_NOAUTONAME_ecore-ipc = "1" | ||
66 | DEBIAN_NOAUTONAME_ecore-x = "1" | ||
67 | DEBIAN_NOAUTONAME_ecore-evas = "1" | ||
68 | DEBIAN_NOAUTONAME_embryo = "1" | ||
69 | |||
70 | ALLOW_EMPTY_ecore = "1" | ||
71 | RDEPENDS_ecore = "ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas" | ||
57 | 72 | ||
58 | python populate_packages_prepend () { | 73 | python populate_packages_prepend () { |
59 | for plugin_type in "engines loaders savers".split(): | 74 | for plugin_type in "engines loaders savers".split(): |
@@ -77,22 +92,105 @@ python populate_packages_prepend () { | |||
77 | 92 | ||
78 | PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*" | 93 | PACKAGES_DYNAMIC += "^evas-engine-.* ^evas-loader-.* ^evas-saver-.* ^evas-cserve2-.*" |
79 | 94 | ||
95 | # PACKAGES_DYNAMIC + do_split_packages isn't used for all libe libs, | ||
96 | # because PACKAGES_DYNAMIC would be catching too many patterns | ||
97 | # (or need to list all possible prefixes) and not all original packages | ||
98 | # were splitted like that, so it would need RCONFLICTS/RPROVIDES/RREPLACES | ||
99 | # combos at least in few places for upgrade path. | ||
100 | |||
101 | FILES_efreet-trash = " \ | ||
102 | ${libdir}/libefreet_trash${SOLIBS} \ | ||
103 | " | ||
104 | FILES_efreet-mime = " \ | ||
105 | ${libdir}/libefreet_mime${SOLIBS} \ | ||
106 | " | ||
107 | FILES_libeet = " \ | ||
108 | ${libdir}/libeet${SOLIBS} \ | ||
109 | " | ||
110 | FILES_libefreet = " \ | ||
111 | ${libdir}/libefreet${SOLIBS} \ | ||
112 | " | ||
113 | FILES_ecore-audio = "\ | ||
114 | ${libdir}/libecore_audio${SOLIBS} \ | ||
115 | " | ||
116 | FILES_ecore-input-evas = "\ | ||
117 | ${libdir}/libecore_input_evas${SOLIBS} \ | ||
118 | " | ||
119 | FILES_ecore-input = "\ | ||
120 | ${libdir}/libecore_input${SOLIBS} \ | ||
121 | " | ||
122 | FILES_ecore-imf-evas = "\ | ||
123 | ${libdir}/libecore_imf_evas${SOLIBS} \ | ||
124 | ${libdir}/ecore-imf/modules/*/*/module.so \ | ||
125 | " | ||
126 | FILES_ecore-imf = "\ | ||
127 | ${libdir}/libecore_imf${SOLIBS} \ | ||
128 | " | ||
129 | |||
130 | FILES_ecore-file = "\ | ||
131 | ${libdir}/libecore_file${SOLIBS} \ | ||
132 | " | ||
133 | FILES_ecore-con = "\ | ||
134 | ${libdir}/libecore_con${SOLIBS} \ | ||
135 | " | ||
136 | FILES_ecore-ipc = "\ | ||
137 | ${libdir}/libecore_ipc${SOLIBS} \ | ||
138 | " | ||
139 | FILES_ecore-x = "\ | ||
140 | ${libdir}/libecore_x${SOLIBS} \ | ||
141 | " | ||
142 | FILES_ecore-evas = "\ | ||
143 | ${libdir}/libecore_evas${SOLIBS} \ | ||
144 | ${libdir}/ecore-evas/engines/*/*/module.so \ | ||
145 | " | ||
146 | FILES_eio = "\ | ||
147 | ${libdir}/libeio${SOLIBS} \ | ||
148 | " | ||
149 | FILES_eina = "\ | ||
150 | ${libdir}/libeina${SOLIBS} \ | ||
151 | ${bindir}/eina-bench-cmp \ | ||
152 | " | ||
153 | FILES_edje-utils = "\ | ||
154 | ${bindir}/edje_* \ | ||
155 | ${datadir}/edje/include/edje.inc \ | ||
156 | " | ||
157 | FILES_eldbus = "\ | ||
158 | ${libdir}/libeldbus${SOLIBS} \ | ||
159 | " | ||
160 | FILES_eo = "\ | ||
161 | ${libdir}/libeo${SOLIBS} \ | ||
162 | " | ||
163 | FILES_libemotion = "\ | ||
164 | ${libdir}/libemotion${SOLIBS} \ | ||
165 | " | ||
80 | FILES_efreet = " \ | 166 | FILES_efreet = " \ |
167 | ${datadir}/dbus-1/services/*Efreet* \ | ||
81 | ${libdir}/efreet/*/efreet*create \ | 168 | ${libdir}/efreet/*/efreet*create \ |
82 | ${bindir}/efreetd \ | 169 | ${bindir}/efreetd \ |
83 | ${datadir}/efreet \ | 170 | ${datadir}/efreet \ |
84 | " | 171 | " |
85 | FILES_eet = " \ | 172 | FILES_eet = " \ |
86 | ${bindir}/eet \ | 173 | ${bindir}/eet \ |
174 | ${libdir}/libeet${SOLIBS} \ | ||
87 | " | 175 | " |
88 | FILES_emotion = " \ | 176 | FILES_emotion = " \ |
89 | ${datadir}/emotion \ | 177 | ${datadir}/emotion \ |
90 | " | 178 | " |
179 | FILES_embryo-tests = " \ | ||
180 | ${datadir}/embryo/ \ | ||
181 | " | ||
182 | FILES_embryo-utils = " \ | ||
183 | ${binddir}/embryo_* \ | ||
184 | " | ||
91 | FILES_embryo = " \ | 185 | FILES_embryo = " \ |
92 | ${datadir}/embryo \ | 186 | ${libdir}/libembryo${SOLIBS} \ |
93 | " | 187 | " |
94 | FILES_ethumb = " \ | 188 | FILES_ethumb = " \ |
189 | ${datadir}/dbus-1/services/*Ethumb* \ | ||
190 | ${libdir}/libethumb${SOLIBS} \ | ||
191 | ${libdir}/libethumb_client${SOLIBS} \ | ||
95 | ${bindir}/ethumbd \ | 192 | ${bindir}/ethumbd \ |
193 | ${bindir}/ethumbd_client \ | ||
96 | ${bindir}/ethumb \ | 194 | ${bindir}/ethumb \ |
97 | ${libdir}/ethumb/*/*/*/module.so \ | 195 | ${libdir}/ethumb/*/*/*/module.so \ |
98 | ${libdir}/ethumb/*/*/*/*.edj \ | 196 | ${libdir}/ethumb/*/*/*/*.edj \ |
@@ -100,21 +198,27 @@ FILES_ethumb = " \ | |||
100 | ${datadir}/ethumb* \ | 198 | ${datadir}/ethumb* \ |
101 | " | 199 | " |
102 | FILES_ecore = " \ | 200 | FILES_ecore = " \ |
201 | ${libdir}/libecore${SOLIBS} \ | ||
103 | ${libdir}/ecore*/*/*/*/module.so \ | 202 | ${libdir}/ecore*/*/*/*/module.so \ |
104 | ${datadir}/ecore* \ | 203 | ${datadir}/ecore* \ |
105 | " | 204 | " |
106 | FILES_evas = " \ | 205 | FILES_evas = " \ |
206 | ${libdir}/libevas${SOLIBS} \ | ||
107 | ${libdir}/evas*/*/*/*/*/module.so \ | 207 | ${libdir}/evas*/*/*/*/*/module.so \ |
108 | ${libdir}/evas*/*/*/*/*/*.edj \ | 208 | ${libdir}/evas*/*/*/*/*/*.edj \ |
109 | ${libdir}/evas/cserve2/bin/*/evas_cserve2* \ | 209 | ${libdir}/evas/cserve2/bin/*/evas_cserve2* \ |
110 | ${datadir}/evas* \ | 210 | ${datadir}/evas* \ |
211 | ${bindir}/evas_cserve2_* \ | ||
111 | " | 212 | " |
112 | 213 | ||
113 | FILES_eeze = " \ | 214 | FILES_eeze = " \ |
215 | ${libdir}/libeeze${SOLIBS} \ | ||
114 | ${libdir}/eeze*/*/*/*/*/module.so \ | 216 | ${libdir}/eeze*/*/*/*/*/module.so \ |
115 | ${datadir}/eeze \ | 217 | ${datadir}/eeze \ |
218 | ${bindir}/eeze_* \ | ||
116 | " | 219 | " |
117 | FILES_edje = " \ | 220 | FILES_edje = " \ |
221 | ${libdir}/libedje${SOLIBS} \ | ||
118 | ${libdir}/edje*/*/*/*/module.so \ | 222 | ${libdir}/edje*/*/*/*/module.so \ |
119 | ${libdir}/edje/utils/*/epp \ | 223 | ${libdir}/edje/utils/*/epp \ |
120 | ${datadir}/edje \ | 224 | ${datadir}/edje \ |
@@ -141,5 +245,4 @@ FILES_${PN}-dev += " \ | |||
141 | ${datadir}/gdb/auto-load \ | 245 | ${datadir}/gdb/auto-load \ |
142 | ${datadir}/eo/gdb \ | 246 | ${datadir}/eo/gdb \ |
143 | ${bindir}/eldbus-codegen \ | 247 | ${bindir}/eldbus-codegen \ |
144 | ${bindir}/eina-bench-cmp \ | ||
145 | " | 248 | " |