summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-12 15:13:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:16 +0100
commit5e7476166cb22fc1a34754451c5cc52bf036271f (patch)
tree8d8cf5b85923510267aee78a25ee812c258d282e /meta-efl/recipes-efl
parent98791cfc79739e58c6ce91adb7988b7bb2eaafd9 (diff)
downloadmeta-openembedded-5e7476166cb22fc1a34754451c5cc52bf036271f.tar.gz
webkit-efl: Add recipe with snapshot from r159807
* announcement: http://sourceforge.net/mailarchive/message.php?msg_id=31742684 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl')
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/0001-ButterflyInlines.h-remove-indexingHeader-preCapacity.patch27
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch29
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl/gcc-4.8.2.fix.patch15
-rw-r--r--meta-efl/recipes-efl/webkit/webkit-efl_2.3.2+svnr159807.bb48
4 files changed, 119 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0001-ButterflyInlines.h-remove-indexingHeader-preCapacity.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0001-ButterflyInlines.h-remove-indexingHeader-preCapacity.patch
new file mode 100644
index 000000000..003a1d17a
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/0001-ButterflyInlines.h-remove-indexingHeader-preCapacity.patch
@@ -0,0 +1,27 @@
1From 5b9bbf9c056e3690e2872cc74a8962ec6a21a020 Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Mon, 13 Jan 2014 19:00:46 +0100
4Subject: [PATCH] ButterflyInlines.h: remove
5 !indexingHeader()->preCapacity(oldStructure)
6
7Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
8---
9 Source/JavaScriptCore/runtime/ButterflyInlines.h | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/Source/JavaScriptCore/runtime/ButterflyInlines.h b/Source/JavaScriptCore/runtime/ButterflyInlines.h
13index f5439bb..d5c828f 100644
14--- a/Source/JavaScriptCore/runtime/ButterflyInlines.h
15+++ b/Source/JavaScriptCore/runtime/ButterflyInlines.h
16@@ -128,7 +128,7 @@ inline Butterfly* Butterfly::growArrayRight(
17 bool hadIndexingHeader, size_t oldIndexingPayloadSizeInBytes,
18 size_t newIndexingPayloadSizeInBytes)
19 {
20- ASSERT_UNUSED(oldStructure, !indexingHeader()->preCapacity(oldStructure));
21+// ASSERT_UNUSED(oldStructure, !indexingHeader()->preCapacity(oldStructure));
22 ASSERT_UNUSED(oldStructure, hadIndexingHeader == oldStructure->hasIndexingHeader(intendedOwner));
23 void* theBase = base(0, propertyCapacity);
24 size_t oldSize = totalSize(0, propertyCapacity, hadIndexingHeader, oldIndexingPayloadSizeInBytes);
25--
261.8.5.2
27
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch b/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch
new file mode 100644
index 000000000..5df0f8ad0
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch
@@ -0,0 +1,29 @@
1From bfabbcab5dc4fe29bc91bbfbd9c9a404a3e2538b Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Mon, 13 Jan 2014 17:21:25 +0100
4Subject: [PATCH] WebKitHelpers.cmake: Add -Wno-error=cast-align
5
6Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
7---
8 Source/cmake/WebKitHelpers.cmake | 3 ++-
9 1 file changed, 2 insertions(+), 1 deletion(-)
10
11diff --git a/Source/cmake/WebKitHelpers.cmake b/Source/cmake/WebKitHelpers.cmake
12index 1e51ebc..d813117 100644
13--- a/Source/cmake/WebKitHelpers.cmake
14+++ b/Source/cmake/WebKitHelpers.cmake
15@@ -42,7 +42,10 @@ macro(WEBKIT_SET_EXTRA_COMPILER_FLAGS _target)
16
17 # Enable errors on warning
18 if (OPTION_ENABLE_WERROR)
19- set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter ${OLD_COMPILE_FLAGS}")
20+ # /OE/build/shr-core/tmp-eglibc/work/x86_64-oe-linux/webkit-efl/2.3.2+svnr159807-r0/webkit-efl/Source/WebCore/platform/graphics/GlyphPage.h: In member function 'void WebCore::OpenTypeVerticalData::substituteWithVerticalGlyphs(const WebCore::SimpleFontData*, WebCore::GlyphPage*, unsigned int, unsigned int) const': /OE/build/shr-core/tmp-eglibc/work/x86_64-oe-linux/webkit-efl/2.3.2+svnr159807-r0/webkit-efl/Source/WebCore/platform/graphics/GlyphPage.h:120:30: error: array subscript is above array bounds [-Werror=array-bounds]
21+ # | /OE/build/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/include/libsoup-2.4/libsoup/soup-proxy-uri-resolver.h:13:50: error: 'GType soup_proxy_uri_resolver_get_type()' is deprecated (declared at /OE/build/shr-core/tmp-eglibc/sysroots/qemux86-64/usr/include/libsoup-2.4/libsoup/soup-proxy-uri-resolver.h:48) [-Werror=deprecated-declarations]
22+ # | /OE/build/shr-core/tmp-eglibc/work/cortexa8-vfp-neon-oe-linux-gnueabi/webkit-efl/2.3.2+svnr159807-r0/webkit-efl/Source/JavaScriptCore/runtime/JSDataViewPrototype.cpp:120:133: error: cast from 'uint8_t* {aka unsigned char*}' to 'JSC::IntegralTypedArrayAdaptor<short int, JSC::GenericTypedArrayView<JSC::Int16Adaptor>, JSC::JSGenericTypedArrayView<JSC::Int16Adaptor>, (JSC::TypedArrayType)4u>::Type* {aka short int*}' increases required alignment of target type [-Werror=cast-align]
23+ set(OLD_COMPILE_FLAGS "-Werror -Wno-error=unused-parameter -Wno-error=array-bounds -Wno-error=deprecated-declarations -Wno-error=cast-align ${OLD_COMPILE_FLAGS}")
24 endif ()
25
26 # Disable C++0x compat warnings for GCC >= 4.6.0 until we build
27--
281.8.5.2
29
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl/gcc-4.8.2.fix.patch b/meta-efl/recipes-efl/webkit/webkit-efl/gcc-4.8.2.fix.patch
new file mode 100644
index 000000000..635c1cb1f
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl/gcc-4.8.2.fix.patch
@@ -0,0 +1,15 @@
1Upstream-Status: Backport http://trac.webkit.org/changeset/160834
2
3Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
4
5Index: a/Source/WTF/wtf/dtoa/double-conversion.cc
6===================================================================
7--- a/Source/WTF/wtf/dtoa/double-conversion.cc (revision 160833)
8+++ b/Source/WTF/wtf/dtoa/double-conversion.cc (revision 160834)
9@@ -447,5 +447,5 @@
10 const int kBufferSize = kMaxSignificantDigits + 10;
11 char buffer[kBufferSize]; // NOLINT: size is known at compile time.
12- int buffer_pos = 0;
13+ unsigned buffer_pos = 0;
14
15 // Exponent will be adjusted if insignificant digits of the integer part
diff --git a/meta-efl/recipes-efl/webkit/webkit-efl_2.3.2+svnr159807.bb b/meta-efl/recipes-efl/webkit/webkit-efl_2.3.2+svnr159807.bb
new file mode 100644
index 000000000..879ff1f23
--- /dev/null
+++ b/meta-efl/recipes-efl/webkit/webkit-efl_2.3.2+svnr159807.bb
@@ -0,0 +1,48 @@
1DESCRIPTION = "Webkit browser engine, EFL edition"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Source/WebKit/LICENSE;md5=4646f90082c40bcf298c285f8bab0b12 \
4 file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
5 file://Source/WebKit/efl/ewk/EWebKit.h;endline=20;md5=55ea170b1582797d2c69712de850f2fa \
6"
7
8# you need harfbuzz with icu enabled, you can add this to your config:
9# PACKAGECONFIG_append_pn-harfbuzz = " icu"
10DEPENDS = "icu libxslt sqlite3 gperf-native bison-native flex-native jpeg \
11 libpng libxt fontconfig cairo freetype glib-2.0 libsoup-2.4 \
12 libxml2 pango eina ecore evas edje eldbus harfbuzz enchant \
13 ruby-native"
14
15SRC_URI = "\
16 ${E_RELEASES}/libs/webkit-efl/webkit-efl-159807.tar.xz \
17 file://gcc-4.8.2.fix.patch \
18 file://0001-WebKitHelpers.cmake-Add-Wno-error-cast-align.patch \
19 file://0001-ButterflyInlines.h-remove-indexingHeader-preCapacity.patch \
20"
21SRC_URI[md5sum] = "3e1377d976460dd14db0dd3cd39b8e48"
22SRC_URI[sha256sum] = "a99531299e41ba4671b32bbf46c3efc4d65960c9c87949a87f76e622c284f178"
23
24S = "${WORKDIR}/${BPN}"
25
26inherit cmake lib_package pkgconfig perlnative pythonnative
27
28ARM_INSTRUCTION_SET = "arm"
29
30EXTRA_OECMAKE = " \
31 -DPORT=Efl \
32 -DSHARED_CORE=On \
33 -DENABLE_DRAG_SUPPORT=On \
34 -DENABLE_WEB_AUDIO=Off \
35 -DENABLE_VIDEO=Off \
36 -DENABLE_VIDEO_TRACK=Off \
37 -DENABLE_ACCESSIBILITY=Off \
38 -DENABLE_BATTERY_STATUS=Off \
39"
40
41LEAD_SONAME = "libewebkit.so"
42PACKAGES =+ "${PN}launcher-dbg ${PN}launcher ${PN}-inspector"
43
44FILES_${PN} += "${datadir}/webkit-1.0/theme/default.edj ${datadir}/ewebkit-0/themes/default.edj"
45FILES_${PN}-dev += "${libdir}/cmake"
46FILES_${PN}launcher = "${bindir}/EWebLauncher"
47FILES_${PN}launcher-dbg = "${bindir}/.debug/EWebLauncher"
48FILES_${PN}-inspector += "${datadir}/ewebkit-0/inspector"