summaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-16 21:39:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-18 17:35:17 +0100
commitd0d3977290c706f4b71d1a3228df889288583c8e (patch)
tree529901df25eba3d10f852f0f81ffb8957a7c6211 /meta-efl/recipes-efl/efl
parenta140e9a352a2ce801281b5cdee57780f69594dfb (diff)
downloadmeta-openembedded-d0d3977290c706f4b71d1a3228df889288583c8e.tar.gz
azy: rename lemon provided by azy-native to azy_lemon
* meta-openembedded/meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb provides almost the same lemon but lemon.c in azy sources is a bit modified (and completely reformatted :/) * rename it to resolve: WARNING: The recipe azy-native is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/lemon Matched in manifest-x86_64-lemon-native Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-efl/efl')
-rw-r--r--meta-efl/recipes-efl/efl/azy_svn.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-efl/recipes-efl/efl/azy_svn.bb b/meta-efl/recipes-efl/efl/azy_svn.bb
index 43f9b7df9..80821964c 100644
--- a/meta-efl/recipes-efl/efl/azy_svn.bb
+++ b/meta-efl/recipes-efl/efl/azy_svn.bb
@@ -5,7 +5,7 @@ LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" 5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6 6
7PV = "1.0.0+svnr${SRCPV}" 7PV = "1.0.0+svnr${SRCPV}"
8PR = "r1" 8PR = "r2"
9 9
10SRCREV = "${EFL_SRCREV}" 10SRCREV = "${EFL_SRCREV}"
11 11
@@ -15,14 +15,14 @@ BBCLASSEXTEND = "native"
15EXTRA_OECONF += " --disable-mysql-tests" 15EXTRA_OECONF += " --disable-mysql-tests"
16 16
17do_configure_prepend_class-target() { 17do_configure_prepend_class-target() {
18 sed -i "s#\./lemon#${STAGING_BINDIR_NATIVE}/lemon#g" ${S}/src/bin/Makefile.am 18 sed -i "s#\./lemon#${STAGING_BINDIR_NATIVE}/azy_lemon#g" ${S}/src/bin/Makefile.am
19 sed -i "s#\$(top_builddir)/src/bin/azy_parser -H -p -o#${STAGING_BINDIR_NATIVE}/azy_parser -H -p -o#g" ${S}/src/tests/Makefile.am 19 sed -i "s#\$(top_builddir)/src/bin/azy_parser -H -p -o#${STAGING_BINDIR_NATIVE}/azy_parser -H -p -o#g" ${S}/src/tests/Makefile.am
20 sed -i "s#\$(top_builddir)/src/bin/azy_parser -eHn -m#${STAGING_BINDIR_NATIVE}/azy_parser -eHn -m#g" ${S}/src/tests/identi.ca/Makefile.am 20 sed -i "s#\$(top_builddir)/src/bin/azy_parser -eHn -m#${STAGING_BINDIR_NATIVE}/azy_parser -eHn -m#g" ${S}/src/tests/identi.ca/Makefile.am
21} 21}
22 22
23do_install_append_class-native() { 23do_install_append_class-native() {
24 install -d ${D}/${bindir} 24 install -d ${D}/${bindir}
25 install -m 0755 ${S}/src/bin/lemon ${D}/${bindir} 25 install -m 0755 ${S}/src/bin/lemon ${D}/${bindir}/azy_lemon
26} 26}
27 27
28inherit efl 28inherit efl